Go Back  R/C Tech Forums > General Forums > Electric Off-Road
Losi 1/10 TEN-SCTE ARR 4x4 Short Course Truck Thread >

Losi 1/10 TEN-SCTE ARR 4x4 Short Course Truck Thread

Like Tree9Likes

Losi 1/10 TEN-SCTE ARR 4x4 Short Course Truck Thread

Old 10-21-2011, 06:51 PM
  #23026  
Tech Elite
iTrader: (29)
 
Factory Seal's Avatar
 
Join Date: Apr 2006
Location: Memphis,TN.
Posts: 3,977
Trader Rating: 29 (100%+)
Default

Originally Posted by Mr.juarez
stop whining about being tight... just put some hair around it, find your "threads" and problem solved!
LMAO!!
Originally Posted by namewasdallas
Mine went on without a hitch, but they were also brand new shock's and i used a dab of shock oil on the collars they were tight and smooth, Just the way I like um
i have the blue aluminum STRC'S.....I have always used a little oil.....We will see whats up when my KIt kets here!....LOL!!
Factory Seal is offline  
Old 10-21-2011, 07:31 PM
  #23027  
Tech Adept
iTrader: (8)
 
Cement head's Avatar
 
Join Date: Aug 2011
Location: The Ocean State
Posts: 166
Trader Rating: 8 (100%+)
Default

Originally Posted by BashemSmashem
If they are so tight they are unusable then that is a pretty big problem .
Yes, this true!!
Cement head is offline  
Old 10-21-2011, 07:36 PM
  #23028  
Tech Adept
iTrader: (8)
 
Cement head's Avatar
 
Join Date: Aug 2011
Location: The Ocean State
Posts: 166
Trader Rating: 8 (100%+)
Default

Originally Posted by BDRMBULLY
Sounds like a classic case of girly fingers. Do some more wrenchen to toughen up them fingers lol break out the vaseline or ky haha. One of mine was tight as well but if you forced it to far with improper threading than id say you screwed em up
First of all my hands are like rough leather mitts from doing concrete work for 15+ years, so that's not the problem. And my plastic collars thread on with out a problem. The collars or shock bodies are not striped.
Cement head is offline  
Old 10-21-2011, 08:03 PM
  #23029  
Tech Adept
iTrader: (13)
 
Join Date: Sep 2011
Posts: 184
Trader Rating: 13 (100%+)
Thumbs down

wow have you guys look a the first page this is thread is getting out off hands .

Is this a viper thread or the official losi ten-scte .

If this is the way viper dose business i will never buy a viper system .
dany5 is offline  
Old 10-21-2011, 08:08 PM
  #23030  
Tech Adept
 
stevepowling's Avatar
 
Join Date: Jul 2011
Location: Barrie, ON
Posts: 194
Default

Oh great, this again.
stevepowling is offline  
Old 10-21-2011, 08:13 PM
  #23031  
Tech Champion
iTrader: (146)
 
RC*PHREAK's Avatar
 
Join Date: Dec 2010
Posts: 5,387
Trader Rating: 146 (100%+)
Default

Originally Posted by dany5
wow have you guys look a the first page this is thread is getting out off hands .

Is this a viper thread or the official losi ten-scte .

If this is the way viper dose business i will never buy a viper system .
i don't think it's "getting out off hands". i rather like the way viper "dose" business.
RC*PHREAK is offline  
Old 10-21-2011, 08:15 PM
  #23032  
Tech Adept
iTrader: (13)
 
Join Date: Sep 2011
Posts: 184
Trader Rating: 13 (100%+)
Default

Originally Posted by RC*PHREAK
i don't think it's "getting out off hands". i rather like the way viper "dose" business.
then lets make this a viper thread.
dany5 is offline  
Old 10-21-2011, 08:17 PM
  #23033  
Tech Master
iTrader: (11)
 
Join Date: Sep 2004
Posts: 1,589
Trader Rating: 11 (100%+)
Default

Originally Posted by kcobra
You have the wires soldered in the wrong direction on the motor. They should be flipped so they are routed above the motor. The way you have them there is the possibility that the weight of the wires will pull the solder tabs away from the support.
I misspoke on the above suggestion. It was in reference to soldering the wires from the rear on the Tekin motors. I got my Pro4 motor today and noticed that Tekin riveted the tabs to the support board. So there should be no issues with the tabs pulling away. Good improvement Tekin.

BTW, pretty weak to post a huge advertisement picture of Viper stuff on the first page. RCTECH really needs wiki capability in threads like most of the hot deal boards now have.
kcobra is offline  
Old 10-21-2011, 08:56 PM
  #23034  
Tech Elite
iTrader: (45)
 
goehm's Avatar
 
Join Date: May 2010
Location: Northern VA
Posts: 2,765
Trader Rating: 45 (100%+)
Default

Originally Posted by Mr.juarez
stop whining about being tight... just put some hair around it, find your "threads" and problem solved!
EPIC!
goehm is offline  
Old 10-21-2011, 09:36 PM
  #23035  
Tech Elite
iTrader: (45)
 
goehm's Avatar
 
Join Date: May 2010
Location: Northern VA
Posts: 2,765
Trader Rating: 45 (100%+)
Default

Originally Posted by dany5
wow have you guys look a the first page this is thread is getting out off hands .

Is this a viper thread or the official losi ten-scte .

If this is the way viper dose business i will never buy a viper system .
Meh, the first post on this thread is no longer an unbiased view on options for the SCTE for electronics, nor is it all inclusive. IE: for chassis options no mention of Bumps, Jammin, etc. That said, I purchased a Bumps chassis and am loving it. I also changed from my Castle MMP to HobbyWing 120A and am pleased as punch. No more glitching, nor any more glitch-busting add-ons. Plus I sold my MMP, bought a HW and still have money left over..

It's no fault of the first poster who had his thread nominated as the 'official' thread because it was the most popular. That post does have the most visibility, however, which is unfortunate since it is not all inclusive. SaladFork has done a lot for the community, but it's clear where his intentions currently lie (Viper employee/sponsored).
goehm is offline  
Old 10-21-2011, 09:44 PM
  #23036  
Tech Addict
iTrader: (22)
 
rcguy76559's Avatar
 
Join Date: Dec 2009
Location: Jarrell tx
Posts: 668
Trader Rating: 22 (100%+)
Default

if you new the whole story u wouldn't say that.
rcguy76559 is offline  
Old 10-21-2011, 10:04 PM
  #23037  
Tech Elite
iTrader: (13)
 
Join Date: May 2006
Posts: 3,557
Trader Rating: 13 (100%+)
Default

Originally Posted by rcguy76559
if you new the whole story u wouldn't say that.
No one person knows the whole story nor can they be unbiased. Please move on from this and get back to the SCTE....thanks!
hacker07 is offline  
Old 10-21-2011, 10:13 PM
  #23038  
Tech Elite
Thread Starter
iTrader: (9)
 
SaladFork's Avatar
 
Join Date: Nov 2009
Location: Earth
Posts: 3,349
Trader Rating: 9 (100%+)
Default

Originally Posted by dany5
wow have you guys look a the first page this is thread is getting out off hands .

Is this a viper thread or the official losi ten-scte .

If this is the way viper dose business i will never buy a viper system .
Dany your 1 month on the forum and under 70 post makes me believe you have one agenda to slam me and Viper. My suggestion to you, do not read the first post, sell your SCTe and leave this thread. The 9 months I have been running this thread it's been up to me to come here DAILY, read every post and update the thread with the info people provided. No one else put all that info there, I did. I also started the thread formatting on RCT, me updating the first page started something here and now look everyone is starting the trend.

Ask how many people in this thread I have sent free SCTe parts to when Losi was sold out, I even paid for the shipping. I never asked for anything in return. Ask Seabass from OCRC who got him back up and running after his trucks where stolen. I donated my 1410 and a $225.00 ESC, paid for shipping and asked for nothing in return. WTF have you done?

I am also a paid advertiser on this website, I deal with Internet Brands on a monthly basis. I also am a paid member here as a Tech Elite. I have done MORE THAN MY SHARE to help support this site and it's members and have never asked for anything in return.

The guys I see with sand in their vaginas are new to this thread, have not seen the work that has gone into it. If you don't like me, then leave this thread because I am not. I will not be run out of my own thread which I have worked my ass off to help grow.

Originally Posted by goehm
Meh, the first post on this thread is no longer an unbiased view on options for the SCTE for electronics, nor is it all inclusive. IE: for chassis options no mention of Bumps, Jammin, etc. That said, I purchased a Bumps chassis and am loving it. I also changed from my Castle MMP to HobbyWing 120A and am pleased as punch. No more glitching, nor any more glitch-busting add-ons. Plus I sold my MMP, bought a HW and still have money left over..

It's no fault of the first poster who had his thread nominated as the 'official' thread because it was the most popular. That post does have the most visibility, however, which is unfortunate since it is not all inclusive. SaladFork has done a lot for the community, but it's clear where his intentions currently lie (Viper employee/sponsored).
Exactly what I would expect from an adult, someone who can make their own discussions and doesn't rely on anyone else to help form their opinion. And you are right, I had no choice about making the thread official, as I mentioned I woke up and the name was changed. Thanks Go!

It's really easy if this thread bugs anyone, don't come in here. Go start your own thread and put the work I have into it and maybe it will take off if you hand hold it long enough. The you have the option of what you want to add in your first post.

Anyone else has an issue with it, see my avatar.
SaladFork is offline  
Old 10-21-2011, 10:19 PM
  #23039  
Tech Adept
iTrader: (8)
 
Cement head's Avatar
 
Join Date: Aug 2011
Location: The Ocean State
Posts: 166
Trader Rating: 8 (100%+)
Default

Originally Posted by StPete40
Careful with the pliers. Once that aluminum starts to give its toast. I tried putting my collars on and gave up the first time. Ran the shock bodies through the ultrasonic parts cleaner and it made all the difference. The threads on the bodies looked clean, but they were sticking like crazy.
Where do I get an ultrasonic parts cleaner? Sounds like I need one of these in my garage! Lol
Cement head is offline  
Old 10-21-2011, 10:21 PM
  #23040  
Tech Elite
Thread Starter
iTrader: (9)
 
SaladFork's Avatar
 
Join Date: Nov 2009
Location: Earth
Posts: 3,349
Trader Rating: 9 (100%+)
Default

Originally Posted by Cement head
Where do I get an ultrasonic parts cleaner? Sounds like I need one of these in my garage! Lol
Youtube has some great videos on how to make them for under 10 bucks.
SaladFork is offline  

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Your Privacy Choices -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.