R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Reply
 
Thread Tools Search this Thread
Old 01-09-2011, 09:12 PM   #1
Tech Adept
 
Join Date: Jan 2008
Posts: 165
Trader Rating: 9 (100%+)
Default T4 Steering Arm Problem

I have broken the servo arm to my T4 twice in a matter of one day and was wondering if there was a better one out there or a solution to my problem. Ok, besides the obvious one of not wrecking Btw, it is a Factory Team T4, not 4.1. Thanks guys!
843rcguy is offline   Reply With Quote
Old 01-09-2011, 09:37 PM   #2
Tech Elite
 
kman16jr's Avatar
 
Join Date: May 2010
Location: Tampa,Fl.
Posts: 4,005
Trader Rating: 53 (100%+)
Default

Quote:
Originally Posted by 843rcguy View Post
I have broken the servo arm to my T4 twice in a matter of one day and was wondering if there was a better one out there or a solution to my problem. Ok, besides the obvious one of not wrecking Btw, it is a Factory Team T4, not 4.1. Thanks guys!
How are you driving it too break servo horns?I had one for over a year without breaking a servo horn.To be honest i think the only answer to this question is too clean up your driving(Not saying your a bad driver)
__________________
Kevin Welfley
AE rc8b3-AE rc8b3e-AE b64d-AE b6d-AE b6
Sponsors:|DDHrc|Team Trinity|Jconcepts|Rc Adiction Products|NitroPro Fuel|M2c racing|Ultimate racing engines|Highest servos|Bellgate Distibutors|
kman16jr is offline   Reply With Quote
Old 01-09-2011, 09:40 PM   #3
Tech Addict
 
rcjoe99's Avatar
 
Join Date: Nov 2010
Location: Huntington Beach
Posts: 525
Default

make sure u have the right one for your brand of servo and make sure u have a screw in the top of it i forgot to put mine in and it popped thank god it did not break
__________________
***LOSI XXX-SCT CR* *TEAM ASSOCIATED FT T4.1* *TEAM ASSOCIATED B4.1***
********************OC/RC RACEWAY*****************************
**********************GET SOME********************************
rcjoe99 is offline   Reply With Quote
Old 01-09-2011, 10:01 PM   #4
Tech Champion
 
BuggyKing's Avatar
 
Join Date: Oct 2006
Location: Huntington Beach, Ca
Posts: 7,919
Trader Rating: 17 (100%+)
Default

Are you using the stronger servo horns. The old ones broke easier then the new ones.
__________________
Our government is a #$%$ joke, from the head jester on down
RIP Mike M
BuggyKing is offline   Reply With Quote
Old 01-10-2011, 09:26 AM   #5
Tech Adept
 
Join Date: Sep 2010
Location: Tacoma, Wa
Posts: 105
Default

Are you saying that you broke two servo horns in one day? I would be surprised because the servo saver should be the weak spot. I broke two servo savers within 20 minutes of track time, but haven't broken one since, (Shouldn't have said it, Now I'm doomed)
Make sure that you have the saver coupling lubed and maybe leave the nut 1/2 turn from seated.
Big Vic is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
RC10B4/T4 Forum DerekL Electric Off-Road 14339 12-13-2017 11:20 PM
QCRCCC OFF-ROAD RACING emer Manila Racers 16543 04-08-2016 01:31 AM
T4 Front Right A Arm Breaking mcsully Electric Off-Road 33 07-28-2009 04:30 PM
T4 Owners Post Here! StepPins Electric Off-Road 338 06-10-2004 09:09 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 09:49 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net