My new SC8E

Reply

Old 11-30-2010, 07:40 PM
  #1  
Tech Adept
Thread Starter
 
djtroy's Avatar
 
Join Date: Apr 2010
Posts: 198
Default My new SC8E

Well I took it out of the box and wanted to take it for a quick spin around the yard before I brought it inside to make sure everything was snug. Bad mistake within the first 2 minutes of running it on my driveway three of the tires came unglued on the inside and one of the foams came flying out of the tire. When I brought it inside three of the 4 wheel nuts were barely hanging on. I guess for all you guys buying RTRs from Associated make sure you don't give in to temptation and check the truck first because its really not RTR. Its more of an ARTR. Almost ready to run.
djtroy is offline  
Reply With Quote
Old 11-30-2010, 07:50 PM
  #2  
Tech Regular
iTrader: (36)
 
marvinbeaverdip's Avatar
 
Join Date: Oct 2010
Location: Rochester MN
Posts: 491
Trader Rating: 36 (100%+)
Default

This could apply to ALL things 1/8 scale RTR.. my ravager nitro did the same thing.. ya look pretty stupid when you show off to the neighbors and your wheels spin off.
marvinbeaverdip is offline  
Reply With Quote
Old 11-30-2010, 08:16 PM
  #3  
Tech Champion
iTrader: (17)
 
BuggyKing's Avatar
 
Join Date: Oct 2006
Location: Huntington Beach, Ca
Posts: 7,919
Trader Rating: 17 (100%+)
Default

Thats sucks. I never have trusted premounted tires, especially on a n 1/8th scale because of the the amount of tq they put out. Just reglue them and you be ready to go.
BuggyKing is offline  
Reply With Quote
Old 12-01-2010, 10:21 PM
  #4  
Tech Adept
Thread Starter
 
djtroy's Avatar
 
Join Date: Apr 2010
Posts: 198
Default

Ya I was really embarrassed. I was like this thing survives the 24hr torure test and boom the wheels fall off. I reglued them and they seem fine now.
djtroy is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service