Go Back  R/C Tech Forums > General Forums > Electric Off-Road
Tekin RX8: Has yours been reliable? >

Tekin RX8: Has yours been reliable?

Tekin RX8: Has yours been reliable?

Reply

Old 11-05-2010, 02:23 PM
  #46  
Tech Adept
 
Join Date: Jan 2010
Location: Helsingborg, Sweden
Posts: 103
Default

Is this the new version with less trouble?

I want a kit for my RC8Be. Is the 1900kv best for buggys?

Also planning on getting a RC8Te. What motor is recommended for truggys?

Thanks!
Limpan is offline  
Reply With Quote
Old 11-05-2010, 03:12 PM
  #47  
Team Tekin
 
TY@TEAMTEKIN's Avatar
 
Join Date: Mar 2006
Location: Tekin
Posts: 2,462
Default

Originally Posted by thriller View Post
my rx8 lasted about 7 weeks. It was the 4 hole. I live up in Canada but am about 3hrs away from the Idaho border. I arranged to have it shipped back to an Idaho shipping address so I could just pick it up and save the 2 week delay through customs. I was told 4 times it would be no problem. I took the day off work cancelled my other weekend plans and made the trip because we don't have much season left and I don't have a spare. Now I am here with my truck, all spare parts, laptop and find out that they shipped it to the Canadian address instead of the Idaho address. 2 thumbs down for a product that does not last 2 months, 2 thumbs down for customer service in regards to the shipping.
Did you put your Idaho or Canadian address on the service form? If you put the Canadian address, I'm not surprised that's where it shipped since they are trained to ship them that way.

You also had an old spec unit so you really aren't giving it a fair shot at all.
TY@TEAMTEKIN is offline  
Reply With Quote
Old 11-05-2010, 03:18 PM
  #48  
Tech Elite
iTrader: (60)
 
smokinu's Avatar
 
Join Date: Apr 2008
Location: MODESTO CA
Posts: 4,865
Trader Rating: 60 (98%+)
Default

Originally Posted by Limpan View Post
Is this the new version with less trouble?

I want a kit for my RC8Be. Is the 1900kv best for buggys?

Also planning on getting a RC8Te. What motor is recommended for truggys?

Thanks!
i like the 1900 in my ve8

and really loved the 2000kv in truggy.

both on 4s.
smokinu is offline  
Reply With Quote
Old 11-05-2010, 03:20 PM
  #49  
Tech Addict
 
Join Date: Nov 2009
Posts: 581
Default

1 x RX8
2 x RS-pro
1x RS

I love em
pirape is offline  
Reply With Quote
Old 11-05-2010, 03:47 PM
  #50  
Tech Addict
 
CJ Weaver's Avatar
 
Join Date: May 2009
Location: Pittsburgh, PA
Posts: 611
Default

Originally Posted by tq_danpatterson View Post
So, if you have used a Tekin RX8, please post the following information:
-Which version it is, including which motor
-When you got it/how long you've been using it
-The setup in which you used it (include car, voltage, gearing, and intensity of running; IE, bashing or hard racing)
-Any problems you have had with it
-Your experience with Tekin's repair service if you had to send it in
-Tekin RX8 with 2.12 Software and 1900KV Motor

-15 Months Ago - ran for 8 months or so without a problem before I sent it in to get an updated one from Tekin. Then ran my current one for 7 more months and still haven't had any problems.

-Xray 808e, 16/42 Gearing, I drive mine extremely hard

-None

-Top of the line, Tekin will do everything they can to get you a new or repaired product in the shortest amount of time for the lowest cost (free if it's under warranty)

A few people at the local tracks around me say they blow up all the time, but then I saw what they were doing with them. If you take care of your equipment and know what you're doing, this will be the best system for you!
CJ Weaver is offline  
Reply With Quote
Old 11-05-2010, 04:02 PM
  #51  
Tech Master
iTrader: (4)
 
Jim Hustins's Avatar
 
Join Date: Jun 2009
Location: Middletown, NY
Posts: 1,658
Trader Rating: 4 (100%+)
Default

I have run my RX8 T8 1900kv on 4s for a year now in my SC8e with out a single problem. I love the system.
Jim Hustins is offline  
Reply With Quote
Old 08-25-2012, 10:28 PM
  #52  
Tech Fanatic
iTrader: (30)
 
BEAR5OH's Avatar
 
Join Date: May 2009
Location: Redondo Beach, CA
Posts: 944
Trader Rating: 30 (100%+)
Default

It's been a couple of years, Dan. So....what's the sit rep? How's the Tekin stuff been for you after almost 2 years?

B.
BEAR5OH is offline  
Reply With Quote
Old 08-25-2012, 11:21 PM
  #53  
Tech Elite
iTrader: (27)
 
BLbound's Avatar
 
Join Date: Feb 2009
Location: In the LE, SoCal
Posts: 2,288
Trader Rating: 27 (100%+)
Default

I've been running electric 1/8 since they've been around and I started with the castle esc's seeing as they were the most reliable in the beginning. About 8 months ago I dove in and bought a rx8, & it's been nothing but great for me so far. I'm certain now that Tekin has worked out the bugs that were in the first units years ago, coupled with excellent customer service, it's a great esc.
BLbound is offline  
Reply With Quote
Old 08-26-2012, 01:28 AM
  #54  
Tech Adept
iTrader: (1)
 
79kmc's Avatar
 
Join Date: Feb 2012
Location: Gold Coast,australia
Posts: 149
Trader Rating: 1 (100%+)
Default

I've been running my RX8 for over 2 years now without a problem,I've gone through a few fans that's about it
79kmc is offline  
Reply With Quote
Old 08-26-2012, 07:04 AM
  #55  
Moderator
iTrader: (11)
 
Deja Vu's Avatar
 
Join Date: Apr 2012
Location: Omaha, Ne
Posts: 1,015
Trader Rating: 11 (100%+)
Default

For the most part, I run Novak equipment. But when it came to my Pro-4 truck, the Tekin RX8 seemed to be the best choice and I chose the Tekin RS for my F104 car due to the limited space available. Both ESCs have performed flawlessly time after time. The RX8 sees a ton of abuse in the truck, but its never given me any trouble. If either ESC ever did require replacement, I'd put the same equipment back in.
Deja Vu is offline  
Reply With Quote
Old 08-26-2012, 07:59 AM
  #56  
Tech Master
iTrader: (43)
 
bronc4now's Avatar
 
Join Date: May 2011
Location: Hoffman Estates,IL
Posts: 1,480
Trader Rating: 43 (100%+)
Default

3 rx8 one is almost 2 years old

No issues !

And so many more tekin esc 's that have been good to me ..tekin rebel my 1st one about 18 years ago
bronc4now is offline  
Reply With Quote
Old 08-26-2012, 08:58 AM
  #57  
Tech Elite
iTrader: (13)
 
Lonestar's Avatar
 
Join Date: Oct 2001
Location: Switzerland
Posts: 2,388
Trader Rating: 13 (100%+)
Default

Originally Posted by bronc4now View Post
..tekin rebel my 1st one about 18 years ago
totally irrelevant...esp as it isnt the same crew from 25 yrs ago...
Lonestar is offline  
Reply With Quote
Old 08-26-2012, 06:31 PM
  #58  
Tech Champion
iTrader: (100)
 
thecman26's Avatar
 
Join Date: Jul 2006
Location: South Central Kansas
Posts: 7,813
Trader Rating: 100 (100%+)
Default

Have 2 years on my RX8 so far and its still going strong!

Only issue, I had a fan go out on me, thats it.
thecman26 is offline  
Reply With Quote
Old 08-26-2012, 09:44 PM
  #59  
Tech Fanatic
iTrader: (30)
 
BEAR5OH's Avatar
 
Join Date: May 2009
Location: Redondo Beach, CA
Posts: 944
Trader Rating: 30 (100%+)
Default

For the record:

I love all my Tekin stuff. Customer service is wonderful and they were all super nice folks at the RCX this year. I had millions of dumb and not so dumb questions and they were happy to answer them all. Tekin FTW.

All that being said, i'm currently looking to get a pair of RS speed controls to replace my two MMP speed controls. I've got an RX8 in Losi SCTE and never had a hiccup. Tuning is so easy with or without the Hotwire interface. I typically run on the default settings with very little tweaking. If memory serves, the settings are a hair less current output to the motor, a hair more on the timing, one or two other little tiny changes. Mainly to keep my motor (a 4000kv 4-pole Tekin) temps on the low side, I don't like getting it too hot even if i'm not going over the temp threshold. I used to run my Tekin to a Novak Ballistic 4.5T (550 sized) motor with the upgraded 14mm rotor. Ran like a beast but runs even better on the Tekin motor.

I recommend Tekin products any day of the week and twice on sunday.

B.
BEAR5OH is offline  
Reply With Quote
Old 08-26-2012, 09:54 PM
  #60  
Tech Elite
iTrader: (18)
 
Join Date: Dec 2011
Location: Texas
Posts: 3,294
Trader Rating: 18 (100%+)
Default

I have two three hole RX8s. One about a year old in various 1/8 buggies I've had. The other is in a Losi SCTE that gets an average of 10 packs a weekend run though it between practice and racing. I have never had any issues with either one. The only issue I have ever had with a Tekin product was a 4000kv Pro4 that has the magnets explode off the rotor.
MX304 is offline  
Reply With Quote

Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service