R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Reply
 
Thread Tools Search this Thread
Old 10-16-2010, 07:28 PM   #1
Tech Regular
 
Doxiedad's Avatar
 
Join Date: Sep 2009
Posts: 485
Trader Rating: 29 (100%+)
Default Servo causing glitches?

Ran my XB808-E (nitro conversion) for the first time today. Ran into a problem where the esc and steering would keep cutting out on me. I would lose steering and throttle for a sec, then it would come back.

I put the buggy on the table and while running the wheels left and right I would see the light on the rx go out, then come back on.

I have a MMM with Castle 2200KV, Running 2x2s 5000mah 50C Losi Lipos, Spektrum SR3500 micro rx, and Spektrum S6030 steering servo.

I could hold the buggy up and give it all kinds of throttle and no problems, only with the servo.

I'm still fairly new to trouble shooting, but does this sound like the problem?

Tomorrow I'll get a video of it doing it on youtube.

Thanks.
__________________
Slash 2wd/Slash 4X4/DX3S
Doxiedad is offline   Reply With Quote
Old 10-16-2010, 07:53 PM   #2
Tech Fanatic
 
Join Date: Mar 2010
Location: Portland, OR
Posts: 824
Trader Rating: 12 (100%+)
Default

Your answer is here... You need a $10 part and your problem is solved =)

http://www.rctech.net/forum/electric...s-problem.html
Dgee is offline   Reply With Quote
Old 10-16-2010, 08:01 PM   #3
Tech Regular
 
Doxiedad's Avatar
 
Join Date: Sep 2009
Posts: 485
Trader Rating: 29 (100%+)
Default

Awesome, thanks for the help !!!!
__________________
Slash 2wd/Slash 4X4/DX3S
Doxiedad is offline   Reply With Quote
Old 01-09-2011, 02:16 AM   #4
Tech Fanatic
 
Join Date: Feb 2007
Posts: 925
Trader Rating: 6 (100%+)
Default

hey same happening with my car.

i try a diff servo and it works fine?

did u find the cap helped?
__________________
TEAM DURANGO CARBON DEX210 - POWERED BY TEKIN RS GEN2/TEKIN GEN2 17.5
TEAM DURANGO CARBON DEX410 - POWERED BY TEKIN RS PRO/REEDY SONIC 17.5
TEAM ASSOCIATED B5 - POWERED BY TEKIN RS GEN2/TEKIN GEN2 17.5
LiL_JaSoN is offline   Reply With Quote
Old 01-09-2011, 04:35 AM   #5
Tech Elite
 
Dlewis4's Avatar
R/C Tech Elite Subscriber
 
Join Date: Feb 2010
Location: Saint Joseph, MO
Posts: 4,758
Trader Rating: 148 (100%+)
Default

The cap will solve all of your issues. P
It's a known problem
__________________
Why is this hobby so full of drama? Its toy cars....
Dlewis4 is offline   Reply With Quote
Old 01-09-2011, 06:42 AM   #6
Tech Champion
 
Trevor Williams's Avatar
R/C Tech Elite Subscriber
 
Join Date: Feb 2009
Location: Illinois
Posts: 8,227
Trader Rating: 195 (100%+)
Default

I run external Spektrum caps and my problem went away.....The servo is attempting to draw too much power
__________________
RC10-B6d | RC10-B64d
SmacTrac
#WeAreAE #ReedyPower #AE4Life
Trevor Williams is offline   Reply With Quote
Old 01-10-2011, 09:58 PM   #7
Tech Addict
 
Join Date: Oct 2007
Posts: 667
Trader Rating: 7 (100%+)
Default

The problem is that the bec current and voltage settings in the esc are set to low. A cap may solve temporary. Another way to Fix this is to use a rx battery pack. When u pull triger it sucks power from rx this is due to Bec settings
__________________
Speedpassion USA Team Driver
Schumacher USA Team Driver
Lucky 13 rc graphics
Remember this..... Heaven and Hell are really not places, just your state of mind.
JdogL is offline   Reply With Quote
Old 01-10-2011, 11:13 PM   #8
Tech Master
 
KingdomRacer's Avatar
 
Join Date: Feb 2010
Location: PA
Posts: 1,483
Trader Rating: 5 (100%+)
Default

Also, make sure your steering EPA is adjusted correctly.
An improper end point for digital servos can stress the servo causing a higher draw in amps.
You'd be surprised how fine most of these servos can work with no extra help.
The cap does and can help if the steering EPA is correctly set.
It is of course another story with HV servos.
__________________
JESUS says, "Fix it B4 it Breaks, 'cuz a DNF is a SIN".

Alpha-RC.com/RcRenew.com/TritonRC.com
VPProUSA.com/UpGrade-RC.com/KalGard.com
Green-Gorilla.com
KingdomRacer is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
RC10B4/T4 Forum DerekL Electric Off-Road 14339 12-13-2017 11:20 PM
Glitches on Servo NOVICE4EVER Singapore R/C Racers 10 12-04-2007 09:24 AM
Can a servo cause a glitch? Iceracer Electric Off-Road 10 04-04-2006 02:07 PM
servo help!!!! ALBERTO Electric On-Road 19 09-18-2004 10:06 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 11:48 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net