Go Back  R/C Tech Forums > General Forums > Electric Off-Road
Novak Ballistic 4.5 or Castle Creations 5700 3.5 >

Novak Ballistic 4.5 or Castle Creations 5700 3.5

Novak Ballistic 4.5 or Castle Creations 5700 3.5

Reply

Old 08-01-2010, 07:24 PM
  #1  
Tech Apprentice
Thread Starter
iTrader: (10)
 
mopargreg's Avatar
 
Join Date: Jan 2010
Location: Sunshine State
Posts: 76
Trader Rating: 10 (100%+)
Default Novak Ballistic 4.5 or Castle Creations 5700 3.5

I have a Ofna Hyper 10sc with a Mamba Max ESC, which one of these motors would be my best choice running on 2s lipo's? Run on a clay track with lots of turns & jumps....Thanks...
mopargreg is offline  
Reply With Quote
Old 08-01-2010, 07:42 PM
  #2  
Tech Regular
iTrader: (3)
 
bschanz's Avatar
 
Join Date: May 2009
Posts: 447
Trader Rating: 3 (100%+)
Default

from what i have heard, the castle 5700 is more along the lines of an 8.5T. I have the castle in a 4wd electric buggy and it gets a little hot sometimes here in south florida. I have the timing at neutral and am running pretty conservative gearing but i have vented the body and got temps down to an acceptable level. That motor has plenty of stink in it and has not given me any trouble on a 2s 5000mah lipo. i am a fan of keeping brands together and have never run the ballistic motors so i cannot give you an opinion on it. I like my CC 5700.
bschanz is offline  
Reply With Quote
Old 08-01-2010, 08:14 PM
  #3  
Tech Master
iTrader: (7)
 
brickshouse's Avatar
 
Join Date: Feb 2009
Posts: 1,246
Trader Rating: 7 (100%+)
Default

Originally Posted by mopargreg View Post
I have a Ofna Hyper 10sc with a Mamba Max ESC, which one of these motors would be my best choice running on 2s lipo's? Run on a clay track with lots of turns & jumps....Thanks...
a 3.5 or 4.5 is way too much motor for anything offroad, i think a 8.5 is about max you would want for a sc.
brickshouse is offline  
Reply With Quote
Old 08-01-2010, 08:23 PM
  #4  
Tech Master
iTrader: (7)
 
MooseDrool's Avatar
 
Join Date: Nov 2008
Location: STL MO
Posts: 1,259
Trader Rating: 7 (89%+)
Default

the 550 sized motors are rated different. a 4.5t 550 is like an 8.5t 540
MooseDrool is offline  
Reply With Quote
Old 08-01-2010, 08:40 PM
  #5  
Tech Champion
iTrader: (14)
 
jmackani's Avatar
 
Join Date: May 2009
Location: Shippensburg
Posts: 5,672
Trader Rating: 14 (100%+)
Default

The 5700 will eat batteries compared to the 4.5. I have seen it first hand. I do run a 4.5 and the it can easily hang with the 5700 and get better run times.
jmackani is offline  
Reply With Quote
Old 08-01-2010, 11:39 PM
  #6  
Tech Elite
iTrader: (56)
 
kman16jr's Avatar
 
Join Date: May 2010
Location: Tampa,Fl.
Posts: 4,013
Trader Rating: 56 (100%+)
Default

get the novak 550 4.5,it runs cooler and has alot more torque than the 5700 because the motor can is thicker and longer,WAY BETTER THAN THE 5700.
kman16jr is offline  
Reply With Quote
Old 08-02-2010, 07:22 PM
  #7  
Tech Apprentice
Thread Starter
iTrader: (10)
 
mopargreg's Avatar
 
Join Date: Jan 2010
Location: Sunshine State
Posts: 76
Trader Rating: 10 (100%+)
Default

Thanks guys, I have both motors already so I'm going to mount the NEW Novak 4.5 in the truck and give it a run........
mopargreg is offline  
Reply With Quote
Old 08-02-2010, 07:23 PM
  #8  
Tech Elite
iTrader: (56)
 
kman16jr's Avatar
 
Join Date: May 2010
Location: Tampa,Fl.
Posts: 4,013
Trader Rating: 56 (100%+)
Default

+1,good choice
kman16jr is offline  
Reply With Quote
Old 08-12-2010, 09:21 PM
  #9  
Tech Adept
iTrader: (6)
 
Join Date: Dec 2009
Posts: 107
Trader Rating: 6 (100%+)
Default

Any update on this? I wasn't even sure if that motor would work with that esc. I'm thinking of buying that motor to use with that esc.
Michael76706 is offline  
Reply With Quote
Old 08-13-2010, 12:19 AM
  #10  
Tech Master
iTrader: (77)
 
Yeti AS3's Avatar
 
Join Date: Jan 2010
Location: lockport,IL
Posts: 1,347
Trader Rating: 77 (100%+)
Default

Run sensored only and you should be alright. I had none of the glitching issues with a DX3s, AMB p/t, fan on the motor, and a ACE 1015 servo.
Yeti AS3 is offline  
Reply With Quote
Old 08-14-2010, 12:43 AM
  #11  
Tech Initiate
 
Join Date: Jul 2010
Location: Southern Ohio
Posts: 40
Thumbs down

I've had terrible luck with the 5700 in my Losi XXX-CR and Traxxas Slash. I was running 16/90 in the Slash, and I couldn't get it below 200 at the end of a run, so I had to cut the runs short. Geared 19/86 in the CR, I was lucky to end up at 190 after a run; (still way too hot!). If I geared down anymore in the CR, it would actually run hotter and top out too soon. I was running 25c 4000mah 2-cell lipos, and Castle told me that I needed to run a higher mah or C rating, as that rating of a battery was not delivering enough current, causing the system to run hotter. I was at a loss. I couldn't even get motor temps down if I set timing to the lowest setting. In my CR the motor failed during a run, and when temped was at 239 degrees. I will note that Castle said to send it in and they'd replace it for free, seeing as it's only a few months old, but I figure the same thing will happen when I run the replacement. I also bought a new 4600, and I'm having the same type of issues. I had no trouble with original Mamba Max 4600 for 3 years of running, but I think the quality of there new motors has been greatly reduced.
FeedThAddiction is offline  
Reply With Quote
Old 08-14-2010, 12:50 AM
  #12  
Tech Elite
iTrader: (65)
 
smokinu's Avatar
 
Join Date: Apr 2008
Location: MODESTO CA
Posts: 4,916
Trader Rating: 65 (99%+)
Default

i am currently running the 5700 3.5 in my hyper and sure its fast and fun! but i have 2 heat sinks on it! and they are both under the motor and touching the chassis for heat and the motor is still in the 150s after a hard run!
smokinu is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service