Go Back  R/C Tech Forums > General Forums > Electric Off-Road
Kyosho Ultima SC-R Thread >

Kyosho Ultima SC-R Thread

Kyosho Ultima SC-R Thread

Old 04-17-2012, 06:20 PM
  #3556  
Super Moderator
iTrader: (80)
 
Kraig's Avatar
 
Join Date: Aug 2001
Location: Sun Prairie, WI
Posts: 6,780
Trader Rating: 80 (100%+)
Default

J-RO, If the servo saver is loose it will feel that way.
Kraig is offline  
Old 04-17-2012, 06:59 PM
  #3557  
Tech Addict
iTrader: (2)
 
Join Date: Oct 2008
Posts: 516
Trader Rating: 2 (100%+)
Default

Changed the servo saver, same thing happened. So i held the tire to restrict the steering and checked to see if the servo was moving inside the saver and it was all solid. Could it be that the servo is not getting enough power from the esc and batt? Im running a Savox.
J-RO is offline  
Old 04-17-2012, 07:05 PM
  #3558  
Tech Master
iTrader: (94)
 
Join Date: Feb 2007
Posts: 1,531
Trader Rating: 94 (100%+)
Default

NVM Got some Thanks!

Last edited by Eric Tomczyk; 04-26-2012 at 06:42 AM.
Eric Tomczyk is offline  
Old 04-17-2012, 07:21 PM
  #3559  
Tech Elite
iTrader: (9)
 
B00t13g's Avatar
 
Join Date: Mar 2012
Location: Houston, TX
Posts: 2,041
Trader Rating: 9 (100%+)
Default

You won't have as much steering on the power.
B00t13g is offline  
Old 04-17-2012, 07:22 PM
  #3560  
Super Moderator
iTrader: (80)
 
Kraig's Avatar
 
Join Date: Aug 2001
Location: Sun Prairie, WI
Posts: 6,780
Trader Rating: 80 (100%+)
Default

Originally Posted by J-RO View Post
Changed the servo saver, same thing happened. So i held the tire to restrict the steering and checked to see if the servo was moving inside the saver and it was all solid. Could it be that the servo is not getting enough power from the esc and batt? Im running a Savox.
Make sure it is tight otherwise you are getting nowhere. I thought mine was tight and did the same thing you did but on the track it wasn't. So I glued the pieces together with my fingers.

What speed control are you running? If the bec can't handle the load then yeah, that could be possible.

Have you tried to walk the truck off of the pipes when it gets stuck?
Kraig is offline  
Old 04-17-2012, 07:26 PM
  #3561  
Tech Addict
iTrader: (2)
 
Join Date: Oct 2008
Posts: 516
Trader Rating: 2 (100%+)
Default

Have not had the truck on track yet, im using the novak gtb 2 esc, trying to get ready for Ironmaximus this weekend.
J-RO is offline  
Old 04-17-2012, 09:46 PM
  #3562  
Tech Master
iTrader: (22)
 
samuelsonmark71's Avatar
 
Join Date: Aug 2010
Posts: 1,476
Trader Rating: 22 (100%+)
Default

Have you installed a capacitor to the reciever yet to act like a BEC of sorts? I know when I had my Savox installed, I had to have a decent size capacitor wired right into one of the aux channels of the reciever
samuelsonmark71 is offline  
Old 04-17-2012, 10:25 PM
  #3563  
Tech Elite
iTrader: (9)
 
B00t13g's Avatar
 
Join Date: Mar 2012
Location: Houston, TX
Posts: 2,041
Trader Rating: 9 (100%+)
Default

Has anyone run into an issue where the steering linkage hits the servo? If so what was your fix?
B00t13g is offline  
Old 04-18-2012, 03:00 AM
  #3564  
Tech Addict
iTrader: (2)
 
Join Date: Oct 2008
Posts: 516
Trader Rating: 2 (100%+)
Default

BEC will be my next step, i notice the steering problems even when i let off the throtle dose not seem to get better.
J-RO is offline  
Old 04-18-2012, 05:24 AM
  #3565  
Tech Elite
iTrader: (35)
 
t0p_sh0tta's Avatar
 
Join Date: Aug 2009
Location: Connecticut
Posts: 4,863
Trader Rating: 35 (100%+)
Default

Originally Posted by B00t13g View Post
Has anyone run into an issue where the steering linkage hits the servo? If so what was your fix?
Yes. I sanded down the back of the ball cup, and it worked fine. This was running an Orion servo. If sanding down the cup doesn't work, then you could always mod the servo case.
t0p_sh0tta is offline  
Old 04-18-2012, 05:48 AM
  #3566  
Tech Fanatic
iTrader: (8)
 
lewis4x4's Avatar
 
Join Date: Jul 2011
Posts: 756
Trader Rating: 8 (100%+)
Default

Originally Posted by B00t13g View Post
Has anyone run into an issue where the steering linkage hits the servo? If so what was your fix?
Yea... I also have to trim the ball cup as well as trim some off the Servo Case... Works like a charm now...
lewis4x4 is offline  
Old 04-18-2012, 06:00 AM
  #3567  
Tech Elite
iTrader: (35)
 
t0p_sh0tta's Avatar
 
Join Date: Aug 2009
Location: Connecticut
Posts: 4,863
Trader Rating: 35 (100%+)
Default

=(

I miss my SC.
t0p_sh0tta is offline  
Old 04-18-2012, 10:12 AM
  #3568  
R/C Tech Elite Member
 
JayL's Avatar
 
Join Date: Mar 2006
Location: Ca
Posts: 3,097
Default

savox almost requires a recv cap

TRP makes an alum 1 piece servo saver arm part, very nice part, loving mine. Search this thread and PM him, can't remember his screename
JayL is offline  
Old 04-18-2012, 12:02 PM
  #3569  
Tech Elite
iTrader: (86)
 
Join Date: Jun 2006
Location: Omaha,NE
Posts: 2,598
Trader Rating: 86 (99%+)
Default

Truck was soooo good last night, I was having a issue with a off power push previous to last night and it magically cured itself , must have just needed some more runs on the tires and foams to get them broke in
WideOpenThrottle RC is offline  
Old 04-18-2012, 12:04 PM
  #3570  
Tech Elite
iTrader: (32)
 
Join Date: Jul 2009
Location: So Cal
Posts: 2,380
Trader Rating: 32 (100%+)
Default

I see and read waaaay too many savox servo problems.

Sure sOme have no problems but thats a small percent compared to the huge number of problems.

I advise that you steer clear from savox. Get it? Steer clear. Lol
Pimpin is offline  

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.