Go Back  R/C Tech Forums > General Forums > Electric Off-Road
Whats best 8th TRUGGY Electric battery connectors? >

Whats best 8th TRUGGY Electric battery connectors?

Whats best 8th TRUGGY Electric battery connectors?

Old 04-01-2010, 09:11 AM
  #16  
Team Tekin
 
TY@TEAMTEKIN's Avatar
 
Join Date: Mar 2006
Location: Tekin
Posts: 2,465
Default

Deans in all of our rigs with no problems. I also put my battery wires facing the rear so they aren't ran over the top of the battery, had them come unplugged too many times!
TY@TEAMTEKIN is offline  
Old 04-01-2010, 10:20 AM
  #17  
Tech Elite
 
UK.hardcore's Avatar
 
Join Date: Aug 2007
Location: Belgium.
Posts: 2,288
Default

never really jumped this thing anyway , but i'll follow you dudes advice's on my other truck that is under contruction.

thanks.
UK.hardcore is offline  
Old 04-01-2010, 01:30 PM
  #18  
Tech Addict
iTrader: (9)
 
Rampokker's Avatar
 
Join Date: Apr 2009
Location: Hawkes Bay, New Zealand
Posts: 624
Trader Rating: 9 (100%+)
Default

I tried using the bullet connectors, and even though they worked great, they're just a serious P I T A to plug and unplug.

I normally use traxxas plugs on all my cars because they're big and easy to use. But they can't handle 8 gauge wire.

So I ended up using bullet connectors to get the wires down to the same thickness as the ones on my esc, and then used traxxas connectors to connect to the esc. Check out the pic:

Rampokker is offline  
Old 04-01-2010, 01:50 PM
  #19  
Team Tekin
 
TY@TEAMTEKIN's Avatar
 
Join Date: Mar 2006
Location: Tekin
Posts: 2,465
Default

Originally Posted by UK.hardcore View Post
never really jumped this thing anyway , but i'll follow you dudes advice's on my other truck that is under contruction.

thanks.
Haha, you make it sound like we're twisting your arm! But seriously, mine kept coming unplugged because I didn't make my wires long enough off the ESC, which also can cause problems if there is constant pressure on the solder posts or plugs. Food for thought!
TY@TEAMTEKIN is offline  
Old 04-01-2010, 02:56 PM
  #20  
Tech Master
Thread Starter
 
malcnz's Avatar
 
Join Date: Sep 2006
Location: CHRISTCHURCH, NewZealand
Posts: 1,339
Default

Thanks again guys..Ty I got youre message about the missing harness in my 1350 Tekin motor so look forward to receiving it.
So is no one using the XT60 connectors? or recommend them?
do have deans but I can see its going to be a bitch soldering those big fat 8awg wires on
malcnz is offline  
Old 04-02-2010, 01:55 AM
  #21  
Tech Elite
 
UK.hardcore's Avatar
 
Join Date: Aug 2007
Location: Belgium.
Posts: 2,288
Default

Originally Posted by [email protected] View Post
Haha, you make it sound like we're twisting your arm! But seriously, mine kept coming unplugged because I didn't make my wires long enough off the ESC, which also can cause problems if there is constant pressure on the solder posts or plugs. Food for thought!
I'm dead serious, that RC8T has done only 5 jumps.

I just drive it on the field here. the plugs haven't come unplugged by themselves ever.

my other one is going to be run on the race track, that one will follow your advice.
UK.hardcore is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.