R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Reply
 
Thread Tools Search this Thread
Old 04-06-2009, 12:35 PM   #16
Tech Elite
 
kufman's Avatar
 
Join Date: Feb 2004
Location: Elburn, IL
Posts: 3,428
Trader Rating: 6 (100%+)
Default

Anybody know what Barry Baker was running?
kufman is offline   Reply With Quote
Old 04-06-2009, 12:40 PM   #17
Tech Master
 
Gary NJ's Avatar
 
Join Date: Jan 2004
Location: Long Island NY
Posts: 1,157
Trader Rating: 8 (100%+)
Default

Quote:
Originally Posted by kufman View Post
Anybody know what Barry Baker was running?
My understanding was one of the new D8Es and Novak 'lectrics.
__________________
Gary - GMK Supply
www.gmksupply.com
Great products. Goofy names.
Gary NJ is offline   Reply With Quote
Old 04-06-2009, 12:42 PM   #18
Tech Master
 
rearviewmirror's Avatar
 
Join Date: Nov 2008
Location: Melbourne / Austin
Posts: 1,844
Trader Rating: 17 (100%+)
Send a message via AIM to rearviewmirror Send a message via Yahoo to rearviewmirror
Default

Quote:
Originally Posted by stfitzgerald View Post
They had no issues with there escs.I went through 2 MMMs at this race.1 quit working and the other went in flames.
Any reason as to why they let go? Any gearing or other issues? I lost a couple myself; both in flames but haven't found a root cause yet.
__________________
ARCTIC DOG RACING (Nitro free since 2009)

"Straights are for fast cars, curves are for fast drivers...."

8ight-E / 8ight-TE / T4 / Slash
rearviewmirror is offline   Reply With Quote
Old 04-06-2009, 02:15 PM   #19
Tech Legend
 
Cain's Avatar
 
Join Date: May 2002
Location: West Fargo, North Dakota
Posts: 29,531
Trader Rating: 240 (100%+)
Default

Was anyone running the RC Monster slipper setup?

For the clutch tekno setups, what as common to go with for shoes and springs, if any?
__________________
Member - Red River Radio/Control Car Club
< Tekno EB48SL / SCT410.3 | Tekno EB410 x 2 | Yokomo YZ-2 DTM x 2 | LC Racing EMB-1 Buggies and Truggies >
Cain is offline   Reply With Quote
Old 04-06-2009, 02:26 PM   #20
Tech Fanatic
 
stfitzgerald's Avatar
 
Join Date: Mar 2007
Posts: 785
Trader Rating: 20 (100%+)
Default

Quote:
Originally Posted by rearviewmirror View Post
Any reason as to why they let go? Any gearing or other issues? I lost a couple myself; both in flames but haven't found a root cause yet.
I coudnt see any reason why they did that.The wires to the motor were fine.One just quit working no wires frayed or nothing and that happened in one of qualifiers.Another qualifier my steer servo horn came loose and came off.In my main my 2nd MMM caught fire.It did no other damage to the car except it melted my receiver because it was next to the MMM.
O-well i was having a crapy race weekend anyway.
I had talked to the Tekin people earlier that day and checked out there new esc and motor and they saw what happen to my car and they just watched in horror.Bob Novak was there too and he saw it as well.Not a good day for castle
__________________
ALL STATE DRIVESHAFT
TEKNO PERFORMANCE PARTS
stfitzgerald is offline   Reply With Quote
Old 04-06-2009, 02:33 PM   #21
Tech Elite
 
Join Date: Dec 2007
Location: Chicago, IL
Posts: 2,854
Trader Rating: 19 (100%+)
Default

Castle really needs to redesign their case. It simply isn't up to the task of racing. I bet most of the failures can be traced to the case design. The board gets slammed on the bottom of the case, not to mention the little plastic tabs simply aren't strong enough for the forces the case has to endure.
__________________
Cars I've Owned: Tekno EB48 & SCT410, AE 8.2e, AE SC10 4x4, MBX6e Tekno V4, Xray 808e, Xray 8Te, Losi 810e, Losi SCTE 4x4, Losi 22, Hot Bodies Ve8, Losi 8te, and plenty of Traxxas

Sponsors: Visa, Mastercard, Amex, and my wife's bank account.
Edumakated is offline   Reply With Quote
Old 04-06-2009, 05:33 PM   #22
Tech Adept
 
Waters's Avatar
 
Join Date: Jan 2009
Location: West Michigan
Posts: 160
Trader Rating: 10 (100%+)
Default

Quote:
Originally Posted by Edumakated View Post
Castle really needs to redesign their case. It simply isn't up to the task of racing. I bet most of the failures can be traced to the case design. The board gets slammed on the bottom of the case, not to mention the little plastic tabs simply aren't strong enough for the forces the case has to endure.
I use some thick double side foam tape and then run zip ties threw the ESC and
under the tray..

My next option is wrap it with a nice layer of bubble wrap and....... just kidding
__________________
Losi 8b 2.0, Werks B5 2057, Losi 8bE 1.0 2200kv 3s 7-12 ounces, T4.1, B4.1,
Waters is offline   Reply With Quote
Old 04-06-2009, 06:11 PM   #23
Tech Elite
 
teknorc's Avatar
 
Join Date: Jul 2005
Location: So Cal
Posts: 3,156
Trader Rating: 2 (100%+)
Default

Quote:
Originally Posted by Cain View Post
Was anyone running the RC Monster slipper setup?

For the clutch tekno setups, what as common to go with for shoes and springs, if any?
We all ran Tekno hard shoes (TKR4105) and Tekno .8mm springs (TKR4108).
__________________
Tekno RC
www.teknorc.com
teknorc is offline   Reply With Quote
Old 04-06-2009, 06:47 PM   #24
Tech Champion
 
R40Victim's Avatar
 
Join Date: Jan 2005
Location: N.W. FL___L.A.___Lower Alabama
Posts: 7,823
Trader Rating: 1 (100%+)
Default

Quote:
Originally Posted by Edumakated View Post
Castle really needs to redesign their case. It simply isn't up to the task of racing. I bet most of the failures can be traced to the case design. The board gets slammed on the bottom of the case, not to mention the little plastic tabs simply aren't strong enough for the forces the case has to endure.
I run a large zip tie with a cut piece of foam under it. Any other way and it breaks free or gets slammed too hard in my truggy.
R40Victim is offline   Reply With Quote
Old 04-06-2009, 08:38 PM   #25
Tech Elite
 
Join Date: Dec 2007
Location: Chicago, IL
Posts: 2,854
Trader Rating: 19 (100%+)
Default

Quote:
Originally Posted by R40Victim View Post
I run a large zip tie with a cut piece of foam under it. Any other way and it breaks free or gets slammed too hard in my truggy.
Yeah, I use dual lock and then zip tie it. Works fine unless the zip tie breaks and then you are screwed if it occurs while you are on the track. Had my zip tie break in the middle of practice and the POS case almost immediately failed. The board got bounced around on the chassis and eventually shorted itself out.
__________________
Cars I've Owned: Tekno EB48 & SCT410, AE 8.2e, AE SC10 4x4, MBX6e Tekno V4, Xray 808e, Xray 8Te, Losi 810e, Losi SCTE 4x4, Losi 22, Hot Bodies Ve8, Losi 8te, and plenty of Traxxas

Sponsors: Visa, Mastercard, Amex, and my wife's bank account.
Edumakated is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 07:44 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net