R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Reply
 
Thread Tools Search this Thread
Old 03-08-2009, 11:25 PM   #1
Tech Initiate
 
Join Date: Feb 2009
Posts: 49
Trader Rating: 2 (100%+)
Default MY ESC WENT TO HEAVEN

i have a duratrax evader with a 12t dynamite tazer esc and a trinity cobalt 12t motor the esc has about 4 runs on it the motor 10 the last time i ran it it seemed a lil flat on the top side so i cleaned it put it back together i went to run it today when i pulled the trigger it moved about an inch and stopped the steering servo still works the led lights are showing no problems but the motor is dead i hooked it up to a stock epic and does the same thing any ideas
RadioCircus is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
New MRT ESC V12 Electric On-Road 494 12-05-2008 11:48 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 11:20 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net