Go Back  R/C Tech Forums > General Forums > Electric Off-Road
Team Durango DEX410 4WD 1/10 Off-Road Buggy Thread >

Team Durango DEX410 4WD 1/10 Off-Road Buggy Thread

Like Tree22Likes

Team Durango DEX410 4WD 1/10 Off-Road Buggy Thread

Old 01-10-2011, 05:59 PM
  #5221  
Tech Fanatic
iTrader: (8)
 
Join Date: Apr 2009
Location: n.e. ohio
Posts: 892
Trader Rating: 8 (100%+)
Default

Originally Posted by Dlewis4
PICS OF THE SERVO SAVER ARM!!!

that is the bottom one, that is the one that breaks.
cbrociuos is offline  
Old 01-10-2011, 06:03 PM
  #5222  
Tech Champion
iTrader: (33)
 
Jason Pelletier's Avatar
 
Join Date: Jul 2007
Location: New York
Posts: 8,834
Trader Rating: 33 (100%+)
Default

Thanks Derek.
Jason Pelletier is offline  
Old 01-10-2011, 06:07 PM
  #5223  
Tech Elite
iTrader: (148)
 
Dlewis4's Avatar
 
Join Date: Feb 2010
Location: Saint Joseph, MO
Posts: 4,758
Trader Rating: 148 (100%+)
Default

Sorry that took so long to get the pic up, we just received the picture from HRP
Dlewis4 is offline  
Old 01-10-2011, 06:13 PM
  #5224  
Tech Champion
iTrader: (88)
 
BMenard17's Avatar
 
Join Date: Jul 2010
Location: North Port, FL
Posts: 6,704
Trader Rating: 88 (99%+)
Default

I know this isnt your problem but why dont durango fix the issue with the saver..... It seems to be ok with everyone that they are breaking. Has anyone brought it to there attention that this is happening?
BMenard17 is offline  
Old 01-10-2011, 06:19 PM
  #5225  
Tech Champion
iTrader: (33)
 
Jason Pelletier's Avatar
 
Join Date: Jul 2007
Location: New York
Posts: 8,834
Trader Rating: 33 (100%+)
Default

Originally Posted by CORRRCR
I know this isnt your problem but why dont durango fix the issue with the saver..... It seems to be ok with everyone that they are breaking. Has anyone brought it to there attention that this is happening?
They may but whatever other cars have this same issue. My 8ight 2.0 does as well.

only a 15 dollar fix and it's beefy....
Jason Pelletier is offline  
Old 01-10-2011, 06:44 PM
  #5226  
Tech Fanatic
iTrader: (8)
 
Join Date: Apr 2009
Location: n.e. ohio
Posts: 892
Trader Rating: 8 (100%+)
Default

Originally Posted by CORRRCR
I know this isnt your problem but why dont durango fix the issue with the saver..... It seems to be ok with everyone that they are breaking. Has anyone brought it to there attention that this is happening?
its one small issue, and if you can drive w/o hitting a wall or slamming a tube the stock piece is pretty durable. this car is about as close to a tank as you'll find in rc. i only wish my other cars would take half the abuse this kit will. besides you have to let the aftermarket have something. if they were going to redesign something they should start w/ the x-rings! its pretty easy to see why they might not have caught both issues in testing. the diffs were prob. getting fluids changed after every run by the pro testers to see what worked best under different conditions, and they all have mad skills and werent wodding up the car to break the servo saver arm. just my .02.
cbrociuos is offline  
Old 01-10-2011, 06:45 PM
  #5227  
Tech Elite
iTrader: (148)
 
Dlewis4's Avatar
 
Join Date: Feb 2010
Location: Saint Joseph, MO
Posts: 4,758
Trader Rating: 148 (100%+)
Default

HRP only has 15 of em left. Had 50 this morning.

If you need one... RCE9801 at premierehobbies.com!
Dlewis4 is offline  
Old 01-10-2011, 06:52 PM
  #5228  
Tech Master
iTrader: (21)
 
TraxxasPeter's Avatar
 
Join Date: May 2010
Location: Mattituck,LI, NY
Posts: 1,510
Trader Rating: 21 (100%+)
Default

Take a gander at my freshly painted body from mikeLdesigns
TraxxasPeter is offline  
Old 01-10-2011, 06:53 PM
  #5229  
Tech Champion
iTrader: (88)
 
BMenard17's Avatar
 
Join Date: Jul 2010
Location: North Port, FL
Posts: 6,704
Trader Rating: 88 (99%+)
Default

Originally Posted by cbrociuos
its one small issue, and if you can drive w/o hitting a wall or slamming a tube the stock piece is pretty durable. this car is about as close to a tank as you'll find in rc. i only wish my other cars would take half the abuse this kit will. besides you have to let the aftermarket have something. if they were going to redesign something they should start w/ the x-rings! its pretty easy to see why they might not have caught both issues in testing. the diffs were prob. getting fluids changed after every run by the pro testers to see what worked best under different conditions, and they all have mad skills and werent wodding up the car to break the servo saver arm. just my .02.
good answer.. ill just live with it
BMenard17 is offline  
Old 01-10-2011, 07:18 PM
  #5230  
Tech Fanatic
iTrader: (8)
 
Join Date: Apr 2009
Location: n.e. ohio
Posts: 892
Trader Rating: 8 (100%+)
Default

Originally Posted by TraxxasPeter
Take a gander at my freshly painted body from mikeLdesigns
nice!
cbrociuos is offline  
Old 01-10-2011, 07:40 PM
  #5231  
Tech Master
iTrader: (5)
 
ABBOTT's Avatar
 
Join Date: Sep 2008
Location: St Charles ,MO
Posts: 1,207
Trader Rating: 5 (100%+)
Default

Originally Posted by cbrociuos
by hv do you mean your running that servo above 6 volts? if so what voltage and im guessing your adjusting the esc's bec? thanks in advance!
Sorry looking again its the Savox 1267 Im running. I know its way to much and I only set it up hv cause I had never used one this way. (voltage coming directly from lipo)
ABBOTT is offline  
Old 01-10-2011, 07:56 PM
  #5232  
Tech Elite
iTrader: (45)
 
rangerjkb's Avatar
 
Join Date: Dec 2008
Location: USA
Posts: 2,609
Trader Rating: 45 (100%+)
Default

Originally Posted by Dlewis4
HRP only has 15 of em left. Had 50 this morning.

If you need one... RCE9801 at premierehobbies.com!
Just ordered one!!! No more worries for that part, for when I do tap something!!! Gotta get'em when while they're available!!!
rangerjkb is offline  
Old 01-10-2011, 08:00 PM
  #5233  
Tech Elite
iTrader: (22)
 
Drift_Buggy's Avatar
 
Join Date: Dec 2004
Location: Australia
Posts: 2,662
Trader Rating: 22 (100%+)
Default

That looks excellent TraxxasPeter
Drift_Buggy is offline  
Old 01-10-2011, 08:22 PM
  #5234  
Tech Fanatic
iTrader: (8)
 
Join Date: Apr 2009
Location: n.e. ohio
Posts: 892
Trader Rating: 8 (100%+)
Default

Originally Posted by ABBOTT
Sorry looking again its the Savox 1267 Im running. I know its way to much and I only set it up hv cause I had never used one this way. (voltage coming directly from lipo)
i have a savox tg, .07 and like 160 on the torque. dont remember the #. id like to try it in the rango, but im about out of room. dont really have a place for a cap. i was thinking if i turn up my bec on the esc to 7.4volts it would drop the amp pull of the servo and i may not need the cap. wasnt sure if the servo would handle it or if the extra voltage would be enough to not need a cap. if it wasnt such a pain in the arse to change the servo id try but im a little on the lazy side cause my airtronics servo works fine. maybe ill throw it in my f.t. sc10 i have on order.
cbrociuos is offline  
Old 01-10-2011, 10:11 PM
  #5235  
Tech Elite
iTrader: (67)
 
tonyv2382's Avatar
 
Join Date: Nov 2009
Location: Queens, NYC
Posts: 3,790
Trader Rating: 67 (100%+)
Default

Originally Posted by TraxxasPeter
Take a gander at my freshly painted body from mikeLdesigns
Def one of the nicest bodies Ive seen yet
tonyv2382 is offline  

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.