R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Reply
 
Thread Tools Search this Thread
Old 01-20-2009, 12:21 PM   #1
Tech Initiate
 
Join Date: Oct 2008
Posts: 26
Default SLASH SUSPENSION

JUST CURIOUS, BOUGHT MY SON A SLASH RAN IT TWO OR THREE TIMES.
RUNS FINE BUT SUSPENSION DOES NOT REBOUND THE SAME. TRIED A LITTLE WD 40 ON HINGE PINS HELPED A LITTLE BUT NOT TO THE POINT IT WAS. ANY SUGGESTIONS WOULD BE GREAT.


THANKS
HOWIE BEDELL is offline   Reply With Quote
Old 01-20-2009, 12:36 PM   #2
Tech Elite
 
Jube's Avatar
R/C Tech Elite Subscriber
 
Join Date: Oct 2008
Location: Indiana
Posts: 2,397
Trader Rating: 43 (100%+)
Default

Check all moving parts for binding. Check shock shafts for straightness. Something has probably been bent without you realizing it.
__________________
Jubal Dike
X-Factory www.xfactoryrc.com | Tekin www.teamtekin.com | Panther Tires www.panthertires.com | DE Racing www.deracing.net | Avid www.avidrc.com | Coyote Hobbies www.coyotehobbies.com | 411 Graphics
Jube is offline   Reply With Quote
Old 01-20-2009, 12:55 PM   #3
Tech Master
 
$Tmoney$'s Avatar
 
Join Date: Jun 2008
Location: Alta Loma
Posts: 1,529
Trader Rating: 28 (97%+)
Default

slash is natorious for bending shock shafts and just the slightest bend will affect the rebound
$Tmoney$ is offline   Reply With Quote
Old 01-20-2009, 01:40 PM   #4
Tech Regular
 
Ebola888's Avatar
 
Join Date: Sep 2007
Location: Oshkosh, WI
Posts: 445
Trader Rating: 44 (100%+)
Default

I noticed that there was very little rebound after the shock was fully compressed. This was a stock shock with the 30W oil and without springs. I rebuilt the shocks and had full rebound afterward. I have a buddy that checked his brand new Slash's shocks and they were the same way, little to no rebound.

After the rebuild my truck had less body roll and was a bit more responsive due to the lack of "sponginess."
Ebola888 is offline   Reply With Quote
Old 01-20-2009, 01:52 PM   #5
Tech Master
 
big al's Avatar
 
Join Date: Jan 2002
Location: Olympia,Wa
Posts: 1,026
Trader Rating: 10 (100%+)
Default

I noticed the same thing just before I changed out the oil in a set of new shocks. Zero rebound.
<<That's how i roll
big al is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Electric 1/8th Scale conversion kits. DJ1978 Electric Off-Road 19923 06-12-2017 06:16 AM
Traxxas Slash, SETUPS ONLY ! ! ! ! ! nobike Electric Off-Road 769 09-13-2014 03:35 PM
West Coast R/C Raceway & Hobby Garage In So. Cali! DannyS California Racing 14045 01-19-2014 09:33 PM
New Traxxas Slash 1:10 Electric CORR Truck salteen Electric Off-Road 3949 03-19-2012 09:24 AM
SC10?!? trdsupra88 Electric Off-Road 926 07-20-2009 01:29 PM
IMPORTANT: New Product Arrival Alert! (January 2009) rcmart rcMart.com Mega Online R/C Marketplace 46 04-23-2009 08:47 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 08:22 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net