R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Reply
 
Thread Tools Search this Thread
Old 06-25-2008, 01:35 AM   #1
Tech Adept
 
Join Date: Apr 2008
Location: Garden Grove CA
Posts: 176
Default GTX esc HELP!!!!!!!!!!!!!

i have a novak GTX and i think theres something wrong with it if i plug it in to my battery it starts heating up with the switch off and it has no brakes. the fact it has no brakes could that be my radio?
__________________
Jammin CRT.5 ext chassis
Spectrum DX2
OS .12tz (5)
Associated B4 FT
XP digital servo
NOVAK GTX
checkpoint 12x2 modified
ktmusa is offline   Reply With Quote
Old 06-25-2008, 01:39 AM   #2
Tech Elite
 
Turbo Joe's Avatar
 
Join Date: Nov 2003
Location: Corona, CA
Posts: 4,878
Trader Rating: 41 (100%+)
Default

Quote:
Originally Posted by ktmusa View Post
i have a novak GTX and i think theres something wrong with it if i plug it in to my battery it starts heating up with the switch off and it has no brakes. the fact it has no brakes could that be my radio?
Just take it over to Novak. They're in Irvine and they can check it out for you in a few minutes.

http://teamnovak.com/cs/index.html
Turbo Joe is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 07:39 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net