R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Reply
 
Thread Tools Search this Thread
Old 04-17-2008, 11:10 AM   #1
Team Tekin
 
yzracer758's Avatar
 
Join Date: Apr 2008
Location: Tekin HQ
Posts: 3,030
Trader Rating: 18 (100%+)
Default Am I the only disappointed Losi owner?

So a couple weeks ago I go to the largest local hobby shop around and want to get the XXX-4 G+ kit. Its the only kit that they basically don't have in stock. Special Order only. Thats fine, a weeks wait isn't too bad, give me time to get the rest of the car planned out and parts ordered. A week later the kit comes in and I'm ready to start putting it together. I get both diffs assembled and mounted on the chassis along with the belt and tensioner. Now is when things start heading south. When I try to tighten the belt the belt seems to be way to long or something. With the tensioner as tight as it will go, the belt still has massive slack. Also when I go to put the belt cover on the bottom of the chassis, the cover is about 1/2" inch longer then the slot its suppose to fit in. WTF? The next day I call up Losi and the tech guy tells me that I got the wrong Chassis, and he's sending out a new one. Well that's comforting at least. Also today I took a look at the kit again and realized that the body is the wrong one also. Not even close to the same shape as the xxx-4 chassis. So now here I sit 3 weeks into this thing and I have not got my chassis and also have the wrong body. HAS ANYONE ELSE RAN INTO THIS PROBLEM FROM LOSI BEFORE?

Last edited by yzracer758; 04-17-2008 at 11:20 AM.
yzracer758 is offline   Reply With Quote
Old 04-17-2008, 11:24 AM   #2
Tech Master
 
Crawler's Avatar
 
Join Date: Mar 2007
Location: I'm an A**HOLE!
Posts: 1,828
Trader Rating: 6 (100%+)
Default

Let's hear it for Horizon!

I weep for the Losi name.
__________________
RCShortCourse.com

550 Mafia.
Crawler is offline   Reply With Quote
Old 04-17-2008, 11:25 AM   #3
Tech Elite
 
OTE_TheMissile's Avatar
 
Join Date: Aug 2007
Posts: 2,688
Trader Rating: 2 (100%+)
Send a message via MSN to OTE_TheMissile
Default

<- once again, glad he races Associated
__________________
Faster Than Factory
On The EDGE Racing, est. 2001 - Home of the 524, the Silverado Slammer E-MAX6X6, and the Sand Dollar prerunner
Mike Budzien | facebook.com/OTE.TheMissile | RIVCO Products | The RC Corral | iRacing.com
OTE_TheMissile is offline   Reply With Quote
Old 04-17-2008, 11:36 AM   #4
Tech Addict
 
Join Date: Aug 2005
Location: Tallahassee, FL
Posts: 695
Trader Rating: 75 (100%+)
Send a message via Yahoo to Paul_67
Default

7 Losi kits and no problems for me.
Paul_67 is offline   Reply With Quote
Old 04-17-2008, 11:42 AM   #5
Tech Champion
 
Jason Pelletier's Avatar
 
Join Date: Jul 2007
Location: New York
Posts: 8,820
Trader Rating: 33 (100%+)
Default

well, second to my lazer i think thats a one of the best 4wd cars going. stuff happens.

You be happy when you got it all sorted out.

I think if i ever bail on my kyosho's i would go with a losi.
__________________
Island Raceway & Hobby
Jason Pelletier is offline   Reply With Quote
Old 04-17-2008, 11:43 AM   #6
Tech Elite
 
OG RC 10T's Avatar
 
Join Date: May 2007
Posts: 2,658
Trader Rating: 41 (100%+)
Default

Sounds like you got one half and half mixed up kit. Your best bet is to send the entire thing back and get an entire new one. Who knows what else is mixed up in your box.

Im not a losi fan and I dont own there products, but a mix up is a mix up. S*@% happens.
__________________
Original RC 10T, T4, RC8Te, Tekin RX8. Losi Ten SCTE, Slash 4x4.
OG RC 10T is offline   Reply With Quote
Old 04-17-2008, 12:02 PM   #7
Tech Master
 
RBMike's Avatar
 
Join Date: Jan 2007
Location: Santa Clara CA
Posts: 1,264
Default

Are you sure you have it built correctly?
__________________
-EMBX6,T8 1400, RX8, 5S Lipo ,Elite-RC, RCM tray
-EMBX6,T8 1350, RX8, 5S Lipo ,Elite-RC, RCM tray
-B44 (Novak)
-ROAR 4 cell rule Blows
RBMike is offline   Reply With Quote
Old 04-17-2008, 12:18 PM   #8
Tech Master
 
Join Date: Sep 2007
Posts: 1,644
Trader Rating: 67 (100%+)
Default

My last Losi kit had several issues including incorrect directions sheet. This stuff has happened more often since the change to Horizon control.

Good luck with the XXX4, I never got mine to work well on rough tracks.
nutz4rcyktw is offline   Reply With Quote
Old 04-17-2008, 12:40 PM   #9
Tech Adept
 
Join Date: Nov 2007
Location: Vine Grove, KY
Posts: 228
Trader Rating: 4 (100%+)
Default

I've had several Losi trucks, buggies, and 4wds to include a XXX4G+ most recently. I've never had any issues with their kits. They are great products, like the 501X, MR4BX, and B44 that I also assembled and own. In fact, I'm not sure why more people aren't running them. The XXX series has always been extremely competitive. Bottom line, Losi makes great stuff.
richard.bratton is offline   Reply With Quote
Old 04-17-2008, 01:12 PM   #10
Tech Fanatic
 
Thai3g_Eclipse's Avatar
 
Join Date: Dec 2004
Location: Plano, TX
Posts: 879
Trader Rating: 10 (100%+)
Default

One of my parts bag was missing when I bought a XXX-4 G+ from the hobby shop. They had to contact Horizon and it took almost two weeks for it to come in, and my XXX-4 sat on the pit table with all the rear suspension components missing in the mean time. Other than that, I never had problems with other Losi kits/cars.
__________________
HPI Savage Flux HP | Tamiya TB-03
Thai3g_Eclipse is offline   Reply With Quote
Old 04-17-2008, 01:21 PM   #11
Tech Adept
 
Strong Bad's Avatar
 
Join Date: May 2007
Location: Strongbadia, OC
Posts: 208
Trader Rating: 1 (100%+)
Default

I think these kinds of issues are probably happening all over the place. Out of personal experience my girlfriend went to build her B4 and found they put a set of T4 shock bodies in the kit and lets not get started about the top shaft quality. There was a kid that ran at my old local track whose Tamiya 501X kit had no central belt drive bearings included. My latest XXX-CR kit had the wrong front hinge pins included as well. The point being as as manufacturers look for cheaper and cheaper ways to distribute thier products amid growing competition we are going to see issues like this. I don't think this is an issue exclusive to Losi, just a sign of global manufacturing, distribution and sales.
__________________
Team Losi XX-4 WE, XXX-4, XXX-CR, 22 2.0, 22-4

"Dudes on the left for hi-fives, girls on the right for making out!"
Strong Bad is offline   Reply With Quote
Old 04-17-2008, 01:27 PM   #12
Tech Addict
 
RussB's Avatar
 
Join Date: Aug 2005
Location: Sacramento
Posts: 736
Send a message via MSN to RussB
Default

Quote:
Originally Posted by yzracer758 View Post
So a couple weeks ago I go to the largest local hobby shop around and want to get the XXX-4 G+ kit. Its the only kit that they basically don't have in stock. Special Order only. Thats fine, a weeks wait isn't too bad, give me time to get the rest of the car planned out and parts ordered. A week later the kit comes in and I'm ready to start putting it together. I get both diffs assembled and mounted on the chassis along with the belt and tensioner. Now is when things start heading south. When I try to tighten the belt the belt seems to be way to long or something. With the tensioner as tight as it will go, the belt still has massive slack. Also when I go to put the belt cover on the bottom of the chassis, the cover is about 1/2" inch longer then the slot its suppose to fit in. WTF? The next day I call up Losi and the tech guy tells me that I got the wrong Chassis, and he's sending out a new one. Well that's comforting at least. Also today I took a look at the kit again and realized that the body is the wrong one also. Not even close to the same shape as the xxx-4 chassis. So now here I sit 3 weeks into this thing and I have not got my chassis and also have the wrong body. HAS ANYONE ELSE RAN INTO THIS PROBLEM FROM LOSI BEFORE?
sounds like your kit had a xxx-s chassis in it. same basic chassis but it's about a half inch shorter, so your body, belt cover, and belt will all be too long.
RussB is offline   Reply With Quote
Old 04-17-2008, 01:28 PM   #13
Tech Master
 
trx450racer174's Avatar
 
Join Date: Mar 2008
Location: Moreno Valley,CA
Posts: 1,261
Trader Rating: 7 (100%+)
Default

Yeah i have several Losi trucks and have had no probs with them, i would maybe take the advice and take the whole kit back and get another one.
__________________
E.K.D. RC Paint Work
Team Serpent USA, Desoto Racing , Team DE Racing, Team Hitec, Team Trakpower, Futaba, Team AKA, TrackstarRC.
trx450racer174 is offline   Reply With Quote
Old 04-17-2008, 04:07 PM   #14
Tech Elite
 
schmelme's Avatar
 
Join Date: Mar 2003
Posts: 2,294
Trader Rating: 13 (100%+)
Default

Not sure what happened there but sounds like operator error to me. Instructions
schmelme is offline   Reply With Quote
Old 04-17-2008, 04:23 PM   #15
Tech Elite
 
Drift_Buggy's Avatar
 
Join Date: Dec 2004
Location: Australia
Posts: 2,652
Trader Rating: 21 (100%+)
Default

I have owned XXX-4, XXX-4 G+, XXX BK2, XXX-T MF1 and a Losi 8ight and had no dramas.

So the XXX-S chassis was in there instead of the XXX-4?
Drift_Buggy is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Disappointed with new 13.5T BL??? bprocket Rookie Zone 5 05-17-2008 09:48 PM
Tamiya Nitrage 5.2 make us Disappointed lifeforrc Monster Trucks 38 08-27-2007 03:23 PM
Team Losi XXX-NT RTR all you need is fuel For Sale Like New/Good Owner! MarkieMark231 R/C Items: For Sale/Trade 7 10-18-2006 05:20 PM
Adjsutments and othe basics for Losi XXXS, for first time owner. imjonah Rookie Zone 3 10-10-2003 01:20 AM
MP6 owner, first time buggy owner rhys Electric Off-Road 1 04-25-2002 03:04 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 03:53 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net