R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Reply
 
Thread Tools Search this Thread
Old 12-30-2007, 04:06 AM   #1
Tech Master
 
sir miles's Avatar
 
Join Date: Jun 2007
Posts: 1,476
Trader Rating: 23 (100%+)
Default New E Maxx EVX-2 problem

Hello guys! Just wanna ask if somebody who bought a new E maxx (3905) have the same problem like mine. I just acquired this New E Maxx, I love this truck and I will be racing this baby for a long time now. But the problem is I cant use my M11 - Spektrum combo with this thing. The EVX-2 cant recognize the signal. At first I thought that I damaged the esc but when I re install the stock radio equiptment which is a normal TQ am gear, it runs again! Whats weird about this is, this morning I tried to install my M11 standard module and novak reciever hoping that this can solve my problem but the same thing happened. Im planning to buy a HV Maxx soon coz I know that this will solve my problem but for the meantime I want to use the stock motor and esc combo. Ive contacted Traxxas about this but they dont have any answer for me. Can somebody shed a light on this matter? TIA!
__________________
gaining momentum!

Last edited by sir miles; 12-30-2007 at 07:06 AM.
sir miles is offline   Reply With Quote
Old 12-30-2007, 07:12 AM   #2
Tech Elite
 
ta_man's Avatar
 
Join Date: Nov 2006
Location: New Jersey
Posts: 4,365
Trader Rating: 151 (100%+)
Default

There is at least one speed control that cannot be used with the Spektrum system - the Associated XPS Micro ESC in the RC18T - because it will not arm unless it sees a signal within a very short period after being turned on. Since the Spektrum RX takes a second or so to recognize the TX signal, the XPS has timed out before it gets the signal from the RX and will not turn on.

You may have found another speed control with this problem. That is the kind of question you must ask Traxxas about - the arming delay.
ta_man is offline   Reply With Quote
Old 12-31-2007, 01:00 AM   #3
Tech Master
 
sir miles's Avatar
 
Join Date: Jun 2007
Posts: 1,476
Trader Rating: 23 (100%+)
Default

Damn fool of me, I didnt read the manual carefully. The esc needs only to be re program so it can sense the spektrum. Thanks anyway.
__________________
gaining momentum!
sir miles is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Steering Problem on T-maxx 2.5 TH691 Monster Trucks 4 03-11-2007 07:07 PM
E-maxx 7 cell problem hasqual Electric Off-Road 2 01-10-2007 04:36 PM
t-maxx problem lovecrime720 Monster Trucks 5 02-13-2006 11:50 AM
s-maxx problem? Smaxxblue Monster Trucks 3 05-08-2005 07:35 PM
Problem with my t-maxx BIGGERSTUFF Electric Off-Road 2 09-23-2003 01:25 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 01:44 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net