3200 LIPO ISSUES

Reply

Old 09-23-2007, 05:36 PM
  #16  
Tech Elite
iTrader: (41)
 
Turbo Joe's Avatar
 
Join Date: Nov 2003
Location: Corona, CA
Posts: 4,878
Trader Rating: 41 (100%+)
Default

Originally Posted by F N CUDA View Post
the 'cuda for you Turbo
Yeah, I'm sure that never draws any attention.
Turbo Joe is offline  
Reply With Quote
Old 09-23-2007, 05:40 PM
  #17  
Tech Elite
iTrader: (41)
 
Turbo Joe's Avatar
 
Join Date: Nov 2003
Location: Corona, CA
Posts: 4,878
Trader Rating: 41 (100%+)
Default

Originally Posted by kuzo View Post
Joe, I don't think any more will be required. That was explanation was dead on and simple.
Thanks...LOL...I consider (aka: "rationalize") myself to be "big picture" guy for the most part, so sometimes I miss (aka: "ignore") the details on occasion.
Turbo Joe is offline  
Reply With Quote
Old 09-23-2007, 05:55 PM
  #18  
Tech Fanatic
iTrader: (11)
 
kuzo's Avatar
 
Join Date: Jul 2005
Location: Connecticut
Posts: 948
Trader Rating: 11 (100%+)
Default

Originally Posted by Turbo Joe View Post
Thanks...LOL...I consider (aka: "rationalize") myself to be "big picture" guy for the most part, so sometimes I miss (aka: "ignore") the details on occasion.
Opposite of my problem. I over detail everything. If you are ever bored ask me to send a lipo faq I started and you'll see what I mean.
kuzo is offline  
Reply With Quote
Old 09-23-2007, 06:43 PM
  #19  
Tech Champion
Thread Starter
iTrader: (34)
 
F N CUDA's Avatar
 
Join Date: May 2007
Location: Mission Viejo, So Cal
Posts: 5,841
Trader Rating: 34 (100%+)
Default

Opened up my lipo cases today and one of the thin tabs IS broken!
Maybe these things can't take it offroad!
2 dead batteries, same symptoms.
Mr Black, you hearin this? Will Orion/Peak help me out with this?
I don't think runnin em offroad sometimes should be considered abuse, should it?
F N CUDA is offline  
Reply With Quote
Old 09-23-2007, 06:56 PM
  #20  
Tech Fanatic
iTrader: (11)
 
kuzo's Avatar
 
Join Date: Jul 2005
Location: Connecticut
Posts: 948
Trader Rating: 11 (100%+)
Default

Originally Posted by F N CUDA View Post
Opened up my lipo cases today and one of the thin tabs IS broken!
Maybe these things can't take it offroad!
2 dead batteries, same symptoms.
Mr Black, you hearin this? Will Orion/Peak help me out with this?
I don't think runnin em offroad sometimes should be considered abuse, should it?
Granted I am running the 4800 but I have a 10, 7 and 4 year old kids with their own trucks. I have 8 packs and with the crashes these kids can manage there's no reason to believe these packs can't handle offroad. Not saying there isn't another problem with your packs but running offroad is not the issue.

Have you PMed or emailed Mr Black?
kuzo is offline  
Reply With Quote
Old 09-23-2007, 07:11 PM
  #21  
Tech Addict
iTrader: (5)
 
magm20001's Avatar
 
Join Date: Sep 2007
Posts: 546
Trader Rating: 5 (100%+)
Default

peak and orion same company?
magm20001 is offline  
Reply With Quote
Old 09-23-2007, 07:24 PM
  #22  
Tech Champion
Thread Starter
iTrader: (34)
 
F N CUDA's Avatar
 
Join Date: May 2007
Location: Mission Viejo, So Cal
Posts: 5,841
Trader Rating: 34 (100%+)
Default

I just pm'd Mr. Black, funny you mention it!
Thanks for the tips.
I've heard that offroad can be hard on the hardcase lipos when the battery is warm.
F N CUDA is offline  
Reply With Quote
Old 09-23-2007, 07:33 PM
  #23  
Tech Fanatic
iTrader: (11)
 
kuzo's Avatar
 
Join Date: Jul 2005
Location: Connecticut
Posts: 948
Trader Rating: 11 (100%+)
Default

Originally Posted by magm20001 View Post
peak and orion same company?
yep
kuzo is offline  
Reply With Quote
Old 09-24-2007, 10:11 AM
  #24  
Tech Adept
 
TheBackmarker's Avatar
 
Join Date: Nov 2003
Location: Florida
Posts: 208
Default

Peak and Orion are not the same company, but they import the same products under different labels. That's my understanding. And yes the 3200's have a common problem of intermittent or no voltage at the terminals. I've seen several new right out of the box with this issue so I test them all before I sell them now. It has nothing to do with offroad or vibration or abuse. It is a manufacturing problem. I haven't seen a single problem with the 4800's though. I've sold dozens of both these packs and if the 3200 pack works the first time, you'll probably never have a problem. All Peak and Orion have to do is check them before they ship them and we won't be having this discussion.
TheBackmarker is offline  
Reply With Quote
Old 09-24-2007, 11:29 AM
  #25  
Tech Champion
Thread Starter
iTrader: (34)
 
F N CUDA's Avatar
 
Join Date: May 2007
Location: Mission Viejo, So Cal
Posts: 5,841
Trader Rating: 34 (100%+)
Default

Peak and Orion are under the same roof. Kyosho's roof.
I'll be making my return of the Peak Performance 3200 Lipo to Orion's service department at Kyosho in Lake Forest Calif. as per Orion's instruction.
F N CUDA is offline  
Reply With Quote
Old 09-24-2007, 07:12 PM
  #26  
Tech Champion
Thread Starter
iTrader: (34)
 
F N CUDA's Avatar
 
Join Date: May 2007
Location: Mission Viejo, So Cal
Posts: 5,841
Trader Rating: 34 (100%+)
Default

My batts worked great for several months, flying my TC around parking lots mostly. Never hooked em up backwards (really!) or ran em too low.
I didn't have any problems with em til I started racin offroad again. They held up to a few good crashes, nothing outrageous but good ones.
They each gave up after nosedive type biffs. Must have been just enough cuz I'm sure it was a jolt that killed em.
Anyway I got the one I still have to Kyosho/Orion/Peak this afternoon so we'll have to see how it goes.
F N CUDA is offline  
Reply With Quote
Old 09-26-2007, 08:42 PM
  #27  
Tech Champion
Thread Starter
iTrader: (34)
 
F N CUDA's Avatar
 
Join Date: May 2007
Location: Mission Viejo, So Cal
Posts: 5,841
Trader Rating: 34 (100%+)
Default

Brand new lipo pack delivered to my door in 2 days!!!!!!!! No questions asked.
Kyosho/Orion/Peak ROCKS!
Thanks a bunch guys, I'll be at the track on Friday nite!
F N CUDA is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service