R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Reply
 
Thread Tools Search this Thread
Old 08-20-2007, 02:09 PM   #1
Tech Regular
 
Jeff K.'s Avatar
 
Join Date: May 2007
Location: Chatsworth, CA
Posts: 410
Trader Rating: 18 (100%+)
Send a message via AIM to Jeff K.
Default ICE Charger Button Problem

My right button has crapped out on me. I haven't been having too much luck these past few days, GTX crapped out yesterday. I opened it up to see if it was just a bad solder joint, and when it was open, it worked fine. I closed it up again, but it just didn't want to work. It's not really that big of a deal, I just have to use the left button and scroll all the way through. Even though I got it new on eBay, Hobbico won't warranty it, but they can service it for $30+, which is ridiculous. Has anyone else had this problem?
__________________
Losi 8ight 2.0
Spektrum DX3S
Jeff K. is offline   Reply With Quote
Old 08-20-2007, 06:29 PM   #2
Tech Master
 
joeling's Avatar
R/C Tech Elite Subscriber
 
Join Date: Jun 2005
Location: Malaysia
Posts: 1,304
Trader Rating: 6 (100%+)
Default

Hi,

I have a similar problem. One of the buttons is not working anymore. On top of that, the click wheel has also gone south. Scrolling with the wheel is now a random walk. Despite that, the unit still charges fine so just have a bear wih it. Well, I bought a second unit so I use 2 units now.

Regards,
Joe Ling
joeling is offline   Reply With Quote
Old 08-20-2007, 11:23 PM   #3
Tech Master
 
Join Date: Jun 2005
Location: Brisbane. Australia
Posts: 1,820
Trader Rating: 5 (100%+)
Default

what u probably find is over continual use of pushing th buttons down they have sliped down the switch they activate all u need to do is pull the button up the shaft about a miollimetre or less and it should help with your problem
__________________
Josh P
to make Keith happy
Corally phi
M11
SP GT
SP 5.5,17.5
aus jd 2703 is offline   Reply With Quote
Old 08-21-2007, 12:14 AM   #4
Tech Regular
 
Jeff K.'s Avatar
 
Join Date: May 2007
Location: Chatsworth, CA
Posts: 410
Trader Rating: 18 (100%+)
Send a message via AIM to Jeff K.
Default

Thanks for the replies. I tried that, but no luck. I realized that it worked when you pushed the button and wiggled it a bit, so I dremeled some material out from the box channel that it has to keep it traveling just up and down. Looks stock, and works, just needs to be pushed a little harder, so I'm happy.
__________________
Losi 8ight 2.0
Spektrum DX3S
Jeff K. is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
ICE charger problem dgraham225 Radio and Electronics 9 03-19-2008 08:54 PM
Motors,batteries,Trinity Dyna Pulse,Team Orion Advantage Charger,Turbo30 5 button FST WisRacr1 R/C Items: For Sale/Trade 38 03-20-2006 05:50 PM
3-Button Turbo Charger Danny-The-Dude R/C Items: For Sale/Trade 1 11-02-2005 11:24 AM
5-Button Turbo Charger Danny-The-Dude R/C Items: For Sale/Trade 2 11-02-2005 11:14 AM
Charger Problem Franky Australian Racing 13 07-24-2003 07:15 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 01:56 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net