R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Reply
 
Thread Tools Search this Thread
Old 08-05-2007, 09:04 AM   #1
Tech Adept
 
Join Date: Jul 2007
Posts: 182
Trader Rating: 6 (100%+)
Default Evader ST problem

I have an Evader ST running stock electronics, and an Epic 27 turn motor, I'll be running it, hit a bump and it just stops, I lightly kick the car and it starts running again. Also reverse doesn't seem to work always, you can hear the engine humm like it's trying to go but is jammed, again a kick usually gets it going. I've heard this could be symptoms of a hung brush, but I don't know anything about brushes, what do I have to do to fix that?
parnelli97 is offline   Reply With Quote
Old 08-05-2007, 09:57 AM   #2
Tech Regular
 
Join Date: Mar 2004
Location: Albuquerque, New Mexico
Posts: 278
Trader Rating: 20 (100%+)
Default

Yep, sounds to me like a case of a stuck brush. If you haven't cleaned your motor lately i recommend you do so. To clean the brushes you just unlatch the spring and then unhook it from the post.. The brush should just slide out after the spring is out of the way. If your motor needs to be cleaned, it probably also needs to have the comm cut and the brushes cleaned up with a 'comm stick' or some other way of cleaning them off.
rc10gt82 is offline   Reply With Quote
Old 08-05-2007, 10:25 AM   #3
Tech Adept
 
Join Date: Jul 2007
Posts: 182
Trader Rating: 6 (100%+)
Default

I just took the motor apart and found a very small washer stuck to the magnet inside, I'm thinking that could be part of the problem. But how do you clean the brushes, and I don't have a comm stick, is there anything else I can use to clean it?
parnelli97 is offline   Reply With Quote
Old 08-05-2007, 11:53 PM   #4
Tech Regular
 
Join Date: Mar 2004
Location: Albuquerque, New Mexico
Posts: 278
Trader Rating: 20 (100%+)
Default

Back in the day, a friend of mine used one of those pink stick erasers. I hope you know what im talking about, cause I don't know a better way to describe it without a picture.

Edit - Found a picture
rc10gt82 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Big sale! 4 trucks! XXX-T MF1, HPI NMT, Evader BX roller, Evader ST Pro Syber Serulean R/C Items: For Sale/Trade 69 02-03-2008 09:37 PM
Nitro Evader problem Profyrfyter Nitro Off-Road 4 08-13-2007 01:14 PM
Evader ST problem parnelli97 Rookie Zone 3 08-06-2007 10:01 PM
Duracrap evader diff problem Cardboard Electric Off-Road 7 11-19-2004 06:54 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 04:27 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net