Clutch Problem

Old 04-06-2003, 09:03 AM
  #1  
Tech Adept
Thread Starter
 
B3boy's Avatar
 
Join Date: Aug 2001
Location: Napperville, Illinois
Posts: 166
Arrow Clutch Problem

I just broke in my new Fantom FR12 in my RC10GT, but i have a problem.

When I give the engine throttle, the car only inches forward. I know the tires are glued and the nuts are tightened, so I am thinking its a clutch problem. I never trimmed the clutch shoes if that has anything to do with it.

Help me if you can
thanks
B3boy is offline  
Old 04-06-2003, 09:57 AM
  #2  
Tech Elite
 
popsracer's Avatar
 
Join Date: Oct 2002
Location: "Hot, Sunny Southern California"
Posts: 3,120
Default Clutch Problem

B3boy;

I doubt it's a Clutch Shoe problem (unless theres oil on them). Trimming the Clutch Shoes makes them lighter and engage at a higher RPM.
What MAY be your problem is the slipper clutch adjustment. Tighten the slipper nut ALL the way down, then back it off 1/8 to 1/4 of a turn.
If that doesn't work, check the drive axle pins and make sure they're not missing, broken or the wheels are stripped.

Hope I helped.
popsracer is offline  
Old 04-06-2003, 12:20 PM
  #3  
Tech Adept
Thread Starter
 
B3boy's Avatar
 
Join Date: Aug 2001
Location: Napperville, Illinois
Posts: 166
Default

ok, thanks, I never thought bout the slipper clutch, i bet thats it, thanks
B3boy is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell or Share My Personal Information -

Copyright © 2023 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.