R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Reply
 
Thread Tools Search this Thread
Old 03-24-2007, 06:43 PM   #1
Tech Regular
 
Join Date: Jun 2006
Posts: 390
Default ENGINE PROBLEM

I was breaking in my new traxxas 3.3 engine, got to the 4th tank, and now it wont start. It wont even try if I dont give it full throttle, then it will rev but cut off. It was running perfect until then. Maybe a dead glow plug? because it was still hot when i tried to restart it. Please help me, I need it for tomorrow.
derricklong38 is offline   Reply With Quote
Old 03-24-2007, 07:59 PM   #2
Tech Master
 
LOWGEARED's Avatar
 
Join Date: Oct 2006
Location: Kokomo , Indiana
Posts: 1,137
Trader Rating: 2 (100%+)
Default

Check the glow plug and try leaning it off abit!!!!
__________________
MEGA BAJA HOP UP LIST:
GPM BLUE ALUMINUM THREADED SHOCKS
LOSI YELLOW SPRINGS
GPM BLUE ALUMINUM A-ARM SET U/L
ACNCM ENORMOUS COOLING HEAD
INTEGY SWAY BAR KIT
VANTAGE HX5 TIRES

Micro baja
Micro raminator

ALUMINUM PIVOT BLOCKS
FULLY ADJUSTABLE C/C/S
LOWGEARED is offline   Reply With Quote
Old 03-27-2007, 02:13 AM   #3
Tech Addict
 
Join Date: Nov 2006
Posts: 354
Default

Use the Traxxas customer service number! They are your revos best friend.
8ightScale/CJP is offline   Reply With Quote
Old 03-27-2007, 02:32 AM   #4
Tech Addict
 
steelhawke's Avatar
 
Join Date: Jan 2007
Location: Junction City, WI
Posts: 661
Trader Rating: 5 (100%+)
Send a message via Yahoo to steelhawke
Default

Sounds like a glowplug possibly failed, plus check the lid on the tank make sure its sealed. Make sure the fuel is getting forced down the fuel line. Place a fingertip over the exhaust tip to help "prime" the fuel up to the carb while trying to start the first 3 seconds or so. I recently had both issues happen to me on my jato 3.3 during break in.
__________________
Losi Lover..!
steelhawke is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
engine problem what happened? Nitro Off-Road 6 11-23-2007 05:27 AM
engine problem tony montana Nitro On-Road 10 06-17-2007 07:50 PM
problem with engine longlive289s Nitro On-Road 11 05-09-2007 02:59 PM
problem with NR engine eduardo_garcia Onroad Nitro Engine Zone 0 11-06-2006 01:10 PM
engine problem bleach1 Nitro On-Road 14 03-13-2004 01:06 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 11:55 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net