R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Reply
 
Thread Tools Search this Thread
Old 03-22-2007, 04:09 PM   #16
Tech Master
 
Join Date: Jan 2007
Posts: 1,056
Trader Rating: 10 (100%+)
Default

maybe their customer service has gotten better but i used to run lrp till the worlds that were at the old minnereg here in florida. i gave the guy two speedos on the very first day before practice started and asked if i could get some new wires and new cases. nothing big just a little maintence and i needed them by the start of 4wheel 4 days from when i gave them too him. long story short i got them back at the end of the race and they had not even been touched so i have turned to novak and have never looked back
punkracer24 is offline   Reply With Quote
Old 03-22-2007, 04:27 PM   #17
Tech Fanatic
 
AzBobby's Avatar
 
Join Date: Jan 2007
Posts: 312
Trader Rating: 1 (100%+)
Default

I havent had a single product of theirs that hasn't giving up the ghost. and up until the last charger that fried i was able to replace through my shop and he took care of sending it back and getting a new one to replace it. the only reason i havent sent it yet, is i keep forgetting. but what ever the outcome is it will be forsale. i have had such bad luck with their products it surprises me that the factory guys that are running lrp ever finish a big main. glad it works for them.

My Orange has never let me down.
__________________
GO TECH
AzBobby is offline   Reply With Quote
Old 03-22-2007, 04:32 PM   #18
Tech Addict
 
Join Date: Oct 2005
Location: Plain City, OH
Posts: 727
Trader Rating: 6 (100%+)
Default

Yep. I had a QC2 that the switch wires pulled out of the case. Sent it in to "repair", and a month later when I called they say they can't open the case, you can get it replaced for $55, After I say OK, it takes about another month and a half, and several calls before I got the replacement back.

Not sure how they "repair" anything if they can't open the case?????
__________________
XXX-CR, XXX-T CR, XXX-SCT (Kertez conversion)
CRCRC.COM
Sneaky Pete Racing
Hammer Racing
Bike racer is offline   Reply With Quote
Old 03-22-2007, 06:15 PM   #19
Tech Master
 
trebor's Avatar
 
Join Date: Nov 2006
Posts: 1,338
Trader Rating: 6 (100%+)
Default

I had a LRP Speedo fry on me due to crimp in wiring, my fault. Sent it out and got it back 1 1/2 weeks later. Very impressed with customer Care.
I am going to try Tekin though.

Thanks LRP.
trebor is offline   Reply With Quote
Old 03-22-2007, 06:30 PM   #20
Tech Champion
 
tony montana's Avatar
 
Join Date: Aug 2002
Location: Leonardtown Md.
Posts: 6,154
Trader Rating: 66 (100%+)
Default

I had a 2 run old qc2 in my xxx4 go up in smoke. wasnt overgeared or anything. About 3 minutes into my second quailfier it stopped and went up in smoke. I was so pissed I didnt even bother to send it to lrp, I just went and bought a gtx and have had zero issues
__________________
K.C. Guy- TLR- Horrizon Hobby- Team Trinity- 92 zero designs- AKA
tony montana is offline   Reply With Quote
Old 03-23-2007, 12:27 PM   #21
Tech Master
 
johnnyboy's Avatar
 
Join Date: Sep 2006
Location: Ontario, Canada
Posts: 1,634
Trader Rating: 28 (97%+)
Default

I was wondering the same thing. I had 2 Sphere Comp's blow within about 10 minutes of each other (one in my 2wd...caught fire... and one in my 4wd...throttle stopped working).I thought I had bad Karma as I had no issues with them before and quite like them performance wise. A few people told me there were flaws with the Sphere Comps. Mine are not under warranty anymore so I'll have to pay to get them fixed. Although it's been about a month since I sent them in, the guys at LRP have always been up front and pretty cool over the phone (I followed up every couple of weeks). They are waiting for the new Sphere Comp's to come in (told me a couple more weeks). I am just itching to get racing again. I'll still run the Sphere Comps though (I hate the fans and huge cap on the Novaks!)
__________________
"Almost Live Race Coverage": www.johnnyboy.ca

.:Team Orion : JConcepts : B-Fast RC:.
johnnyboy is offline   Reply With Quote
Old 03-23-2007, 12:33 PM   #22
Tech Legend
 
Wild Cherry's Avatar
 
Join Date: Aug 2001
Location: TRCR Modified Driver
Posts: 22,595
Default

Quote:
Originally Posted by tony montana
I had a 2 run old qc2 in my xxx4 go up in smoke. wasnt overgeared or anything. About 3 minutes into my second quailfier it stopped and went up in smoke. I was so pissed I didnt even bother to send it to lrp, I just went and bought a gtx and have had zero issues
Big mistake !!!

You should send them to Ae and they will send you replacements .....

JohnnyBOY !!!

When you get um back you will be very ,very, impressed with the 2007 Comp Sphere....
__________________
Any driver can copy a great set up, a Champion however will steal it .
If Jesus returned as a Rc car he be a Rc10 B5M
George W. Cherry
Wild Cherry is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
b4/t4 problems trdsupra88 Electric Off-Road 12 03-15-2008 10:52 PM
JR Z-1 Problems...need help! pumpkinfish Radio and Electronics 3 10-24-2007 05:31 PM
Problems.. Oasis Chat Lounge 9 01-16-2006 08:41 AM
tc3 one way problems dontfeelcold Australian Racing 7 12-31-2003 04:34 PM
Set Up Problems Griz Australian Racing 5 12-05-2003 12:44 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 02:23 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net