Go Back  R/C Tech Forums > General Forums > Electric Off-Road
Damn @#$! Radio piece of crap! >

Damn @#$! Radio piece of crap!

Damn @#$! Radio piece of crap!

Old 03-23-2003, 04:21 AM
  #1  
Tech Adept
Thread Starter
 
Samma3l's Avatar
 
Join Date: Feb 2003
Location: Self-Proclaimed Internet Celebrity
Posts: 238
Default Damn @#$! Radio piece of crap!

I am in the process of making my first nitro MT and am up to the lovely stage where I install the radio. My problem is that when I test the servos and receiver nothing happens. I know that all components work because I have tried them out on one of my electric cars. I do get one servo workin however when I plug the battery into a servo port, instead of battery port. The receiver does have BEC and I am suspecting this may have something to do with it (though i dont see how). I have tried to connect the battery in every position in the battery port, yet still nothing happens. Is anybody familiar with this and do they know the remedy?



thanks if you help me

Last edited by Samma3l; 03-23-2003 at 04:55 AM.
Samma3l is offline  
Old 03-23-2003, 06:49 AM
  #2  
Tech Elite
 
sosidge's Avatar
 
Join Date: Dec 2001
Location: Bristol, UK
Posts: 4,277
Default

Sounds like the connections in the battery slot are faulty.
sosidge is offline  
Old 03-23-2003, 01:31 PM
  #3  
Tech Adept
Thread Starter
 
Samma3l's Avatar
 
Join Date: Feb 2003
Location: Self-Proclaimed Internet Celebrity
Posts: 238
Default

ive checked all that and even opened up the receiver to see if it was something inside. still no dice.
Samma3l is offline  
Old 04-17-2003, 12:52 PM
  #4  
Tech Adept
 
Join Date: Mar 2003
Location: Gillette, WY
Posts: 133
Default

You might try lifting the metal pieces on the side of the plug with a small screwdriver. I had the same problem with my steering servo in my XX-4 until I did this.
mr. chicken is offline  
Old 04-23-2003, 03:36 PM
  #5  
Suspended
 
Join Date: Apr 2003
Posts: 403
Default

What radio is it?
R C king is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell or Share My Personal Information -

Copyright © 2023 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.