R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Reply
 
Thread Tools Search this Thread
Old 01-23-2007, 09:16 PM   #1
Tech Adept
 
Join Date: Feb 2006
Posts: 185
Default KO Propo 3014 Servo Problem

well i picked this servo up today and got it put in my RC18MT..but for some reason now when i power it up it just makes a hard right and wont move from there...i tried reversing it and get nothing...i also tried the Steering Trim and all it does is move about 2mm when i rotate it the full way...

i am using a Mamba 25ESC and 5400 motor and the stock TX and RX....

do you need a special radio to use Digital Servos?

anyone know why it makes hard right upon power up?

THNX
Duggy
duggyb is offline   Reply With Quote
Old 01-24-2007, 07:29 AM   #2
Tech Adept
 
Join Date: Feb 2006
Posts: 185
Default

anyone?

THNX
Duggy
duggyb is offline   Reply With Quote
Old 01-25-2007, 09:23 AM   #3
Tech Master
 
scoobydo's Avatar
 
Join Date: Sep 2004
Location: Bay Area San Jose
Posts: 1,501
Trader Rating: 1 (100%+)
Default

Quote:
Originally Posted by duggyb
anyone?

THNX
Duggy
I had problems with the newer KO digital servos.
They require a ceratin amount of current that some ESC's don't provide.
I was using a QC2 and it wouldn't work.
Try it on another ESC and see if it works.
If it does, you just need to get more power to it.
Perhaps a Cap on the reciever.
If that doesn't work than your out of luck, your ESC won't work with the Servo.
Also, Maybe your Servo is bad?
I would definitely try another ESC to see if that is the problem. Perhaps a friends or another of your cars.
scoobydo is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
KO Propo PDS-3014 ICS Micro servo Fred Perkins R/C Items: For Sale/Trade 10 12-14-2007 06:52 PM
KO propo EX-1 Mars! Problem with servo tt01-demon Australian Racing 8 03-15-2007 07:18 AM
KO Propo 3014 Servo Problem duggyb Micro and Mini Scales 3 01-25-2007 09:57 PM
KO 3014 Digital Servo dr_hfuhuhurr Micro and Mini Scales 2 06-27-2006 07:29 AM
weird ko propo servo problem VenomWorldOrder Australian Racing 6 01-09-2003 03:21 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 03:11 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net