R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Reply
 
Thread Tools Search this Thread
Old 01-10-2007, 04:17 PM   #1
Tech Rookie
 
Join Date: Jan 2007
Posts: 1
Angry E-maxx 7 cell problem

I got an E-maxx for Christmas and just purchased two 7-cell battery packs to run in it. The problem is that when I plugged it in, there is no juice. To answer several obvious questions first ... I charged the batteries using a peak charger the night before (and they took the expected amount of time to charge), secondly there was a little life, in that the ESC would show green lights when the trigger was pulled full throttle, and blink green lights when full throttle in reverse. In addition, the steering worked and would respond, as did the shifting from 1st to 2nd gear, just no power to run the wheels.

I had just run the car on two 6-cell sticks, where it ran just fine to completion. Is there any "programming" that needs to be done to the ESC to take the 16.8 volts? Could the batteries themselves be bad? Any thoughts would be greatly appreciated. Thanks!

~Jack
hasqual is offline   Reply With Quote
Old 01-10-2007, 04:35 PM   #2
Tech Elite
 
streetracer745's Avatar
 
Join Date: Oct 2006
Posts: 2,291
Send a message via AIM to streetracer745
Default

an emaxx speed control can only take 14.4 volts. your 7 cells are useless in the truck. the speedo limits at 14.4 input volts. your trying to put too much power through it.
__________________
89% of Revos are racers. If your Revo can out-bash and out-run a Savage, put this in your sig.

SMOKE TIRES, NOT DRUGS

46.7% of all statistics are made up on the spot and have no real value or truth.
streetracer745 is offline   Reply With Quote
Old 01-10-2007, 04:36 PM   #3
Tech Adept
 
Join Date: Jul 2006
Posts: 158
Trader Rating: 3 (100%+)
Default

no programming needed, it's probably a dud ESC or an obvious problem we havent seen.

if you have a chance, get a real esc from an e-savage.

Cheers
aussiebuddha is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
New E Maxx EVX-2 problem sir miles Electric Off-Road 2 12-31-2007 01:00 AM
Problem with Cell Master raidvs Australian Racing 1 01-15-2007 01:22 AM
t-maxx problem lovecrime720 Monster Trucks 5 02-13-2006 11:50 AM
s-maxx problem? Smaxxblue Monster Trucks 3 05-08-2005 07:35 PM
Problem with my t-maxx BIGGERSTUFF Electric Off-Road 2 09-23-2003 01:25 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 01:47 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net