R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Reply
 
Thread Tools Search this Thread
Old 11-10-2006, 07:05 PM   #1
gio
Tech Initiate
 
Join Date: Jun 2006
Posts: 29
Unhappy jato+rain=something wrong!!!

well i started up my jato fine right after i got home from skool and it was raining not hard but medium. so i was like nothing will happen to it soo i ran it for about 5 min or so and i took it inside. and then i came back like around 6 and tried to start it up and when i put the ez starter wand thingy in where it starts it up it lights up 2 lights and it usually only light up one that says "motor". and when i tryed it it lite up the light that is next to it that says "glow plug" and it didn't even do anything. do u think that the rain did something to the ez start??? o and after i ran it in the rain i got a blow dryer and dried alot of the water that was on it.
gio is offline   Reply With Quote
Old 11-11-2006, 09:15 AM   #2
gio
Tech Initiate
 
Join Date: Jun 2006
Posts: 29
Default

bumpo come on peeps help me!!! please
gio is offline   Reply With Quote
Old 11-11-2006, 09:20 AM   #3
Tech Champion
 
MikeXray's Avatar
 
Join Date: Oct 2006
Location: New York
Posts: 5,749
Trader Rating: 73 (100%+)
Default

you burnt out your glow plug, probably not related to the rain, but get a new one.
__________________
Mike L. Awesomatixusa.com | TQWire.com | Islandraceway.com |JacksonRCracing.com | Horsham RC | Sweepracingusa.com
MikeXray is offline   Reply With Quote
Old 11-11-2006, 09:59 AM   #4
gio
Tech Initiate
 
Join Date: Jun 2006
Posts: 29
Default

could i get any glow plug?? what kind should i get?? i only have 6 buxs lol
gio is offline   Reply With Quote
Old 11-11-2006, 10:57 AM   #5
gio
Tech Initiate
 
Join Date: Jun 2006
Posts: 29
Default

could i use ANY glow plug?? or does it have to be a special one for the ez start???
gio is offline   Reply With Quote
Old 11-11-2006, 11:36 AM   #6
Tech Elite
 
streetracer745's Avatar
 
Join Date: Oct 2006
Posts: 2,291
Send a message via AIM to streetracer745
Default

could most likely use any standard glow plug. make sure the electric motor is turning. and make sure the plug is connected with the glow plug right. 6 buxs is plenty for a glow plug. you can get one for like 2. so no worries. make sure everything is connected. and if it dont turn over, then you need to get a plug and possibly change the electric start motor.
__________________
89% of Revos are racers. If your Revo can out-bash and out-run a Savage, put this in your sig.

SMOKE TIRES, NOT DRUGS

46.7% of all statistics are made up on the spot and have no real value or truth.
streetracer745 is offline   Reply With Quote
Old 11-11-2006, 12:28 PM   #7
gio
Tech Initiate
 
Join Date: Jun 2006
Posts: 29
Default

hey thanx every1 for the help but i fixed it. it wasn't the glow plug cause i took it out and tried it with my maximum st and it worked fine and it wsa heating up and everything. it was when i flipped my jato yesterday when it was raining the black power wire that goes to the ez start fell off so right when i put it on it started right up. thanx every1
gio is offline   Reply With Quote
Old 11-11-2006, 12:43 PM   #8
Tech Elite
 
streetracer745's Avatar
 
Join Date: Oct 2006
Posts: 2,291
Send a message via AIM to streetracer745
Default

yeah i didnt think of that. i soldered mine on so that wouldnt happen. haha. but now its a pain to take it off
__________________
89% of Revos are racers. If your Revo can out-bash and out-run a Savage, put this in your sig.

SMOKE TIRES, NOT DRUGS

46.7% of all statistics are made up on the spot and have no real value or truth.
streetracer745 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rain rain go away... suck_my_exhaust Singapore R/C Racers 0 12-18-2007 10:01 PM
looking for pit rain tires? J.Gonzalez Electric On-Road 0 07-28-2007 07:49 PM
Rain Black_Widow Nitro On-Road 0 01-25-2007 08:32 AM
Hi all using nitro car in the rain karlmaddock Nitro On-Road 5 04-07-2006 03:24 PM
Rain, rain go away..... devious17 Malaysian R/C Racers 2 01-08-2006 04:41 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 02:04 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net