R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Reply
 
Thread Tools Search this Thread
Old 10-26-2006, 04:12 PM   #1
Tech Rookie
 
Join Date: Oct 2006
Posts: 1
Default hpi rush evo dont run right

I have jus bought a hpi rush evo i run it in like it said in the book but wen i try and go flat out it dont wanna know it stalls and the doesnt restart anyone have any idea on what i can do to sort it out?
cherokee28 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rush evo help FrancisH Electric Off-Road 0 08-09-2006 08:56 AM
HPI RUSH EVO bumm_off_street Electric Off-Road 0 03-14-2006 08:16 AM
Could I put a .21 in my rush evo? silacomalley Electric Off-Road 2 09-09-2005 04:51 PM
rush RushRacing R/C Items: For Sale/Trade 0 01-19-2003 10:42 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 03:48 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net