Go Back  R/C Tech Forums > General Forums > Electric Off-Road
Brand new stock Arrma Senton ESC/Motor problems >

Brand new stock Arrma Senton ESC/Motor problems

Brand new stock Arrma Senton ESC/Motor problems

Old 07-25-2020, 12:40 PM
  #1  
Tech Regular
Thread Starter
iTrader: (11)
 
Join Date: Jul 2010
Posts: 271
Trader Rating: 11 (100%+)
Unhappy Brand new stock Arrma Senton ESC/Motor problems

Well I let my coworker drive my 1/8 buggy with the 1/8th sidewinder brushless combo and he was hooked on how fun it was and picked himself up an Arrma Senton 3s. He said it was fun but had this weird issue where it took a second for full throttle to engage. I gave it a test drive and sure enough if the vehicle is stopped and you floor it, it goes slow for a second and then full power kicks in. Rather annoying. If the vehicle was in tall grass or had any sort of resistance at all it would try to move and then cut out because it couldn't get moving fast enough to engage its full power. If this happened three times the motor stopped working completely and you only had steering and you had to turn your ESC on and off again to get it to work again. I told him to take it back to the hobbyshop as I figured something was wrong with it, he demonstrated that if he held his foot against the truck it would just not go at all. Hobby store claimed this was normal and it was just cogging. My 1/8 buggy has the unsensored sidewinder ESC, so it cogs if I try to crawl around and super low speed but whenever I fully engage my throttle, stopped or not, it fully engages at the vehicle. Does anyone have any idea on what is going on with my friends new Senton?

Arrma Senton 3S with BLX100
Gens Ace 5000mah 2s 50c
Awanfi 5000mah 3s 60c
Liquid_Ice is offline  
Old 07-26-2020, 06:40 AM
  #2  
Tech Initiate
 
Join Date: Jul 2020
Posts: 38
Default

I've never had one but hear the rtr radio -stx2 I think- is horrible and delay in input is normal for them. The radio could account for the delay in full engagement but, if it's ok, not for it not moving at all if there is minimum pressure against it. Check that all wires are fully plugged in and there isn't binding in the drivetrain, motor mesh. Otherwise, could be faulty tx/rx, esc or motor. A tactic ttx300 is a good inexpensive radio replacement.

Sounds like LHS just brushed you off.
mosquito is offline  
Old 07-26-2020, 06:58 AM
  #3  
Tech Elite
 
the rc guy's Avatar
 
Join Date: Aug 2016
Location: Detroit
Posts: 2,217
Default

contact arrma via Email it is the esc not the radio.
the rc guy is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.