Go Back  R/C Tech Forums > General Forums > Electric Off-Road
Revo 2.0 gearing/questions >

Revo 2.0 gearing/questions

Revo 2.0 gearing/questions

Old 07-24-2020, 06:37 PM
  #1  
Tech Regular
Thread Starter
iTrader: (4)
 
Join Date: Aug 2013
Location: northwest pa
Posts: 410
Trader Rating: 4 (100%+)
Default Revo 2.0 gearing/questions

hey guys....just bought a revo 2.0 a few days ago. I've been out of it for a few years. Im a little dissapointed.....

Out of the box I had a few 5200 20c batteries. Stock gearing was slow and far from punchy.....upgraded to 19/46....lost all of the low end.....changed to 19/54 had to Dremel the plate to get the gear to mesh correctly....

Is it the batteries? I remember my 1st gen revo doing backflips in the road. I have 5200 60c on order but im struggling with the gearing. It seems like everything's much more limited than it used to be.

I would like to at least pull the front end and bash through the yard around 50.

My buddies 3.3 revo spanked me.....i remember not being able to control the dang thing.


Advice? Thanks in advance!
thake618 is offline  
Old 07-25-2020, 02:13 PM
  #2  
Tech Regular
Thread Starter
iTrader: (4)
 
Join Date: Aug 2013
Location: northwest pa
Posts: 410
Trader Rating: 4 (100%+)
Default

.
thake618 is offline  
Old 07-25-2020, 02:32 PM
  #3  
Tech Elite
 
the rc guy's Avatar
 
Join Date: Aug 2016
Location: Detroit
Posts: 2,217
Default

you have 20 c batteries ..sorry try some 50+c batteries,mine has a 4 cell(2x2) 5600mah 100C batts..its a beast...lipo hv...
the rc guy is offline  
Old 07-26-2020, 12:43 AM
  #4  
Tech Regular
Thread Starter
iTrader: (4)
 
Join Date: Aug 2013
Location: northwest pa
Posts: 410
Trader Rating: 4 (100%+)
Default

Originally Posted by the rc guy View Post
you have 20 c batteries ..sorry try some 50+c batteries,mine has a 4 cell(2x2) 5600mah 100C batts..its a beast...lipo hv...
I have 75c 5200 coming tommorow. I was assuming that was the issue, it was just what I had laying around. What gearing are you running?
thake618 is offline  
Old 07-26-2020, 12:33 PM
  #5  
Tech Regular
Thread Starter
iTrader: (4)
 
Join Date: Aug 2013
Location: northwest pa
Posts: 410
Trader Rating: 4 (100%+)
Default

Originally Posted by the rc guy View Post
you have 20 c batteries ..sorry try some 50+c batteries,mine has a 4 cell(2x2) 5600mah 100C batts..its a beast...lipo hv...

3s 5200mah 60c..... nothing impressive wont lift the tires....just boring. Esc is fine with no lights. I recaled the tx as well and verified it was in sport mode. Switched back to stock gearing as well 15/54
thake618 is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.