R/C Tech Forums

R/C Tech Forums (https://www.rctech.net/forum/)
-   Electric Off-Road (https://www.rctech.net/forum/electric-off-road-4/)
-   -   Redcat Terremoto v2 steering problems. (https://www.rctech.net/forum/electric-off-road/1063451-redcat-terremoto-v2-steering-problems.html)

Kjanora10 04-08-2020 12:49 PM

Redcat Terremoto v2 steering problems.
 
I have a redcat terremoto v2. When I turn it on the steering wheels instantly go all the way to the left. After they are stuck in that position they don't move when I try to steer them. First I replaced the steering servo and it did the same thing. It went to the left then didn't respond. So then I checked to make sure it wasn't the receiver by switching the throttle and steering wire. The throttle worked perfect being switched. So it's not the receiver. So my only guess is that's it's the controller. What do you guys think it is?

Biz73 04-09-2020 09:43 AM

Is the steering trim set all the way to one side?

Mirkinator 04-09-2020 11:11 AM


Originally Posted by Biz73 (Post 15622308)
Is the steering trim set all the way to one side?

This or its possible the end points got messed up. Try to rebind your controller with all the dials to 0. Not sure if this is the radio you have but..

https://dealer.redcatracing.com//man...CENRMANUAL.pdf

Kjanora10 04-09-2020 11:19 AM

No the steering trim is not set to one side.

Kjanora10 04-09-2020 11:22 AM

It goes all the way to the left and then doesn't respond to the transmitter anymore. I tried it with 2 steering servos.

lowspark 04-09-2020 03:45 PM

Disconnect the steering arm from the servo.
Turn on the car
Reconnect the steering arm centering the arms..

Note check first, with the steering arm disconnected, will the servo go left and right now using the radio?


All times are GMT -7. It is currently 03:43 AM.

Powered By: vBulletin v3.9.3.8
Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.