Broken Telluride

Reply

Old 02-09-2019, 07:53 PM
  #1  
Tech Rookie
Thread Starter
 
Join Date: Feb 2019
Posts: 3
Default Broken Telluride

Hello, I have a Traxxas Telluride and I built a cool little jump and was stupid and built a pond right beside it. I was standing a distance away and hit the jump, flying into the pond. I ran over there and got it out as fast as I could. It turned off, and I turned it back on. I drove it around the yard a little bit and it started smoking white smoke really bad and filled up the body and ran under the edges until you couldn’t see the car anymore, I couldn’t see anything that happened to it after the smoke went away and it smelled so bad I had to leave it outside for a couple of days. Does anyone know what I have to do to fix this? Thanks.
jrw653 is offline  
Reply With Quote
Old 02-10-2019, 12:33 PM
  #2  
Tech Fanatic
iTrader: (66)
 
Taman's Avatar
 
Join Date: Jun 2008
Location: GC, Aust
Posts: 845
Trader Rating: 66 (100%+)
Default

Can you tell which part the bad smell was coming from? Apparently your vehicle has waterproof electronics so the water should normally cause issues unless something shorted out. Can you take it back to where your bought it?
Taman is offline  
Reply With Quote
Old 02-10-2019, 04:19 PM
  #3  
Tech Addict
iTrader: (17)
 
Join Date: Jan 2017
Location: Seattle
Posts: 638
Trader Rating: 17 (100%+)
Default

My guess is it was the battery that went up in smoke. Depending on the extent of the damage, you may need new electronics.

Next time something like this happens just disconnect the battery immediately and let things dry out before trying again.
Tbuggy is offline  
Reply With Quote
Old 02-11-2019, 07:26 PM
  #4  
Tech Rookie
Thread Starter
 
Join Date: Feb 2019
Posts: 3
Default

Originally Posted by Taman View Post
Can you tell which part the bad smell was coming from? Apparently your vehicle has waterproof electronics so the water should normally cause issues unless something shorted out. Can you take it back to where your bought it?
I couldn’t tell because the smell was so strong. I think it might’ve been coming from the motor but the battery was to hot to touch. The place I bough it is far away and I think it might’ve close. I have another shop closer, but I just wanna get an idea of what it couldVe been.
jrw653 is offline  
Reply With Quote
Old 02-11-2019, 07:28 PM
  #5  
Tech Rookie
Thread Starter
 
Join Date: Feb 2019
Posts: 3
Default

Originally Posted by Taman View Post
Can you tell which part the bad smell was coming from? Apparently your vehicle has waterproof electronics so the water should normally cause issues unless something shorted out. Can you take it back to where your bought it?
Originally Posted by Tbuggy View Post
My guess is it was the battery that went up in smoke. Depending on the extent of the damage, you may need new electronics.

Next time something like this happens just disconnect the battery immediately and let things dry out before trying again.
It might’ve been the battery. Once the smoke cleared, the battery was to hit to touch. I just want to get a good idea of what it could’ve been. Thanks.
jrw653 is offline  
Reply With Quote
Old 02-12-2019, 03:56 AM
  #6  
Tech Fanatic
iTrader: (66)
 
Taman's Avatar
 
Join Date: Jun 2008
Location: GC, Aust
Posts: 845
Trader Rating: 66 (100%+)
Default

Given that the electrics are waterproof I’d be guessing the battery like Tbuggy suggested. See if the shop that’s closer can hook a battery up to see if it runs.
Taman is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service