Go Back  R/C Tech Forums > General Forums > Electric Off-Road
22SCT 3.0 Poor Brakes Whatís the problem. >

22SCT 3.0 Poor Brakes Whatís the problem.

Like Tree1Likes
  • 1 Post By RC*PHREAK

22SCT 3.0 Poor Brakes Whatís the problem.

Old 01-06-2019, 02:04 PM
  #1  
Tech Rookie
Thread Starter
 
Join Date: Jan 2019
Posts: 4
Default 22SCT 3.0 Poor Brakes Whatís the problem.

Ok, so I bought a 22SCT 3.0 second hand and the brakes were terrible, it wouldnít even lock the rear wheels up on dusty concrete. Truck has a hobbywing Justock system in it with a Motiv motor. I have the LCD box and have tried everything set brakes to 100 set reverse to 100 nothing. Truck came with an M12 TX I went through all the settings in there and nothing. Bound it to my Spectrum system and same thing. Reset the controller and esc to factory still same thing. Last night I went on a limb and through a castle sidewinder motor in it and same thing. Pulled the ESC and put a spare HW SC8 that used to make my 4x4 endo and same deal. Thereís gotta be something else going on. Itís not locking one tire and the other rolling, it literally stops like itís set at 25% brake. Truck has a Laydown ExoTek trans and slipper lockout running a 56 spur and 26 pinion. Asked a few racers at the track today and nobody could figure it out had several guys go through the TX and the ESC settings and nobody could figure it out.
mmulisha84 is offline  
Old 01-06-2019, 02:39 PM
  #2  
Tech Master
iTrader: (3)
 
RazorRC's Avatar
 
Join Date: Oct 2017
Posts: 1,455
Trader Rating: 3 (100%+)
Default

The Hobbywing Justock ESC has terrible brakes, itís the ESC. Itís barely enough for 2WD 17.5 buggy.
RazorRC is offline  
Old 01-06-2019, 04:47 PM
  #3  
Tech Rookie
Thread Starter
 
Join Date: Jan 2019
Posts: 4
Default

Originally Posted by RazorRC View Post
The Hobbywing Justock ESC has terrible brakes, itís the ESC. Itís barely enough for 2WD 17.5 buggy.
True, but the brakes are the same with my SC8 ESC and a Castle Motor, and that speed control stopped my Tekno 410 easily.
mmulisha84 is offline  
Old 01-06-2019, 06:51 PM
  #4  
Tech Rookie
Thread Starter
 
Join Date: Jan 2019
Posts: 4
Default

Yea I expected it from the Justock because my kids have that in there 2WD Slashís but when I put the SC8 in the truck today with a castle motor it was the same thing. Both setups the Motiv and Justock and the SC8 and Castle brake like 25% when set at 100% Dx5c radio, M12 radio, flysky radio, and a traxxas radio none made a difference. I canít figure what it could be but itís something with the truck.
mmulisha84 is offline  
Old 01-07-2019, 01:13 AM
  #5  
Tech Champion
iTrader: (141)
 
RC*PHREAK's Avatar
 
Join Date: Dec 2010
Posts: 5,208
Trader Rating: 141 (100%+)
Default

have you set the end point for brakes on your radio to 100% before re-calibrating the esc to the receiver?
RazorRC likes this.
RC*PHREAK is offline  
Old 01-07-2019, 05:34 AM
  #6  
Tech Fanatic
iTrader: (12)
 
Join Date: Dec 2004
Location: Olathe, KS
Posts: 989
Trader Rating: 12 (100%+)
Default

I've always noted that my Hobbywing ESC's seem to come with the default setting at 75%, so you'll have to hook up the program box to turn it up to 100%. I've run many of these and have never not been able to lock the rear wheels up. You just need to get the settings correct.
CTRJ is offline  
Old 01-07-2019, 05:38 AM
  #7  
Tech Rookie
Thread Starter
 
Join Date: Jan 2019
Posts: 4
Default

Yes EPAs are at 100 and weíre at 100 during calibration. And I have the LCD box and have turned the brakes to 100. Per hobby wings tech support the even asked I set the reverse EPA at 80% and calibrate it thinking the radio had a range the esc didnít like but that didnít do it.
I mean itís driveable but when the track is hooking and I canít slow down enough into the turns it makes for all the slashís beating me lol
mmulisha84 is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.