Fenwick did me wrong..

Reply

Old 02-27-2008, 11:00 PM
  #1  
Tech Regular
Thread Starter
iTrader: (13)
 
magilla66's Avatar
 
Join Date: Jun 2007
Location: San Diego, CA
Posts: 263
Trader Rating: 13 (100%+)
Default Fenwick did me wrong..

did a trade with fenwick here a while back. my losi jrxs-pro for his 1/18th micro stuff. now i did send him a mint condition roller. you can check out the pics in the for sale thread. i received my package and was cool with it so i left positive feedback for him. well i finally go over the roller i was sent and everything on it was pretty bad. both diffs were shot to hell, aluminum arms had screws broken off in them, hubs were very warped, stickers on the bottom of chassis covered a crack, and the extras that were sent to supposed built almost another roller were shot as well... we did talk about this via private messages and he assured me he would take care of the problems to either send me another roller or enough parts to cover the bad ones. that was on 2-08-2008. he said give a couple of days.. have not heard from him since.. here are the last messages.....

I thought that I sent u almost another chassis worth of spare parts if I didn't I will make it right. Give me a few days to get some money together to get those parts or even a new roller out to you I will pay for shipping. How do I fit those other cvds on bc the front lcds are bent and spur gears on and how do I rotate the front diff there is no screw and it looks glued.
[quote=magilla66] Quote:
Originally Posted by Fenwick




thank you for a great car, i just got it today i hope that you got urs today as well, that was a really quick shipment for us both shipping on saturday and having a holiday in between. Im always shippin usps now Both lipos had 100% charges on them when i sent them if you have any ?s about the charger just call or email me it is kind of confusing but it does the job. also both lipos were recently equalized as well.



hey fenwick, its phil from san diego.. got a big problem here bro.. i was just going over the rc18t i got from you and there are multiple problems. the front diff housing was superglued to the chassis, both front and rear diffs are stripped and shot, one of the rear arms still has a piece of a screw that was broken off and left in there. thrust bearings are way shot and the rear diff itself will not come loose. its like super glued or something.. at least help me out here as you got a clean kit from me in the trade. i can pay for shipping just repla
magilla66 is offline  
Reply With Quote
Old 03-04-2008, 11:35 AM
  #2  
Tech Regular
Thread Starter
iTrader: (13)
 
magilla66's Avatar
 
Join Date: Jun 2007
Location: San Diego, CA
Posts: 263
Trader Rating: 13 (100%+)
Thumbs down

well after multiple emails and phone calls going un-answered, i might as well chalk this up as a loss.. he doesnt even work at raceline motorworks anymore. oh well....
magilla66 is offline  
Reply With Quote
Old 03-05-2008, 09:56 PM
  #3  
Tech Regular
Thread Starter
iTrader: (13)
 
magilla66's Avatar
 
Join Date: Jun 2007
Location: San Diego, CA
Posts: 263
Trader Rating: 13 (100%+)
Default

damn.. he was just on yahoo messenger. i asked him what happened to making things right, then he logs off.. great..
magilla66 is offline  
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service