Like Tree1Likes

FEAR FARM RC RACEWAY

Old 02-02-2012, 02:08 PM
  #5041  
Tech Addict
iTrader: (7)
 
nadan805's Avatar
 
Join Date: Mar 2011
Location: PHX
Posts: 614
Trader Rating: 7 (100%+)
Default

I didnt realize how nice it is to race in phx. These guys in Augusta only race once a month! They dont seem to have the motivation to race like yall. You guys are awesome. Im stuck like chuck in GA untill july. I might have to go awol. How is the racing in mexico? Ha
nadan805 is offline  
Old 02-02-2012, 02:12 PM
  #5042  
Tech Addict
iTrader: (9)
 
Join Date: Mar 2011
Posts: 638
Trader Rating: 9 (100%+)
Default

Originally Posted by C-Dub View Post
Jeff, I should have it just see me about it tonight ill be out for some Buggy and Truggy action!!
Nevermind....Dont need it anymore. Thanks though.

Mellen
mellen_mpz is offline  
Old 02-03-2012, 12:27 AM
  #5043  
Tech Master
 
Join Date: Nov 2002
Location: Phoenix
Posts: 1,749
Default Results from tonights racing...

Cold night but a good one! Thanks Casey for making the trip!
Attached Files
File Type: txt
Round1.txt (30.4 KB, 53 views)
File Type: txt
Round2.txt (31.9 KB, 71 views)
File Type: pdf
R3_Race_02_Pro 4_A-Main(1).pdf (25.8 KB, 120 views)
Dbackmasta is offline  
Old 02-03-2012, 12:29 AM
  #5044  
Tech Master
 
Join Date: Nov 2002
Location: Phoenix
Posts: 1,749
Default

Last mains.. 63 on a thursday night Good job Dale!

The 2wd main is actually 2wd and pro lite combined. 2wd was Josh, Matt, and Chance..

Have a good Friday!
Attached Files
File Type: pdf
R3_Race_05_2WD Buggy_A-Main.pdf (26.1 KB, 102 views)
Dbackmasta is offline  
Old 02-03-2012, 01:12 AM
  #5045  
Tech Addict
iTrader: (9)
 
Join Date: Mar 2011
Posts: 638
Trader Rating: 9 (100%+)
Default

Strange. I was running 38 second laps a couple weeks ago when I first got that truggy.....now I'm running 2 seconds slower! What the hell?????
mellen_mpz is offline  
Old 02-03-2012, 01:21 AM
  #5046  
Tech Addict
iTrader: (15)
 
Join Date: Jul 2005
Location: AZ
Posts: 564
Trader Rating: 15 (100%+)
Default

Originally Posted by mellen_mpz View Post
Strange. I was running 38 second laps a couple weeks ago when I first got that truggy.....now I'm running 2 seconds slower! What the hell?????
Things wear, parts bind, truck no turn, laptimes fall. Magic doesn't just happen, time to get wrenching.
Shocker is offline  
Old 02-03-2012, 01:33 AM
  #5047  
Tech Addict
iTrader: (9)
 
Join Date: Mar 2011
Posts: 638
Trader Rating: 9 (100%+)
Default

Originally Posted by Shocker View Post
Things wear, parts bind, truck no turn, laptimes fall. Magic doesn't just happen, time to get wrenching.
I suppose it could be because my engine wasnt tuned very well.....it was slow as hell during the main. I would think this truck would be a bit better as it loosens up a but. It was pretty tight with all driveline parts basically new when I got it from Trevor. It still shows very little wear.
mellen_mpz is offline  
Old 02-03-2012, 02:29 AM
  #5048  
Tech Addict
iTrader: (15)
 
Join Date: Jul 2005
Location: AZ
Posts: 564
Trader Rating: 15 (100%+)
Default

Originally Posted by mellen_mpz View Post
I suppose it could be because my engine wasnt tuned very well.....it was slow as hell during the main. I would think this truck would be a bit better as it loosens up a but. It was pretty tight with all driveline parts basically new when I got it from Trevor. It still shows very little wear.
If only he was around to shed some light on the problem...
Shocker is offline  
Old 02-03-2012, 07:12 AM
  #5049  
Tech Champion
iTrader: (25)
 
losi_racer's Avatar
 
Join Date: Nov 2008
Location: mesa,az
Posts: 6,470
Trader Rating: 25 (100%+)
Default

Originally Posted by Shocker View Post
If only he was around to shed some light on the problem...




Mellen: the way I clean my stuff isn't just for looks . Making sure you have smooth suspension makes or breaks handling .
losi_racer is offline  
Old 02-03-2012, 07:19 AM
  #5050  
Tech Addict
iTrader: (34)
 
Join Date: Jan 2010
Location: Glendale,AZ
Posts: 710
Trader Rating: 34 (95%+)
Default

Great racing last night. Thanks to James Allara for tuning my motor to perfection. Also like to thank all the staff and everyone who helped out at the track. The program ran smooth.
dougwalter911 is offline  
Old 02-03-2012, 07:59 AM
  #5051  
Tech Addict
iTrader: (4)
 
Join Date: Nov 2009
Location: The NitroPit
Posts: 610
Trader Rating: 4 (100%+)
Default

Originally Posted by mellen_mpz View Post
I suppose it could be because my engine wasnt tuned very well.....it was slow as hell during the main. I would think this truck would be a bit better as it loosens up a but. It was pretty tight with all driveline parts basically new when I got it from Trevor. It still shows very little wear.
It went from 72 degrees for round 1 to 44 degrees when your main went off. I'll bet you're engine tune was off.
msciarrotta is offline  
Old 02-03-2012, 08:48 AM
  #5052  
Tech Lord
iTrader: (52)
 
Jaz240's Avatar
 
Join Date: Aug 2008
Location: Dwindle city
Posts: 12,494
Trader Rating: 52 (100%+)
Default

Oh crap!, your gonna get faster?
Jaz240 is offline  
Old 02-03-2012, 09:50 AM
  #5053  
Tech Addict
iTrader: (9)
 
Join Date: Mar 2011
Posts: 638
Trader Rating: 9 (100%+)
Default

Originally Posted by msciarrotta View Post
It went from 72 degrees for round 1 to 44 degrees when your main went off. I'll bet you're engine tune was off.
Well, that and I had to switch fuels because I couldnt find another gallon of VP. Spent all night dealing with that. Wheeler lapped me on the last lap of the A-main, he blew by me on the back straight like I was half throttle!
mellen_mpz is offline  
Old 02-03-2012, 09:55 AM
  #5054  
Suspended
iTrader: (6)
 
Join Date: Oct 2008
Location: PHOENIX, ARIZONA
Posts: 1,368
Trader Rating: 6 (100%+)
Default

Well another good night of racing!!! Now just need to get more consistent!
Vareck is offline  
Old 02-03-2012, 10:57 AM
  #5055  
Tech Fanatic
iTrader: (25)
 
Join Date: Dec 2010
Location: 10 mins West of Fear Farm- Arizona!
Posts: 963
Trader Rating: 25 (100%+)
Default

I dont know about you guys but it was cold as a mofo last night out there! And at 5pm it looked like rain was coming....surprised we didnt get wet! got to run a few laps with the new SCTE...suspension felt pretty good but may need to work on the pro4 4600kv/RX8 settings as it didnt seem much faster then my 2wd truck with Castle 3800kv sidewinder sct in the back straight. May be the 5000mah 20C's im using?? (I have 6000mah 60c coming).

Last edited by fourseventeen; 02-03-2012 at 12:22 PM.
fourseventeen is offline  

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 13 votes, 3.00 average.

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.