View Single Post
Old 08-10-2009, 02:21 PM  
Espeefan
Tech Adept
 
Espeefan's Avatar
 
Join Date: Jul 2008
Location: Central Wisconsin
Posts: 121
Trader Rating: 3 (100%+)
Default Losi 8ight buggy brakes - feel a little draggy

Hi guys,

I was wondering if anyone could offer some information. I have a brand new Losi 8ight 2.0 buggy that I am installing the engine and electronics on. So far, just the engine and pipe are in place. No servos yet.

But in my playing around with the throttle and brake linkages, by hand, it feels like the brakes do not fully release, once applied. If I lightly apply them by pulling on the linkages with my fingers, and then let go, it's as though the brake cams are not loosening their grip on the metal plates (calipers). Even if I try rolling the buggy, while completely pushing the brake linkages the opposite way, there is still a noticable drag, and the cams will not seem to loosen up. I have to manually release the cams, by pushing the cam levers, and then the buggy rolls very easily.

Is this normal? Is there something I can do to help the cams loosen up, when the linkage is released? Maybe some springs on the shoulder bolts, which the brake calipers slide on? Or is this drag just caused by the simple fact that my buggy hasn't been run in and things haven't gotten a chance to loosen up? It doesn't seem right to me, and I'm about to dig into the problem by disassembling the center differential assembly, to inspect the brake cams.
__________________
You have a rodent infestation. Shall I terminate?
Espeefan is offline   Reply With Quote