R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Radio and Electronics

Reply
 
Thread Tools Search this Thread
Old 01-10-2017, 08:17 PM   #1
Tech Apprentice
 
Join Date: Dec 2010
Posts: 85
Trader Rating: 7 (100%+)
Default Sanwa 92744 Receiver not powering up

Hello everybody,

I just received an M11X with a 92744 receiver which I am trying to install in my Rustler. After I cut the tabs off the leads from the traxxas servos and plug them into the Airtronics receiver, there is no power and does not light up. Am I doing something wrong here? Any help much appreciated.

Thanks,

Joe
photopro123 is offline   Reply With Quote
Old 01-10-2017, 08:41 PM   #2
Tech Master
 
trigger's Avatar
 
Join Date: Jun 2004
Location: SoCal
Posts: 1,030
Trader Rating: 6 (100%+)
Default

Make sure you have the esc plugged into channel 2 and in the correct orientation. since you've cut the tab off he plug, you may have plugged it in backwards.
__________________
Minh Nguyen
[Maclan Racing][Xpert]
trigger is offline   Reply With Quote
Old 01-10-2017, 11:02 PM   #3
Tech Fanatic
 
MontanaMaxx's Avatar
 
Join Date: May 2008
Posts: 870
Trader Rating: 12 (100%+)
Default

Make sure the signal wire is on inside I'm guessing that it is plugged in backwards also try binding it to your transmitter
MontanaMaxx is offline   Reply With Quote
Old 01-10-2017, 11:31 PM   #4
Tech Elite
 
Join Date: Oct 2013
Posts: 3,288
Trader Rating: 23 (100%+)
Default

Have you gone through the binding process? The Rx won't light until it has been successful bound to the Tx
__________________
Serpent Viper 977e EVO2, Serpent 977 EVO2 GP, Serpent Project 4x, Serpent 811T-TE Truggy, Serpent 811e 2.1, Serpent SRX2-MH, Serpent SRX-2 RM, Serpent SRX-4, Serpent F110-SF2, Serpent F180, Serpent 748 Natrix WC, Serpent Cobra GT 3.0, Serpent SRX8, Serpent S811 2.2, Baja 5B Flux, Atomic AMZ 1/27th, Schumacher GT12 SS.
Sanwa, Ielasi Tuned Novarossi Racing Engines, Tekin, Hobbywing, Muchmore.
dan_vector is offline   Reply With Quote
Old 01-11-2017, 05:09 PM   #5
Tech Apprentice
 
Join Date: Dec 2010
Posts: 85
Trader Rating: 7 (100%+)
Default

Quote:
Originally Posted by trigger View Post
Make sure you have the esc plugged into channel 2 and in the correct orientation. since you've cut the tab off he plug, you may have plugged it in backwards.
Thanks. Should it be channel two or should the lead from the esc go into throttle?

Thanks
photopro123 is offline   Reply With Quote
Old 01-11-2017, 05:12 PM   #6
Tech Apprentice
 
Join Date: Dec 2010
Posts: 85
Trader Rating: 7 (100%+)
Default

Quote:
Originally Posted by dan_vector View Post
Have you gone through the binding process? The Rx won't light until it has been successful bound to the Tx
Thanks. Is the binding process in the setup menu if the M11x? First you hit * then you hit enter?

Thanks
photopro123 is offline   Reply With Quote
Old 01-11-2017, 05:16 PM   #7
Tech Master
 
Join Date: Nov 2012
Location: Bay Area, Ca
Posts: 1,449
Trader Rating: 23 (100%+)
Default

Quote:
Originally Posted by photopro123 View Post
Thanks. Is the binding process in the setup menu if the M11x? First you hit * then you hit enter?

Thanks
I can't quite remember the steps for the m11x but if you Google search for the manual it should explain it thoroughly
EbbTide is offline   Reply With Quote
Old 01-12-2017, 02:32 AM   #8
Tech Fanatic
 
MontanaMaxx's Avatar
 
Join Date: May 2008
Posts: 870
Trader Rating: 12 (100%+)
Default

Quote:
Originally Posted by photopro123 View Post
Thanks. Is the binding process in the setup menu if the M11x? First you hit * then you hit enter?

Thanks
To bind go to menu push * then while holding button down on receiver power on hold till flashes then press enter on transmitter should blink then go solid
MontanaMaxx is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 02:46 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net