R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Radio and Electronics

Reply
 
Thread Tools Search this Thread
Old 04-14-2015, 11:56 AM   #1
Tech Rookie
 
Join Date: Apr 2015
Posts: 1
Post Radio Problems - Please Help!

I have just got a spektrum dx2e and sr201 receiver for my HPI Firsestorm Flux. I have followed the instructions to correctly bind the transmitter and receiver, however, after I remove the bind plug and try to use it normally, the steering servo moves by itself. Also when I try to steer, sometimes it will move forward.

Is there anything I can do to fix this, or do I need to ask for a replacement?

Last edited by JoeEarl; 04-14-2015 at 12:15 PM.
JoeEarl is offline   Reply With Quote
Old 04-14-2015, 10:20 PM   #2
Tech Regular
 
GerryH's Avatar
 
Join Date: Nov 2009
Posts: 257
Trader Rating: 19 (100%+)
Default

Does the throttle work at all?

When you say the steering moves by itself, you mean it sort of vibrates quickly back and forth close to center?

You confirmed you have the esc and servo in the right plug?
GerryH is offline   Reply With Quote
Reply


Tags
issue, problem, receiver, spektrum, transmitter


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 02:46 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net