R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Radio and Electronics

Reply
 
Thread Tools Search this Thread
Old 09-24-2013, 07:59 PM   #1
Tech Rookie
 
Join Date: Oct 2012
Posts: 5
Default Tekin Gen 2 going up in smoke

I have as of today seen two new Tekin Gen 2 go up in smoke the first was on the track after being ran for a few minutes the truck was sitting for about 5 minutes then came the smoke. The second was on a friends work bench he just finished binding it to his radio all of a sudden the esc smoked. He called Tekin they said the Gen 2 has some issues. Anyone else having this problem.
cirtcele is offline   Reply With Quote
Old 09-24-2013, 09:08 PM   #2
Tech Master
 
Burlap's Avatar
 
Join Date: Jan 2004
Location: Melbourne, Australia
Posts: 1,225
Trader Rating: 5 (100%+)
Send a message via MSN to Burlap
Default

Not yet, thankfully. I do 8 minute races with my RS Gen 2, however I do have the motor fan close to it. What type of motor/s were being run in the trucks?
Burlap is offline   Reply With Quote
Old 09-24-2013, 09:40 PM   #3
Tech Master
 
XRated SCT's Avatar
 
Join Date: Feb 2013
Location: SanDiego
Posts: 1,065
Default

I'm running the rx8 gen2 and so far so good, ran the RS with no problems, going to run the gen2 spec when available as well, all I know is that anything electrical can go up in smoke, it's just who's going to be the unlucky ones to get the duds or make a mistake themselves and cause it to die
__________________
Tekno SCT410--RX8 g2/Pro4 HD4300--RP green
Associated FT T4.2--RS g2/Redline g2 17.5--RP blue
XRated SCT is offline   Reply With Quote
Old 09-24-2013, 10:26 PM   #4
Team Tekin
 
Randy_Pike's Avatar
 
Join Date: Nov 2007
Location: Norcal
Posts: 8,643
Trader Rating: 5 (100%+)
Send a message via Yahoo to Randy_Pike
Default

Quote:
Originally Posted by cirtcele View Post
I have as of today seen two new Tekin Gen 2 go up in smoke the first was on the track after being ran for a few minutes the truck was sitting for about 5 minutes then came the smoke. The second was on a friends work bench he just finished binding it to his radio all of a sudden the esc smoked. He called Tekin they said the Gen 2 has some issues. Anyone else having this problem.
Esc's just don't go bad sitting there on the bench. Chances are something wasn't hooked up properly here.

Please have them contact support@teamtekin.com.

I'd also like to know who you spoke to at Tekin: Rpike@teamtekin.com
__________________
Something about winning attracts losers with opinions......

Tekin,Protek,A-Main Hobbies,KoPropUSA,JConcepts,Avid RC,MIP,SikLidz,ImagineItGraphx, FactoryRC, B-fast
Randy_Pike is offline   Reply With Quote
Old 09-24-2013, 10:58 PM   #5
Tech Regular
 
Join Date: Aug 2013
Posts: 252
Trader Rating: 8 (100%+)
Default

Quote:
Originally Posted by Randy_Pike View Post
Esc's just don't go bad sitting there on the bench. Chances are something wasn't hooked up properly here.

Please have them contact support@teamtekin.com.

I'd also like to know who you spoke to at Tekin: Rpike@teamtekin.com
I love my rx8 gen 2. Got another one coming in tomorrow.

Also that's some sweet customer service right here.
brandon32689 is offline   Reply With Quote
Old 09-25-2013, 07:22 AM   #6
Tech Master
 
timannnn6's Avatar
 
Join Date: Jul 2010
Posts: 1,558
Trader Rating: 92 (100%+)
Default

Quote:
Originally Posted by cirtcele View Post
He called Tekin they said the Gen 2 has some issues.
HIGHLY doubt anyone at Tekin would say that. The Gen2 has been incredible in all 3 of my cars. No fanboy for any brand.....just like running the best.
timannnn6 is online now   Reply With Quote
Old 09-25-2013, 11:51 AM   #7
Tech Addict
 
Skitee's Avatar
 
Join Date: Jul 2005
Location: Johannesburg, South Africa
Posts: 735
Default

Quote:
Originally Posted by cirtcele View Post
I have as of today seen two new Tekin Gen 2 go up in smoke the first was on the track after being ran for a few minutes the truck was sitting for about 5 minutes then came the smoke. The second was on a friends work bench he just finished binding it to his radio all of a sudden the esc smoked. He called Tekin they said the Gen 2 has some issues. Anyone else having this problem.
I've been running 2 of these for the last couple of months one in 1/12 with a TQ cells booster and the other in a boosted 13.5 touring car, they have been absolutely faultless.
__________________
Xray T4 2015 ~ Tekin RSX ~ Speedzone 7.5
Xray T4 2015 ~ ORCA Vrita VXX ~ Speedzone 13.5
Xray X12 2014 ~ ORCA Vritra VX1 ~ Speedzone 10.5

POWERED BY SPEEDZONE USA
Skitee is offline   Reply With Quote
Old 09-25-2013, 01:38 PM   #8
Tech Fanatic
 
Join Date: May 2006
Location: cincinnati ohio
Posts: 867
Trader Rating: 88 (100%+)
Default Gen 2

I saw one of the 8th scale versions go up in flames at the track and it was the first race on it. It landed after a small jump and quit. I went to move it and the smoke started coming out then flames. I thought the lipo had went but pulled the body and it was the ESC melted . I was turn mashalling and when the owner came to get it he said it was new.
latemodel13 is offline   Reply With Quote
Old 09-25-2013, 04:49 PM   #9
Tech Rookie
 
Join Date: Oct 2012
Posts: 5
Default

I don't know if he got the name of the person he talked to but i will try to find out. What could you wire incorrectly that would allow the truck to run fine for several laps then start smoking a few minutes later. It was just sitting on the track not being driven. Neither one of the trucks were mine and i did not inspect the wiring after the smoke. I was just making sure that there is not a trend going on with these gen 2 s before i buy one. I guess i'm assuming everyone knows its the RX8 model.
cirtcele is offline   Reply With Quote
Old 10-24-2013, 09:05 PM   #10
Tech Adept
 
kris88's Avatar
 
Join Date: Oct 2008
Posts: 159
Trader Rating: 1 (57%+)
Default

I have run them and had no issues whatsoever

on a side note i had a old hobao shortcourse with a 4.5 ballistic and a mamba pro esc all brand new. when it was all wired up i connected the lipo and ran a few laps and poof, smoke and flames from the esc. we sent the esc back to castle and when they sent a replacement, once again soldered it up and poof, went up again

turned out to be a faulty motor causing this

you never know, and Tekin is a top notch company with awesome customer support. if there is a problem with their product they take care of you. i had a bec quit in a gen 1 RX8 and they took care of it, and turnaround was super fast

its stuff like that that makes custoemrs loyal, and to see them on the forums asking about issues speaks volumes
__________________
Mugen Seiki * Racetech Hobbies * Upgrade RC * Tekno RC * Kal Guard * First Turn Racing
kris88 is offline   Reply With Quote
Old 10-25-2013, 05:21 AM   #11
Tech Addict
 
Join Date: Jan 2003
Posts: 548
Trader Rating: 3 (100%+)
Default

Quote:
Originally Posted by cirtcele View Post
I don't know if he got the name of the person he talked to but i will try to find out. What could you wire incorrectly that would allow the truck to run fine for several laps then start smoking a few minutes later. It was just sitting on the track not being driven. Neither one of the trucks were mine and i did not inspect the wiring after the smoke. I was just making sure that there is not a trend going on with these gen 2 s before i buy one. I guess i'm assuming everyone knows its the RX8 model.
I can't speak for Tekin, but i can speak to the fact that i swear at least 1/2 or more people i see with them have NO business with a soldering iron!

Most of the failures i have seen on any of the RX8's have been very poor solder jobs that caused excessive heat and then it melts.. things touch that shouldn't, and poof... magic smoke.

I am skeptical about any electronics failure online unless they post a pic showing the solder jobs....

so many "my friends (insert any ESC here) went up in smoke! they MUST be defective!" posts these days.

IMO show pics, or it didn't happen.
DsWright is offline   Reply With Quote
Old 10-25-2013, 05:31 AM   #12
Tech Addict
 
Join Date: Nov 2008
Location: Tampa, FL.
Posts: 639
Trader Rating: 1 (100%+)
Default

Quote:
Originally Posted by DsWright View Post
I can't speak for Tekin, but i can speak to the fact that i swear at least 1/2 or more people i see with them have NO business with a soldering iron!

Most of the failures i have seen on any of the RX8's have been very poor solder jobs that caused excessive heat and then it melts.. things touch that shouldn't, and poof... magic smoke.

I am skeptical about any electronics failure online unless they post a pic showing the solder jobs....

so many "my friends (insert any ESC here) went up in smoke! they MUST be defective!" posts these days.

IMO show pics, or it didn't happen.

You hit the nail on the head!!
Johnnysplits is offline   Reply With Quote
Old 10-25-2013, 07:03 AM   #13
Tech Adept
 
Racer8ight's Avatar
 
Join Date: Sep 2013
Location: Fredericksburg, VA
Posts: 122
Default

Well I had a brand new one go up in smoke on me at the VA state race in practice. I also witnessed a friend of mines go bad as well. His was brand new as well as mine. Tekin sent me a brand new one in about a week. They do have great service. You call them and get an answered phone with someone who speaks English.
__________________
JQ Products TheCar White Edition, Picco 5TR, 2099 Picco pipe. AKA
JQ Products The E Car White Edition, Tekin RX8 Gen 2 1900KV.
Losi 3.0 Werks B6 RTR with upgrades fresh rebuild for sale $600 Firm
losi E 3.0 Roller for sale fresh rebuild $325 Firm
Awesome RC Hobbies
Racer8ight is offline   Reply With Quote
Old 10-29-2013, 06:30 PM   #14
Tech Apprentice
 
Join Date: Oct 2010
Posts: 58
Default

Tekin has excellent customer service, and I'll bet that they warranty more than they should due to shoddy soldering. I know most of the people I race with can't solder for crap.
AERob is offline   Reply With Quote
Old 10-30-2013, 10:02 AM   #15
Tech Addict
 
Antimullet's Avatar
 
Join Date: Dec 2011
Location: Raleigh, North Carolina
Posts: 748
Trader Rating: 18 (100%+)
Default

Every thing I've ever burnt up was a result of solder failing or a piece of wire short circuiting between terminals or plugging things in wrong. All user induced (me!!!) and due to not catching it on a typical maintence check.
Tekins for me have never failed.
__________________
Aaron Moore
Tekno EB48.2, ARC R10 2015 ATS, Serpent SRX2 MM, Xray X12
Thank you Sponsors!:Tekno RC, Viper R/C Solutions, Team ARC USA, Expert RC, VP Pro USA, PTRC Racing.
Antimullet is offline   Reply With Quote
Sponsored Links
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


All times are GMT -8. It is currently 08:23 PM.



SEO by vBSEO 3.5.0