R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Radio and Electronics

Reply
 
Thread Tools Search this Thread
Old 07-30-2012, 06:41 AM   #46
Tech Addict
 
liteweight's Avatar
 
Join Date: Aug 2009
Posts: 740
Trader Rating: 12 (100%+)
Default after 3 laps speedo stop and no lights at all

Guys im 1st time user of lrp, I have a lrp tc spec last Saturday im practicing after 3 laps the car stop I check the Speedo there is no light at all, try to reset it still no power,any solution on this .thanks
__________________
John's Mobile R/C Raceway outdoor racing
"The New Coliseum Carpet Track"
"MRH" Carpet racing
"Xray T3 2012"
liteweight is offline   Reply With Quote
Old 07-30-2012, 03:57 PM   #47
Tech Elite
 
Join Date: Sep 2009
Location: Central Wisconsin
Posts: 2,895
Trader Rating: 211 (100%+)
Default

Quote:
Originally Posted by liteweight View Post
Guys im 1st time user of lrp, I have a lrp tc spec last Saturday im practicing after 3 laps the car stop I check the Speedo there is no light at all, try to reset it still no power,any solution on this .thanks
Try plugging a receiver pack into the receiver and see if it lights up then. The BEC has been the culprit on these things. Had this happen with a new one right out of the box some time ago.
Andy Koback is offline   Reply With Quote
Old 07-30-2012, 07:37 PM   #48
Tech Addict
 
liteweight's Avatar
 
Join Date: Aug 2009
Posts: 740
Trader Rating: 12 (100%+)
Default

Quote:
Originally Posted by Andy Koback View Post
Try plugging a receiver pack into the receiver and see if it lights up then. The BEC has been the culprit on these things. Had this happen with a new one right out of the box some time ago.
just tried it and still no light
__________________
John's Mobile R/C Raceway outdoor racing
"The New Coliseum Carpet Track"
"MRH" Carpet racing
"Xray T3 2012"
liteweight is offline   Reply With Quote
Old 07-30-2012, 07:53 PM   #49
Tech Elite
 
Join Date: Sep 2009
Location: Central Wisconsin
Posts: 2,895
Trader Rating: 211 (100%+)
Default

Quote:
Originally Posted by liteweight View Post
just tried it and still no light
Are you using the switch on the receiver pack and not on the ESC? Some have had the switch on the ESC go bad too. As a last resort, cut the switch off and twist the 2 wires together on the speedo. Only way to shut it off is to disconnect the main battery pack. If these 2 things don't work, then something inside took a dump.
Andy Koback is offline   Reply With Quote
Old 07-30-2012, 08:23 PM   #50
Tech Addict
 
liteweight's Avatar
 
Join Date: Aug 2009
Posts: 740
Trader Rating: 12 (100%+)
Default

Quote:
Originally Posted by Andy Koback View Post
Are you using the switch on the receiver pack and not on the ESC? Some have had the switch on the ESC go bad too. As a last resort, cut the switch off and twist the 2 wires together on the speedo. Only way to shut it off is to disconnect the main battery pack. If these 2 things don't work, then something inside took a dump.
Thanks for the help but still didn't work, i have read some thread about the bec issue of it, not a good experience with lrp , i've been using Tekin before swithching to lrp now im ending up going back with my Tekin, well i guess that what it is, Im just one unhappy customer
__________________
John's Mobile R/C Raceway outdoor racing
"The New Coliseum Carpet Track"
"MRH" Carpet racing
"Xray T3 2012"
liteweight is offline   Reply With Quote
Old 07-30-2012, 09:06 PM   #51
Tech Elite
 
bhambrent's Avatar
 
Join Date: Mar 2004
Location: B'ham, AL.
Posts: 2,026
Trader Rating: 11 (100%+)
Default

Quote:
Originally Posted by liteweight View Post
Thanks for the help but still didn't work, i have read some thread about the bec issue of it, not a good experience with lrp , i've been using Tekin before swithching to lrp now im ending up going back with my Tekin, well i guess that what it is, Im just one unhappy customer
Try here SXX Comp and TC Version 2 maybe someone in the sxx forum can tell you what's going on with it.
__________________
Half-A$$ Racing - Cooperhobbies.com - Hot Bodies D413 - OneLug Hobbies - Awesomatix - Thunder RC Raceway - SpeedKingz Racing "G SERIES"
bhambrent is offline   Reply With Quote
Old 07-30-2012, 09:14 PM   #52
Tech Regular
 
Join Date: Aug 2011
Location: Northern VA
Posts: 280
Default

Quote:
Originally Posted by liteweight View Post
Guys im 1st time user of lrp, I have a lrp tc spec last Saturday im practicing after 3 laps the car stop I check the Speedo there is no light at all, try to reset it still no power,any solution on this .thanks
I had this problem with 2 diffierent units. Sent it back!
__________________
Adrian Clements
Team Meech
Yokomobd7 2016
Kyosho MP9E TKI
M3CSLDreamin is offline   Reply With Quote
Old 07-31-2012, 12:41 AM   #53
Tech Adept
 
Stusdal's Avatar
 
Join Date: Nov 2004
Location: Norway
Posts: 100
Trader Rating: 1 (100%+)
Default

I have been using LRP for some time and it gives way better feel then anyting i ever tried, and they are so easy to get right. The FLOW probably won't be any worse.

However, I have had two sxx die on me over a polarity mistake - how hard can it be to build in protection for this?

I'll try out ORCA VX now, but will keep an eye on how the FLOW is treating people.
__________________
Serpent || Futaba || Protoform || Orca || GensACE || Sorex ||
*When you are not practicing, remember, someone somewhere is practicing, and when you meet him he will win*
Stusdal is offline   Reply With Quote
Old 07-31-2012, 03:00 PM   #54
Tech Rookie
 
Join Date: Jul 2012
Location: Denmark
Posts: 19
Default

Quote:
Originally Posted by NolanP View Post
Sounds like you should trade me a speedo for my rs pro.....
I'll trade you my stock spec for the rs if you dont mind sending to Denmark :-) I will gladly cover the expenses :-) PM me if your interested.

Kind regards Chris
mrtoulouse is offline   Reply With Quote
Old 07-31-2012, 03:55 PM   #55
Tech Elite
 
Join Date: Sep 2009
Location: Central Wisconsin
Posts: 2,895
Trader Rating: 211 (100%+)
Default

Quote:
Originally Posted by liteweight View Post
Thanks for the help but still didn't work, i have read some thread about the bec issue of it, not a good experience with lrp , i've been using Tekin before swithching to lrp now im ending up going back with my Tekin, well i guess that what it is, Im just one unhappy customer
I had the understanding that when the BEC fails, it will work with a receiver pack. Mine did. Gotta be something else. I went back to Mamba!
Andy Koback is offline   Reply With Quote
Old 08-11-2012, 09:01 PM   #56
Tech Adept
 
Join Date: Jul 2012
Posts: 128
Trader Rating: 1 (100%+)
Default

I am running a tc spec v2 with a Revtech 8.5 can anyone help with settings /gearing for 2wd sc10
Fvann is offline   Reply With Quote
Old 08-21-2012, 01:45 PM   #57
Tech Apprentice
 
Join Date: Aug 2010
Location: Denmark
Posts: 56
Default

The new FLOW's are coming soon, but wich one do I need for 1/12 modified with LRP 3,5 and 4,0 motors with worksteam rotors ... I think the worksteam version but used without the fan.

Any advise?

Best wishes; Jens
jensroland is offline   Reply With Quote
Old 08-21-2012, 02:55 PM   #58
Tech Elite
 
Join Date: Nov 2009
Location: Woodinville, WA
Posts: 2,512
Trader Rating: 8 (100%+)
Default

Quote:
Originally Posted by Stusdal View Post
However, I have had two sxx die on me over a polarity mistake - how hard can it be to build in protection for this?
My understanding is that it's not hard, it just increases resistance and thus reduces power.

-Mike
grippgoat is offline   Reply With Quote
Old 08-22-2012, 12:42 AM   #59
Tech Apprentice
 
Join Date: Jul 2005
Location: Íhringen near Stuttgart / Germany
Posts: 71
Default

Quote:
Originally Posted by jensroland View Post
The new FLOW's are coming soon, but wich one do I need for 1/12 modified with LRP 3,5 and 4,0 motors with worksteam rotors ... I think the worksteam version but used without the fan.

Any advise?

Best wishes; Jens
You should use the WorksTeam Version. I've seen a few pictures of drivers using the fan behind or in front of the speedo at the worlds.
kind regards
Marcel
Marcel is offline   Reply With Quote
Old 08-29-2012, 02:18 AM   #60
Tech Fanatic
 
Julius's Avatar
 
Join Date: Oct 2003
Location: Amsterdam Netherlands
Posts: 960
Default

Quote:
Originally Posted by jensroland View Post
The new FLOW's are coming soon, but wich one do I need for 1/12 modified with LRP 3,5 and 4,0 motors with worksteam rotors ... I think the worksteam version but used without the fan.

Any advise?

Best wishes; Jens
I ran a works team flow at the 1:12 world championship without fan. Esc temps were no issue at all. Keep in mind the flow does need a receiver battery or booster to work on 1s.

As a nitro racer i need all capacity for the motor anyway so the receiver pack helps
__________________
Team Serpent, Xceed, Sanwa, LRP
Julius is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
NEW HOBBYWING STOCK SUPERCHARGED SOFTWARE COBRARACING Radio and Electronics 12494 11-15-2016 03:57 PM
LRP Vector x12 Brushless Motors mok Electric On-Road 697 08-04-2013 01:35 PM
LRP SXX StockSpec ESC Stein Tumert Electric On-Road 1241 06-08-2012 09:52 AM
Ask Frank Root.....AE, Reedy, LRP, JC Frank Root Electric Off-Road 568 02-14-2010 01:24 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 04:54 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0