R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Radio and Electronics

Reply
 
Thread Tools Search this Thread
Old 08-03-2011, 01:45 PM   #1
Tech Addict
 
Fatam's Avatar
 
Join Date: Apr 2010
Location: Iowa
Posts: 534
Trader Rating: 6 (100%+)
Default brand new tekin rx8 question

I just got it soldered up all the leads and pluged it in. The esc is doing nothing for about 5 seconds or so then beeping and flashing all lights. Any one got any ideas.
__________________
Thunder Road Hobbies-Moline, IL
www.thunderroadhobbies.com
Rocket Graphics
Hitec
Pro-line
Fatam is offline   Reply With Quote
Old 08-03-2011, 03:57 PM   #2
Tech Master
 
Join Date: Jul 2008
Location: Melbourne, Australia
Posts: 1,465
Trader Rating: 3 (100%+)
Default

Is the ESC setup for the correct battery type ?

Have you calibrated the ESC to your transmitter ?

Cheers
__________________
Slash Platinum
Xerun 150, Tenshock SC401 3500kv
Gensace 40c
crusey_aus is offline   Reply With Quote
Old 08-03-2011, 04:01 PM   #3
Tech Addict
 
Fatam's Avatar
 
Join Date: Apr 2010
Location: Iowa
Posts: 534
Trader Rating: 6 (100%+)
Default

No nothing yet as it was the first time I plugged it in and it won't let me go into any programming mode
__________________
Thunder Road Hobbies-Moline, IL
www.thunderroadhobbies.com
Rocket Graphics
Hitec
Pro-line
Fatam is offline   Reply With Quote
Old 08-04-2011, 07:44 AM   #4
Tech Regular
 
BigRM's Avatar
 
Join Date: Mar 2011
Location: Courtice, ON
Posts: 250
Default

Turn on the radio and ESC

Hold down the "Mode" button for approximately 3 seconds.

You should now be in calibration mode.

Neutral throttle (chime), Full throttle (chime), Full Reverse (chime), ESC will then save your settings and reboot.

You should now be able to program the ESC.

http://www.teamtekin.com/manuals/RX8Manual.pdf
__________________
Hobby Revolution
Team N.E.R.D.
BigRM is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Tekin RX8 1/8 Scale Brushless ESC Thread sharkman Electric Off-Road 18835 09-11-2017 07:44 AM
Tekin Vegas 2.0 Setup and Support Randy_Pike Electric Off-Road 1713 12-06-2011 04:31 PM
Tekin RX8 Purchase question Brad.R Electric Off-Road 9 07-22-2011 09:19 AM
Lipo banana plug question MXracer115 Electric Off-Road 15 03-16-2010 07:54 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 12:37 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net