R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Radio and Electronics

Reply
 
Thread Tools Search this Thread
Old 11-24-2011, 03:14 AM   #7051
Tech Rookie
 
Join Date: Sep 2005
Posts: 14
Default

Quote:
Originally Posted by COBRARACING View Post
No im sorry not possible for the v1 i will ask michael though if there is anything we can do .
Just to clarify, don't want timing on the V1, just curious if it could be done now, happy with your answer.

Would be good if you could have option to show blinky mode on V1 and V2 tho'
derekk is offline   Reply With Quote
Old 11-24-2011, 04:52 AM   #7052
Tech Apprentice
 
Join Date: Jul 2010
Location: South Africa
Posts: 80
Trader Rating: 1 (100%+)
Default

Quote:
Originally Posted by M7H View Post
OK, that is not correct.
You should be able within V1.64 to flash your ESC to any of the firmwares within it....
What's the version on the 2 in 1 box? V1.08?

Do you have the possibility to try it on a windows XP computer?
Maybe it is related to Windows 7....
(now just don't tell me you are already on XP )

Ok, just tried it on an Windows XP machine.

I get exactly the same error. I tried going down to V2 versions - no.
I tried to goi down to V3.0 119 - no go.
I even tried to put the latest no timing software and no go.

Every time I get exactly the same error.

It would seem that once u have loaded the latest software 930, that is it, you cant go back - from my experience anyway.

Cobra can you please have a chat to Michal about this, and advise me what is the best method to downgrade my Xerun ESC from the latest 930 stock software, to a previous version, or even to the no timing software would be great.
SeanV is offline   Reply With Quote
Old 11-24-2011, 01:22 PM   #7053
Tech Adept
 
chinaman's Avatar
 
Join Date: Feb 2010
Location: UK
Posts: 141
Default

Quote:
Originally Posted by SeanV View Post

Ok, just tried it on an Windows XP machine.

I get exactly the same error. I tried going down to V2 versions - no.
I tried to goi down to V3.0 119 - no go.
I even tried to put the latest no timing software and no go.

Every time I get exactly the same error.
Happened to me when I had

usb link version on computer (XP): V1.63_110119
2 in 1 program card version: v1.07_110119

was using 119 and then decided to go back to 1224 and ...

installed usb link version on computer (XP): V1.63_110105
flashed 2 in 1 program card version: v1.07_101224

and could not download the 1224 onto the esc.

After a few tries, I had to go back to install 518 on the esc using the latest software on your program card that you have been using currently ... I hope the 930 has the 518 in the drop down list???

then ...

install usb link version on computer (XP): V1.62_100917
flash 2 in 1 program card version: v1.06_100512

then, 'upgrade' from there to

usb link version on computer (XP): V1.63_110105
and re-flash again 2 in 1 program card version to: v1.07_101224

and only then could I install 1224 onto the esc. Hope I made some sense ...
__________________
... wyrd bi ful rd ...
chinaman is offline   Reply With Quote
Old 11-24-2011, 03:55 PM   #7054
Tech Elite
 
COBRARACING's Avatar
 
Join Date: Nov 2007
Posts: 3,206
Default

Hi Guys

Michael upgrades the software as he has done the testing and says no need to run older versions on your esc as the new one is the one to use but i guess some of you want to go back to older versions.Please be reminded the v3 will not use older versions.

The easiest method is as follows .

1.under c/drive programfiles/hobbywing usb link (please delete this file program and any other usb link software you have .

2.Making sure you have access to older version of the usb link software load the older version to your pc may it be v1.62 or 1.63 were ever your software say 1224 is located in the correct updated usb link then use the usb link to upgrade your 2 in 1 programmer and your esc with whatever firmware you need .

This is the easiest method that will not give you any errors at the moment you have to many usb link program sitting in your programfiles thus confusing which is the right program and which is the wrong it will only allow you to use the latest update even though you have a older version sitting in the program files .when you upgrade to a new usb link version the older version is still it doesnt get replaced by the new so you must delete one of them either the new or the old you cant use both .Having both of them you can only use the new version as thats what the pc will recognise with no errors to use the old you must delete the new.Keeping both the new will always be used .

I will also ask michael if he can still keep the older files like the 1224,119,213,211 etc on the usb link instead of removing them so then you have a choice but believe me when i tell you we went from 211 to 930 the only difference was the sensor port sensitivity thats all nothing else changed no timing ,no boost no nothing like that .

thank you for your time guys

have a good weekend

Angelo
__________________
Email : teamcobraracing@gmail.com or ae@hobbywing.com
Repair service Address
Hobbywing Technology Co., Ltd.
4th Floor, 3rd Building, KeLunTe Industrial Park, ShangLiLang, BuLan Road, LongGang District, ShenZhen, China
COBRARACING is offline   Reply With Quote
Old 11-24-2011, 10:35 PM   #7055
Tech Apprentice
 
Join Date: Jul 2010
Location: South Africa
Posts: 80
Trader Rating: 1 (100%+)
Default

Quote:
Originally Posted by COBRARACING View Post
Hi Guys

Michael upgrades the software as he has done the testing and says no need to run older versions on your esc as the new one is the one to use but i guess some of you want to go back to older versions.Please be reminded the v3 will not use older versions.

The easiest method is as follows .

1.under c/drive programfiles/hobbywing usb link (please delete this file program and any other usb link software you have .

2.Making sure you have access to older version of the usb link software load the older version to your pc may it be v1.62 or 1.63 were ever your software say 1224 is located in the correct updated usb link then use the usb link to upgrade your 2 in 1 programmer and your esc with whatever firmware you need .

This is the easiest method that will not give you any errors at the moment you have to many usb link program sitting in your programfiles thus confusing which is the right program and which is the wrong it will only allow you to use the latest update even though you have a older version sitting in the program files .when you upgrade to a new usb link version the older version is still it doesnt get replaced by the new so you must delete one of them either the new or the old you cant use both .Having both of them you can only use the new version as thats what the pc will recognise with no errors to use the old you must delete the new.Keeping both the new will always be used .

I will also ask michael if he can still keep the older files like the 1224,119,213,211 etc on the usb link instead of removing them so then you have a choice but believe me when i tell you we went from 211 to 930 the only difference was the sensor port sensitivity thats all nothing else changed no timing ,no boost no nothing like that .

thank you for your time guys

have a good weekend

Angelo

Thx for replies guys, I really appreciate the hekp.

Ok here is what I have tried now.... as per Cobra's instructions....

I took my wife's laptop (Win7 which has never had any Hobbywing software installed on it) and installed Hobbywing_USB_Link_setup_V1.63_110310.

I then took my 2 in Box and attached it to the PC and attempted to down grade the 2 in 1 box from it's current version of V1.08_111007 to V1.07_101224 and then also tried the same thing to downgrade it to V1.07_110119.

I got the error as posted below when trying to do the downgrade of the 2 in 1 box.

I then went in "Add Remove Programs" and removed the Hobbywing Software from he PC and also went in the Program Files folder and checked to make sure that the Hobbywing folder was deleted.

I then installed Hobbywing_USB_Link_setup_V1.62_101106 on the laptop and connected the 2 in 1 Box and attempted to downgrade it to V1.06_100512.
I get the same error.
See below.

On both occasions I was running the Hobbywing USB Link program as Administrator and also tried it in XP compatibility mode.
Nothing helps.

Any other suggestions I can try?
Thx

Edit:
The way I see it, the only two options I have left is to....
Try the same thing above agaion, but this time use a Win XP machine.

or....

Not sure if this is possible, install the speed Passion software on my 2 in 1 box and the same on the ESC. Then remove that and install the Hobbywing Software back on V1.63 which will then hopefully allow me to install the no timing software or and older version onto my Xerun.
Is this second option viable?
Attached Thumbnails
NEW HOBBYWING STOCK SUPERCHARGED SOFTWARE-untitled-2.jpg   NEW HOBBYWING STOCK SUPERCHARGED SOFTWARE-untitled-1.jpg  
SeanV is offline   Reply With Quote
Old 11-24-2011, 10:36 PM   #7056
Tech Elite
 
AlanHall's Avatar
 
Join Date: Jan 2003
Location: Watson ,Louisiana
Posts: 2,938
Trader Rating: 42 (100%+)
Send a message via AIM to AlanHall Send a message via Yahoo to AlanHall
Default

Is this setup suggested for 17.5 touring car racing? There's so much to choose from. And I see all the software discussion .. is this something all the esc can do and come with?

http://www.hobbypartz.com/07e-combo-js5.html
__________________
Alan Hall
AE B5r
AE B5/SC10
AlanHall is offline   Reply With Quote
Old 11-24-2011, 11:29 PM   #7057
Tech Elite
 
COBRARACING's Avatar
 
Join Date: Nov 2007
Posts: 3,206
Default

Quote:
Originally Posted by AlanHall View Post
Is this setup suggested for 17.5 touring car racing? There's so much to choose from. And I see all the software discussion .. is this something all the esc can do and come with?

http://www.hobbypartz.com/07e-combo-js5.html

Yes the justock is good if you want to run zero timing which im sure thats what is run the usa .Grab it while you can as this is a fire sale because hobbywing will have a new distributor in the usa thats why you see so much out of stock on the site .
__________________
Email : teamcobraracing@gmail.com or ae@hobbywing.com
Repair service Address
Hobbywing Technology Co., Ltd.
4th Floor, 3rd Building, KeLunTe Industrial Park, ShangLiLang, BuLan Road, LongGang District, ShenZhen, China
COBRARACING is offline   Reply With Quote
Old 11-24-2011, 11:38 PM   #7058
Tech Elite
 
COBRARACING's Avatar
 
Join Date: Nov 2007
Posts: 3,206
Default

Hi Guys

You can all say it's my fault that the V3 is delayed and i would like to apologise for this .

I wanted a cnc case not a plastic one ,i wanted a new heatsink to have airflow from all directions instead on north and south ,i wanted new graphics and new laser engravements ,i wanted new software not the old stuff as present .I also wanted a new switch so that you can easily see the led's and many more things to be changed on the V3 so thats why there has been the delays im sorry for the delays but i want to bring you the best of the best beyond anyone's imagination and even mine ,i wanted it different ,i wanted it more poweful and much much smaller .There has been some nights well alot of the nights were i sit there and stare at the ceiling and start to imagine and think on how would my customer and myself want the v3 to be like if i made these changes so im on the phone and the email and i tell michael i need these changes and i wont take no for an answer it can be done dont tell me no .I like to think outside the square and sometimes beyond.

So it's me who has delayed the v3 not the factory or anyone else at hobbywing maybe im being anal about it but i want things to be perfect and i wont have it any other way im sorry and i deeply apologise to everyone but i can tell you you wont be dissapointed .

with maximum respect Angelo
__________________
Email : teamcobraracing@gmail.com or ae@hobbywing.com
Repair service Address
Hobbywing Technology Co., Ltd.
4th Floor, 3rd Building, KeLunTe Industrial Park, ShangLiLang, BuLan Road, LongGang District, ShenZhen, China
COBRARACING is offline   Reply With Quote
Old 11-25-2011, 03:00 AM   #7059
M7H
Tech Elite
 
M7H's Avatar
 
Join Date: Dec 2004
Location: The Netherlands
Posts: 2,191
Default

Quote:
Originally Posted by COBRARACING View Post
Hi Guys

Michael upgrades the software as he has done the testing and says no need to run older versions on your esc as the new one is the one to use but i guess some of you want to go back to older versions.
If I understand SeanV correct, he can not switch to any of the firmwares available in V1.64 usb link, so also not even to 930_MOD.... or to a "blinky" no-timing firmware.....

@SeanV, is this correct?


Quote:
Originally Posted by COBRARACING View Post
Please be reminded the v3 will not use older versions.

I have ordered the V3 from Racers in exile (Cherry2blost) to use it at the 12th scale worlds next year in our country, so will be running Mod firmware anyway, but like to go back to 101224_STOCK after that....
But, ok, I will see when I have it what is possible, or not....
__________________
Serpent
M7H is offline   Reply With Quote
Old 11-25-2011, 03:22 AM   #7060
Tech Apprentice
 
Join Date: Jul 2010
Location: South Africa
Posts: 80
Trader Rating: 1 (100%+)
Default

Quote:
Originally Posted by M7H View Post
If I understand SeanV correct, he can not switch to any of the firmwares available in V1.64 usb link, so also not even to 930_MOD.... or to a "blinky" no-timing firmware.....

@SeanV, is this correct?


Well.... I tried going to blinky and that didn't work either - same error (Which is in fact more of a problem as I want to run my Xerun 60A in my FF03 which is a blinky class) and then upgrade to a 120A to run in the boosted classes.

I haven't tried the 930_MOD as yet.
SeanV is offline   Reply With Quote
Old 11-25-2011, 03:33 AM   #7061
M7H
Tech Elite
 
M7H's Avatar
 
Join Date: Dec 2004
Location: The Netherlands
Posts: 2,191
Default

Quote:
Originally Posted by SeanV View Post
I haven't tried the 930_MOD as yet.
Try them all Sean, and even 2 or 3 times.
Maybe you can switch to 930_MOD and then to the no-timing version.
The flashing of an EEPROM (Electrically Erasable Programmable Read Only Memory) sometime needs more then 1 attempt to be succesfull.... but I don't want to cheer you up to much, most of the times it needs a second flash if halfway throught the process it stops with an error, and not as you have it, immediately in the beginning....
__________________
Serpent
M7H is offline   Reply With Quote
Old 11-25-2011, 09:57 AM   #7062
Tech Initiate
 
Join Date: Oct 2011
Location: Canada
Posts: 45
Default

Quote:
Originally Posted by SeanV View Post
I then installed Hobbywing_USB_Link_setup_V1.62_101106 on the laptop and connected the 2 in 1 Box and attempted to downgrade it to V1.06_100512.
I get the same error.
See below.
hi,
I have done some pretty intensive research on the hobbywing software. I downloaded the DB3 drivers to look into the firmware database file(DB3)to see what/how the software worked.
What I found is there are 2 files that control what you can install on your ESC: the CAR_ESC_version_control.ini and the CAR_ESC_settings.db3.
I did a post on the RCCanada.ca forum about it, but I will give you the summary here.
The config in the INI file seem to contain an entry for every version of the firmware for your ESC that have ever been released. The DB3 file only contains a few supported versions at the time of the release. Where you get that error is when there in an entry for the firmware in the INI file but there is no version in the DB3 database. The versions in the INI file that have matching entries in the DB3 file will show in the drop down list for you to select from. To make this a bit more confusing, the version number of the firmware that is in your ESC will show in the current version box no matter if it is in either file. The version number of the firmware in your ESC MUST be in the drop down list(meaning in the INI and DB3 files) or the software will not let you upgrade/downgrade the firmware.
UPDATE: Actually the firmware version that is in the ESC must be in the INI file of the software you are using for you to be able to change the firmware in the ESC. It does not have to be in the DB3 file. Having the version in the INI and the DB3 file is just a very safe way to do it, because if anything goes wrong you would be able to reload the firmware you have.
To go back to an older version of the firmware may take a few steps. Each version of the software 1.64, 1.63, 1.62 ... contains the specific supported versions of firmware at the time of the release in the DB3 file.
I will use your scenario as an example. I'm assuming you want to go from firmware version V3.0_110930STOCK to version V2.0_100518STOCK. Lets call these 930 and 518 for short.
930 only exists in the 1.64 DB3 file, 518 only exists in the 1.63 DB3 file, which means you have to downgrade to a version that is in both files. Looking in the DB3 files, I see that version V1.10_090323a_m is in both files.
So this is what I would do:
step 1) using software 1.64 I set the LCD programmer software to whatever the highest version is.
step 2) downgrade the firmware on your ESC to V1.10_090323a_m
Step 3) using the software downgrade your programer to the lowest version you can
Step 4) now use V1.63 software, upgrade the programmer to whatever the highest version you can
Step 5) load the V2.0_100518STOCK firnware on your ESC.

What would make this all easier is for hobbywing ('Michael' as Cobra says) to leave the all firmware versions in the DB3 file and not take them out each release of the software.
FYI, another version for your ESC that is common between the 2 software versions is V1.10_090205_MOD.

good luck, let me know how you make out.

Now the topic of putting hobbywing firmware on a speed passion ESC is a whole other topic. The same version rules apply.

Last edited by lawton70; 11-25-2011 at 12:20 PM.
lawton70 is offline   Reply With Quote
Old 11-25-2011, 10:47 AM   #7063
Tech Initiate
 
Join Date: Oct 2011
Location: Canada
Posts: 45
Default

SeanV,
Just noticed!
You said you have 213 on your ESC!
Using the software version you put 213 on with, change the firmware version to the common version v1.10_090323a_m.
Remember, the version that is in the ESC MUST be in the software you are using and I don't see 213 in the 1.64 DB3 file, or even in my version of the 1.63 file.
That is another problem hobbywing is getting themselves into.
They are releasing versions of versions with no version control!
How can you have 2 or more versions of 1.63??

I know they are trying to be nice guys and release stuff quick, but their habit of removing firmware versions with each release of the software is making a mess. Software programmers would call it 'version perversion'.
lawton70 is offline   Reply With Quote
Old 11-25-2011, 11:05 AM   #7064
Tech Fanatic
 
Join Date: Apr 2011
Location: France
Posts: 812
Default

lawton70 has a point here Angelo, I know that when I had to go back to 224 (with no problem by the way on 64bit Win7) it took me a while to understand all these versions from one to the other update, I "agree" that the date system is logical to you guys who work with the product, but for a new guy it is algebra.

then you have in reality TWO versions to look at (2 in 1 and speedo)

It is a little complicated, specially when you bring out a version (213) that is not a real release and everybody wants.

Don't take it badly but it needs to be easier for the masses, this is what you want too..
__________________
Electriquement votre...

Drink EARTH water and save lives! in support of WFP
olly986 is offline   Reply With Quote
Old 11-25-2011, 01:23 PM   #7065
Tech Initiate
 
Join Date: Oct 2011
Location: Canada
Posts: 45
Default

The answer is actually quite simple.
Have a release of the USB Link software, v1.65 for example, with an entry of every version their ever was in the INI file and every released version of the firmware in the DB3 file.
What I mean by released is if it was ever published in any way to the public. On the hobbywing site, on the cobraracing site, sent in emails to specific people, whatever.
Then there would be no questions at all about how to load firmware XXX on ESC YYY and versions of software and version on the programmer. The answer would always be to download the most recent version of the software from hobbywing and load the firmware you want.

Of course I realize the drop down box would contain many more selections. But with the version/date stamp it is easy to tell which version is newer than the other.
A page could be posted indicating the firmware version and a description of its features so owners could make a choice between firmware if they wanted. The CAR_ESC_readme.txt file in the hobbywing directory already has some basic information about the release.

I think the point to be made is don't remove the old versions from the new release so the owners can re-load their previous version from the new software. It simplifies this whole process and lets the racers get back to asking what setup do you run rather than ask for help to load a specific version.
lawton70 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 11:28 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0