R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Radio and Electronics

Reply
 
Thread Tools Search this Thread
Old 03-29-2010, 09:14 PM   #1
Tech Adept
 
Join Date: Jan 2008
Posts: 113
Default hyperion charger issues. Help!

My hyperion 0606i charges all my lipos past 8.400 volts. I continually get 8.412-8.420 volts even when balance charging. Is this normal? I thought they were not supposed to go past 8.400. This has happened with all my batteries even when they were new. My other charger always stopped them at 8.4 every time.
__________________
HB Ve8 Tekin RX-8/1900kv T8
HB D8
Team Associated B4.1 Tekin RS/Redline 17.5
Team Associated B44.1 Tekin RS pro/Redline 13.5
fazznick is offline   Reply With Quote
Old 03-29-2010, 11:22 PM   #2
Tech Regular
 
scrawl's Avatar
 
Join Date: Jan 2008
Posts: 387
Trader Rating: 8 (100%+)
Default

My 0606i does the same. Can't say I've noticed any problems.
__________________
stivesrc.org.au

"It's a spending hobby. You race occasionally."
scrawl is offline   Reply With Quote
Old 03-30-2010, 06:16 AM   #3
Super Moderator
 
racer1812's Avatar
R/C Tech Elite Subscriber
 
Join Date: Nov 2008
Location: RIP 'Chopper', 4/18/13 miss you bud:(
Posts: 14,769
Trader Rating: 31 (100%+)
Default

My Hyperion does the same thing, don't worry you're fine..
__________________
Stand for the flag, kneel for the fallen.

Thank you to all of our service men and women!

racer1812 is offline   Reply With Quote
Old 03-30-2010, 06:43 PM   #4
Tech Adept
 
Join Date: Jan 2008
Posts: 113
Default

Thanks for the replies. One thing I overlooked was the voltage for each cell. They were both at 4.20 when fully charged and balanced.
__________________
HB Ve8 Tekin RX-8/1900kv T8
HB D8
Team Associated B4.1 Tekin RS/Redline 17.5
Team Associated B44.1 Tekin RS pro/Redline 13.5
fazznick is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hyperion EOS0610i Reg & Duo Lipo Chargers Still Bill Radio and Electronics 393 02-22-2015 08:39 AM
max amps hyperion charger HOWIE BEDELL Electric Off-Road 6 10-13-2009 09:01 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 11:14 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net