R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road > Onroad Nitro Engine Zone

Thread Tools Search this Thread
Old 10-31-2011, 05:40 PM   #1
Tech Adept
NitoriousRC's Avatar
Join Date: Jul 2010
Posts: 127
Trader Rating: 1 (100%+)
Default ENgine starts without glow igniter!

Ok had this happend twice now when starting a mates motor for him.

He has i think the Novarossi Plus 12-3SCT, and it always seems to happen when i have first connected the glow igniter, then the car wouldnt start so I have removed the ignitier so i could put my finger over the exhuast to crank some more fuel through and ... zing ... motor fire up .... so yeah whats going on?

Is it because it is still new and has a very high compression .... would that be possible for it to start like a diesel?

Or is it the glow wire must still have enough heat in ot for it to fire up.

Anyway its kinda weird and has only happened with this motor .... and yeah not a bad thing would just like to know why.

NitoriousRC is offline   Reply With Quote
Old 10-31-2011, 05:48 PM   #2
Tech Master
Join Date: Jan 2006
Location: Virginia
Posts: 1,807
Trader Rating: 47 (100%+)

Sounds like the glowplug coil was still hot enough to ignite
the fuel in the engine. What glowplug are you using in that
engine ? It must be a good one.
rageworks is offline   Reply With Quote
Old 10-31-2011, 06:30 PM   #3
Tech Elite
Factory Seal's Avatar
R/C Tech Elite Subscriber
Join Date: Apr 2006
Location: Memphis,TN.
Posts: 3,977
Trader Rating: 29 (100%+)

plug still hot!
My club.....msra-racing.com
Factory Seal is offline   Reply With Quote
Old 10-31-2011, 08:20 PM   #4
Tech Adept
NitoriousRC's Avatar
Join Date: Jul 2010
Posts: 127
Trader Rating: 1 (100%+)

Yah i guess it just didnt cool down much in the 3-5 seconds it ook me to unhook it and then go to crank.

I think its a Nova plug, he also has a lipo on the start box which does crank it a lot faster..... not sure if that is a contributing factor.
NitoriousRC is offline   Reply With Quote
Old 11-20-2011, 10:56 PM   #5
Tech Elite
rcabj's Avatar
Join Date: Feb 2004
Location: johor, west malaysia
Posts: 4,682
Trader Rating: 1 (100%+)

happened to me too..took off the glow heater, carry on cranking to get some fuel into the carby..and voilla...the motor started...happens to be the nova 12-3 st with nova no. 5 plug. didn feel it was that weird coz it cross my mind the plug coil must have been still red hot or so...
BLacK cRoW RaCiNg TeaM
pemandu upahan ;)
rcabj is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
"the engine tuning bible" houston Offroad Nitro Engine Forum 495 10-09-2016 09:50 AM
Go Engine USA 2011 Thread GoEngineUSA Offroad Nitro Engine Forum 2713 05-16-2013 04:58 AM
Fantom Engine Manual = ABC Engine Bible Horatio Monster Trucks 9 02-05-2007 07:35 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 05:09 AM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0