R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road > Onroad Nitro Engine Zone

Thread Tools Search this Thread
Old 09-21-2004, 08:57 AM   #1
Tech Rookie
Join Date: Sep 2004
Posts: 1
Talking Help...Engine stalling

I'm running a few week old, properly broke-in HPI RS4 Evo. The engine has been tuned to run properly, however each time I let off of the gas after a short burst the engine dies.

Any ideas what's wrong? I'm a newbie.

oipolloi is offline   Reply With Quote
Old 09-21-2004, 09:49 AM   #2
Tech Elite
duneland's Avatar
Join Date: Sep 2004
Location: NW Indiana, USA
Posts: 2,403

Make shure that your idle speed is being set by the idle screw on the carb, as opposed to the throttle trim on the radio.
another possibillity is, lean setting on the bottom end.
also, check or replace the glow plug. If it is the one used for break-in it may be fouled.
duneland is offline   Reply With Quote
Old 09-25-2004, 02:12 AM   #3
Tech Fanatic
HELLION's Avatar
Join Date: Aug 2003
Location: Colorado
Posts: 802
Default hmmmmm!

Maybe you should check the return line or pipe seals
HELLION is offline   Reply With Quote
Old 09-29-2004, 10:47 PM   #4
Tech Addict
Thunder racer's Avatar
Join Date: Feb 2003
Location: ((^^Keep It Sidewayz^^))
Posts: 536

Thunder racer is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
newbie one works fine the other has engine stalling problem deano89 Rookie Zone 6 12-26-2007 01:41 PM
Stalling Engine buggyrac3r Electric Off-Road 3 09-24-2006 04:12 PM
Help Plz: RS4 Evo stalling somegeek Nitro On-Road 0 05-31-2006 07:39 PM
Stalling O.S ScoopGrate Electric Off-Road 4 03-15-2004 01:56 AM
new engine keeps stalling after 10s fuzzylogic Singapore R/C Racers 9 02-11-2003 05:58 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 06:43 AM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0