R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road > Onroad Nitro Engine Zone

Like Tree32Likes
Reply
 
Thread Tools Search this Thread
Old 05-24-2013, 12:11 PM   #4636
Tech Apprentice
 
Join Date: Jul 2009
Posts: 53
Default

Quote:
Originally Posted by jarkko View Post
Maby someone can point me in the right direction to look for a reason for the strange behaviour of my sons Novarossi Flash .12 with 2660 pipe.

Towards the end of a nice training session (about 12 tanks of faultless operation) the engine started suddenly to go extremely rich 1-2 times per lap for a short period like 2-3 secs and then operating well again. No changes were made in any settings. Temps were normal about 125-128 celsius before disaster started and then temps dropped very much. For some reason the engine flooded on its own for short periods and then continued normal operation on its own. When the problem was on it sounded like a new engine during early breaking in and it would not take any higher rpm.

What could cause a normally functioning engine to start suddenly going extremely rich for short periods of time and return to normal? And this repeated very poor / running well / very poor...

Before the session we put in a new air filter and afterwards it looked like the carburator had somehow flooded up to air filter too.

Any similar experiences?

Air was about 20 celsius and weather was sunny and dry.
Check if the carburetor is well fixed in the crankcase....I had a similar condition in the past.

GHN
ghn-sp is offline   Reply With Quote
Old 05-24-2013, 12:51 PM   #4637
afm
Tech Master
 
afm's Avatar
 
Join Date: Nov 2003
Location: lima-peru
Posts: 1,806
Default

Quote:
Originally Posted by jarkko View Post
Maby someone can point me in the right direction to look for a reason for the strange behaviour of my sons Novarossi Flash .12 with 2660 pipe.

Towards the end of a nice training session (about 12 tanks of faultless operation) the engine started suddenly to go extremely rich 1-2 times per lap for a short period like 2-3 secs and then operating well again. No changes were made in any settings. Temps were normal about 125-128 celsius before disaster started and then temps dropped very much. For some reason the engine flooded on its own for short periods and then continued normal operation on its own. When the problem was on it sounded like a new engine during early breaking in and it would not take any higher rpm.

What could cause a normally functioning engine to start suddenly going extremely rich for short periods of time and return to normal? And this repeated very poor / running well / very poor...

Before the session we put in a new air filter and afterwards it looked like the carburator had somehow flooded up to air filter too.

Any similar experiences?

Air was about 20 celsius and weather was sunny and dry.
two possible causes:
1.- glow plug failure......change for a new one.
2.- check for any loose old silicone header gasket inside the pipe....i had this issue once and it was these piece of gasket floating inside, obstructing the pipe´s outlet sometimes yes sometimes no.

hope this hepls

AFM
afm is offline   Reply With Quote
Old 06-13-2013, 08:35 AM   #4638
Tech Master
 
choisan's Avatar
 
Join Date: Jul 2004
Location: San Francisco Bay Area
Posts: 1,231
Default

Anyone knows why the collari 09 is on sale for about US$250?
Any issue with this engine?
choisan is offline   Reply With Quote
Old 06-13-2013, 08:35 AM   #4639
Tech Master
 
choisan's Avatar
 
Join Date: Jul 2004
Location: San Francisco Bay Area
Posts: 1,231
Default

Anyone knows why the collari 09 is on sale for about US$250?
Any issue with this engine?
choisan is offline   Reply With Quote
Old 06-13-2013, 08:55 AM   #4640
Tech Champion
 
Roelof's Avatar
 
Join Date: Aug 2007
Location: Holland
Posts: 6,065
Send a message via ICQ to Roelof
Default

I think people do not want it anymore with the many newer models today.
__________________
The quality of an answer comes with the quality of the question.
Roelof is offline   Reply With Quote
Old 06-13-2013, 09:29 AM   #4641
Tech Fanatic
 
SalvadoriRacing's Avatar
 
Join Date: Dec 2003
Location: Brazil, Sao Paulo
Posts: 928
Send a message via MSN to SalvadoriRacing Send a message via Skype™ to SalvadoriRacing
Default

Quote:
Originally Posted by choisan View Post
Anyone knows why the collari 09 is on sale for about US$250?
Any issue with this engine?
nothing wrong.....maybe some shops is just getting rid of stock.....

I'm distributor of Novarossi in Brazil and the price remains the same.

If I were you, I'd buy it, it's a great engine and for the price you don't get money to afford half of the new engines while performance is almost the same
__________________
Salvadori Racing
www.salvadoriracing.com.br

O.S. Engines - KM RACING - CONTACT TYRES - SAVOX - LRP - ARC | Blitz | Titan
SalvadoriRacing is offline   Reply With Quote
Old 06-13-2013, 03:45 PM   #4642
Tech Master
 
choisan's Avatar
 
Join Date: Jul 2004
Location: San Francisco Bay Area
Posts: 1,231
Default

Thanks
choisan is offline   Reply With Quote
Old 07-03-2013, 11:34 AM   #4643
Tech Apprentice
 
wiggindude6969's Avatar
 
Join Date: Feb 2007
Location: Houston
Posts: 94
Trader Rating: 1 (100%+)
Default

This weekend in Houston, It seemed that everyone was having issues with motors flaming out. The track temp ranged from 125-150 and the actual temp was around 98-100. When the track temp gets that high, what are the affects on the tune?

I tried to richen the bottom end, which helped but after the straight, halfway thru the sweeper the motor would flame out. A lot of guys had the same problem.... I was running the maxy 5 port " off road" with a 6 plug and 6.5 venture. Just looking for tips to help tune when the temp gets hot. The motor seemed to work well when the track temp was under 120... when it got to 150... it kept flaming out. thanks
__________________
F104v2 - RSD/TC6.1 - CRCXTi - AE B6
wiggindude6969 is offline   Reply With Quote
Old 07-03-2013, 02:19 PM   #4644
Tech Addict
 
bassman2's Avatar
 
Join Date: Nov 2009
Location: UT/TX/IN/PA
Posts: 718
Trader Rating: 7 (100%+)
Default

.........................
__________________
Andy Liu "Flyin' Hawaiian"
2015 teams/sponsors:
Serpentamerica/Desoto Racing, Murnan Modified Motors, VP powermaster Fuel, Sweep Racing USA, Speed Passion, BUKU performance products

Last edited by bassman2; 07-03-2013 at 02:22 PM. Reason: remove post
bassman2 is offline   Reply With Quote
Old 07-03-2013, 02:21 PM   #4645
Tech Addict
 
bassman2's Avatar
 
Join Date: Nov 2009
Location: UT/TX/IN/PA
Posts: 718
Trader Rating: 7 (100%+)
Default

Quote:
Originally Posted by wiggindude6969 View Post
This weekend in Houston, It seemed that everyone was having issues with motors flaming out. The track temp ranged from 125-150 and the actual temp was around 98-100. When the track temp gets that high, what are the affects on the tune?

I tried to richen the bottom end, which helped but after the straight, halfway thru the sweeper the motor would flame out. A lot of guys had the same problem.... I was running the maxy 5 port " off road" with a 6 plug and 6.5 venture. Just looking for tips to help tune when the temp gets hot. The motor seemed to work well when the track temp was under 120... when it got to 150... it kept flaming out. thanks
As the air temp gets hotter, the general rule is to lean the settings more and use colder plug. If you richen the engine settings while air temp is so high the engine will flame out due to too rich of the settings.
__________________
Andy Liu "Flyin' Hawaiian"
2015 teams/sponsors:
Serpentamerica/Desoto Racing, Murnan Modified Motors, VP powermaster Fuel, Sweep Racing USA, Speed Passion, BUKU performance products
bassman2 is offline   Reply With Quote
Old 07-06-2013, 06:23 PM   #4646
Tech Adept
 
Join Date: Sep 2010
Posts: 107
Default

Quote:
Originally Posted by choisan View Post
Anyone knows why the collari 09 is on sale for about US$250?
Any issue with this engine?
Not sure where that is on sale at, but I can't find that engine for sale.
Isn't that a Works engine from like 2004???
Hermit 713 is offline   Reply With Quote
Old 07-07-2013, 08:46 PM   #4647
X4
Tech Fanatic
 
X4's Avatar
 
Join Date: Aug 2004
Posts: 956
Trader Rating: 3 (100%+)
Default

Brand new AB Mod .21 Novarossi Keep On Pre Run in (For Sale)

Brand new AB Mod .21 Novarossi Keep On Pre Run in
X4 is offline   Reply With Quote
Old 07-07-2013, 08:46 PM   #4648
X4
Tech Fanatic
 
X4's Avatar
 
Join Date: Aug 2004
Posts: 956
Trader Rating: 3 (100%+)
Default

Brand new AB Mod .21 Novarossi Keep On Pre Run in (For Sale)

Brand new AB Mod .21 Novarossi Keep On Pre Run in
X4 is offline   Reply With Quote
Old 07-07-2013, 09:31 PM   #4649
Tech Master
 
choisan's Avatar
 
Join Date: Jul 2004
Location: San Francisco Bay Area
Posts: 1,231
Default

no, it was offered from our local distributor, it said NR is putting all factory left over parts to build up and then to fulfill the order. i didn't manage to get one.
choisan is offline   Reply With Quote
Old 07-16-2013, 05:16 PM   #4650
Tech Adept
R/C Tech Elite Subscriber
 
Join Date: Sep 2009
Posts: 116
Trader Rating: 10 (100%+)
Default

Does anyone know where I can purchase a 35plus Piston.
On the Novarossi website it has its own part#06008, so can it can be ordered/purchased by itself?
ace16 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sirio engines thread EVOLUTION Offroad Nitro Engine Forum 2824 04-29-2014 10:58 AM
Axial Engines thread Axial Racing Onroad Nitro Engine Zone 164 10-06-2008 05:48 PM
RB engines thread CraigM Nitro Off-Road 7 01-05-2008 10:57 AM
JP Engines Thread DOMOisCOOL Onroad Nitro Engine Zone 2 02-16-2004 05:00 AM
OS engines thread EVOLUTION Onroad Nitro Engine Zone 44 02-11-2004 06:28 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 03:58 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net