R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road > Onroad Nitro Engine Zone

Thread Tools Search this Thread
Old 06-26-2008, 10:35 PM   #1
Tech Rookie
Join Date: Jun 2008
Posts: 6
Default motor problems??

ok so i have a .15 traxxas stampede an the motor was pretty much locked up (I got the rig for free because of the motor being messed up) I take the motor out an start to tear it down but when i got to the block, crank an piston i couldn't figure out how to get it out there is a bearing in there that was rusted BADLY chunks of rust were in the motor, i took some light oil an just poured it in there an started working the motor over an over an cleaned out every thing. Now the motor turns over freely like brand new an the bearing has all the balls in it still an looks good should i try it??

An with this sme rig the spur gear thats attacthed to the motor spins freely is this
good? shouldn't it grab at some point? I hsve another problem with the truck, it revs high
but hardly moves
nighthawk2207 is offline   Reply With Quote
Old 06-27-2008, 12:30 PM   #2
Tech Rookie
Join Date: Jun 2008
Posts: 6
Default bump

nighthawk2207 is offline   Reply With Quote
Old 06-27-2008, 12:54 PM   #3
Tech Champion
Roelof's Avatar
Join Date: Aug 2007
Location: Holland
Posts: 5,357
Send a message via ICQ to Roelof

1) if you are sure the engine is OK again, why not give it a try?

2) Yes, the clutchbell must run free, the clutch will only engage when the engine is running a certain rpm not the clutchbell.

3) a lot of rpm and less speed can be:
a) bad clutch
b) bad (adjusted) slipper clutch (the spurgear)
c) bad gearbox. (will not shown a slipping engage)
Speed is only fiction but a 130+km/h MRS4 is for real.
Roelof is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
RC8 motor problems, can you help? H2oSprayer Nitro Off-Road 20 04-26-2008 03:39 PM
motor problems... rc pro Electric Off-Road 8 08-18-2006 06:16 AM
Motor Problems LosiSuperTruck Electric On-Road 6 09-07-2005 10:21 AM
Motor problems anthony Rookie Zone 7 11-05-2004 05:13 PM
motor problems jughead Nitro On-Road 0 11-16-2002 03:27 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 02:36 AM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0