R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road > Onroad Nitro Engine Zone

Thread Tools Search this Thread
Old 01-27-2008, 03:47 PM   #1
Tech Regular
Join Date: Jan 2008
Location: Round Rock, Texas
Posts: 295
Trader Rating: 9 (100%+)

Hoping for some help I have a Peak .12 motor that was running when i took it off my old rs4 .I put it on a drag car my friend and i built and can not get it start. Doesnt seem to matter the needle settings ,and the glow plugs are good it just wont start. what else could it be?
Roadrash730 is offline   Reply With Quote
Old 01-27-2008, 05:44 PM   #2
Tech Addict
dieseldog20's Avatar
Join Date: Dec 2007
Location: RAF Mildenhall, United States Air Force
Posts: 572
Trader Rating: 2 (100%+)
Send a message via AIM to dieseldog20 Send a message via Yahoo to dieseldog20

i am ASSUMING you are running a roto start or pull start, or even a box starter. have you checked you ignitor battery? sounds stupid but if the battery is too low it wont start. even though when you take it out to check the plug and it glows its just sometimes its not strong enough. check that if you havent. check the glow plug put a new on it. you might try tuning the motor down alittle. if it was running alittle rich you might want to lean it up just a little. thats my opinion the the subject

Good Luck
dieseldog20 is offline   Reply With Quote
Old 01-27-2008, 10:51 PM   #3
Tech Elite
rcabj's Avatar
Join Date: Feb 2004
Location: johor, west malaysia
Posts: 4,682
Trader Rating: 1 (100%+)

if out of tune the engine should at least start for a moment.


1. glow plug good/bad
2. glow heater charged
3. fuel reach the carburator
4. fuel line from tank to carb
5. pressure line from pipe to tank
6. fuel is still good.

fyi.. few weeks back i just started a motor that was left in storage for almost 2 years. after cleaning the inside and the carb... it still running.
BLacK cRoW RaCiNg TeaM
pemandu upahan ;)

Last edited by rcabj; 01-27-2008 at 10:54 PM. Reason: .
rcabj is offline   Reply With Quote
Old 01-28-2008, 09:47 AM   #4
Tech Regular
Join Date: Jan 2008
Location: Round Rock, Texas
Posts: 295
Trader Rating: 9 (100%+)

Yep I feel feel stupid!!! Thanks for the replies. Problem was the pull start broke so itook it off and put my cordless drill striat on the shaft so air was getting through the bearing I know better know put pull start back on it fired first pull
Roadrash730 is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine wont start help! Hpimichael Nitro On-Road 5 03-01-2007 10:03 PM
Engine wont start...need help !! thank you alexlai50 Nitro On-Road 8 11-11-2005 08:18 AM
trx pro. 15 engine wont start, need help... 72skylinegs Onroad Nitro Engine Zone 2 10-09-2005 12:44 AM
engine wont start 2mcgrath Nitro On-Road 3 10-06-2003 09:21 AM
Engine wont start dvargas Nitro On-Road 1 04-26-2003 10:17 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 08:43 AM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0