R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Thread Tools Search this Thread
Old 09-08-2011, 07:46 AM   #1
Tech Initiate
Join Date: May 2010
Posts: 48
Trader Rating: 2 (100%+)
Default IGT2 clutch bell/werks clutch/LRP engine - Too much free play?

I'm pretty this is too much front to back free play, but is this normal with only one shim? Seems to be a lot.

Engine is LRP.30 Spec2, clutch is Werks 34mm "Medium" Pro 4 Shoe Racing Clutch System. Clutch bell is factory Inferno GT2. Currently only using the one shim my original factory clutch had.

Can that amount even be shimmed? looks like it would take a good number of them.

apexslider is offline   Reply With Quote
Old 09-08-2011, 11:03 PM   #2
Tech Addict
Join Date: Dec 2008
Posts: 729

Looks like you're gonna have to shim it so that the shoes make full and proper contact with the bell!
Car-less (Velox V10 or 733) // RB T10.5"+" (JB Modified) // Bluebird BMS-990DMG (St) & BMS-631 (T/B) // ATS 16% // Capricorn Wheels // Protoform
"70% of the time, it works ALL the time"
DJ_Shakespear is offline   Reply With Quote
Old 09-11-2011, 11:31 AM   #3
Tech Rookie
Join Date: Jun 2011
Posts: 3

When you set the engine on the chassis what position does the gears line up at? When I set up my LRP .28 I had to shim the collar, before the flywheel, so that the gears would line up. I hope that makes sense.
sean996 is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 10:27 PM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0