R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Thread Tools Search this Thread
Old 08-04-2004, 12:58 PM   #1
Tech Rookie
Join Date: Aug 2004
Posts: 14
Default trouble with my tc3

i crashed my tc3 into my tire on my car on the exhaust manifold on my car, it bent it up pretty good along with the frame just enough to make the motor a little offset when you look down on the car. my motor fires right up and sounds like it runnin perfect but when you gas it like doesnt transfer the power it still goes but only like 5 mph and its making a whining sound? what do i need to ?
okczy21 is offline   Reply With Quote
Old 08-04-2004, 02:11 PM   #2
Tech Addict
mckrooz's Avatar
Join Date: Mar 2003
Location: Long Beach,CA
Posts: 641
Trader Rating: 7 (100%+)
Send a message via AIM to mckrooz

Wow, had to read that first sentence a couple times to understand what was going on. First off, you need to see if your chassis is bent. The shaft was probably bent too. Take everything apart and see if things are still good. Sorry, there's no easy way identify what the problem is without inspecting everything. But it's a TC3 so they're easy to get apart quick.
Kyosho RRR Evo2

Last edited by mckrooz; 08-04-2004 at 03:13 PM.
mckrooz is offline   Reply With Quote
Old 08-04-2004, 02:51 PM   #3
Tech Elite
R3VoLuTiOn's Avatar
Join Date: Jan 2004
Location: Vancouver, Canada
Posts: 2,173
Trader Rating: 24 (100%+)

im guessing the gear mesh is way messed. and that can also be whats causing the whining sound.
R3VoLuTiOn is offline   Reply With Quote
Old 08-04-2004, 03:09 PM   #4
Tech Regular
bballer's Avatar
Join Date: Nov 2003
Location: The courts of Detroit
Posts: 478

Yeah, the gears sound to be too far apart, and theyre barely touching and just chipping away at each other instead of transferring power. You should also, as stated before, check the car, other parts may need replacement
bballer is offline   Reply With Quote
Old 08-05-2004, 12:52 AM   #5
Tech Regular
MCRUZ's Avatar
Join Date: Dec 2002
Location: j-go paintz
Posts: 327

MCRUZ is offline   Reply With Quote
Old 08-05-2004, 07:46 AM   #6
Tech Master
mop_iko's Avatar
Join Date: Sep 2003
Location: JOHOR BAHRU, MALAYSIA but now working in SHANGHAI
Posts: 1,797

check everything. NO SHORTCUTS please.

i mean check EVERYTHING that relate to your DRIVETRAIN.

first is your crankshaft.
your spur
your gear
your clutch
your clutch spring
your crown gear in gearbox rear and front
your drive shaft
your dogbone
your wheel

in short... check ALL that relates to your drivetrain....

find where the whinning sound comes from.

mop_iko is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble with XXX-4 bemmermazda Electric Off-Road 4 05-24-2007 04:20 PM
having trouble pagmazdan Electric On-Road 2 05-10-2007 07:44 AM
HELP PLEASE trouble with a 4 tec emaxxracer Nitro On-Road 2 03-09-2004 12:46 AM
Having Trouble!!!!! church Buyer/Seller dispute and Feedback discussion forum 6 12-12-2003 11:12 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 11:49 AM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0