R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Thread Tools Search this Thread
Old 07-26-2010, 04:22 PM   #1
Tech Rookie
Join Date: Jul 2010
Posts: 1
Default old serpent help

Ill just get right to the point here... my dad gave me this old nitro on road car its a serpent 6000 series i dont know anything about it besides the fact that it is probably older then i am anyways it still runs and moves but i am having a problem keeping it running it will run fine untill i take the glow starter off of it i thought it could probably be the glow plug untill i bought a brand new one and it is still doing the same thing any help or things i can try would be greatly appriciated

Last edited by f4llen0n3; 07-26-2010 at 04:33 PM.
f4llen0n3 is offline   Reply With Quote
Old 07-26-2010, 06:33 PM   #2
Tech Master
Geezatec's Avatar
Join Date: Oct 2007
Posts: 1,448

Make sure the igniter has fresh batteries or Recharge battery is fully charged. Rechargeable igniter take approximately 12hours to charge.
Geezatec is offline   Reply With Quote
Old 07-26-2010, 10:59 PM   #3
Tech Elite
Wanabrc's Avatar
Join Date: May 2006
Location: Bay area, California
Posts: 4,828
Trader Rating: 70 (100%+)

It might be too rich if it won't stay on. What kind of motor does it have?
Wanabrc is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 04:11 PM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0