R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro On-Road

Thread Tools Search this Thread
Old 05-22-2004, 06:14 PM   #1
Tech Adept
Join Date: Apr 2004
Location: noVA
Posts: 195
Send a message via AIM to goldenboy
Default Engine Problem

i have the novarossi s3, and it has been running real well until now.

when ever i give the car full throttle it does what it is sopposed to, but when i press the brakes, everthing stops (wheels, gears) but the engine stay revved up, and then if i press the brakes again it will stop, and it isnt the carb because that closes the way it is sopposed to. i dont know if it is a tuning problem, or maybe something is wrong with my clutch?!? i have no idea,
goldenboy is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
engine problem what happened? Nitro Off-Road 6 11-23-2007 04:27 AM
engine problem tony montana Nitro On-Road 10 06-17-2007 06:50 PM
problem with engine longlive289s Nitro On-Road 11 05-09-2007 01:59 PM
problem with NR engine eduardo_garcia Onroad Nitro Engine Zone 0 11-06-2006 12:10 PM
engine problem bleach1 Nitro On-Road 14 03-13-2004 12:06 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 11:51 AM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0